mise en cache Vidéo HD

Raspbmc (OSMC) est une distribution Raspbian intégrant XBMC (Kodi)

Modérateur : Francois

Répondre
Bruno76133
Messages : 6
Enregistré le : dim. 17 nov. 2019 12:19

mise en cache Vidéo HD

Message par Bruno76133 » dim. 17 nov. 2019 12:25

Bonjour à tous,
Je souhaiterais réaliser une plateforme multimédia avec OSMC sur PI3 1GB.
Tout fonctionne bien avec un disque dur branché sur USB, par contre les vidéos HD de mon disque dur connecté sur ma livebox 4 (par une liaison ethernet) sont entrecoupées de « mise en cache » incessantes, j’utilise pour cela samba.
J’ai essayé de modifier la mise en cache par les lignes de commandes insérées par l’utilitaire nano du fichier « advancedsettings.xml » tant au niveau de que de mais les coupures sont toujours présentes.
Avez vous une idée?
merci d’avance

jelopo
Raspinaute
Messages : 162
Enregistré le : mer. 11 oct. 2017 10:23

Re: mise en cache Vidéo HD

Message par jelopo » dim. 17 nov. 2019 13:08

Bonjour,
tant au niveau de ... que de ...
Tu pourrais être un peu plus précis ? Sinon, tu va avoir ou pas des réponse à la boule de cristal.

A+

Bruno76133
Messages : 6
Enregistré le : dim. 17 nov. 2019 12:19

Re: mise en cache Vidéo HD

Message par Bruno76133 » dim. 17 nov. 2019 13:16

Qu'est ce que tu veux savoir de plus, si ce n'est que je peux regarder les vidéos de mon pc windows en liaison WiFi sans souci de lag et que la raspberry est connectée en Ethernet.
J'utilise osmc.

Bruno76133
Messages : 6
Enregistré le : dim. 17 nov. 2019 12:19

Re: mise en cache Vidéo HD

Message par Bruno76133 » dim. 17 nov. 2019 13:18

Network et cache entre signes d'inequation ne sont pas passées


Qu'est ce que tu veux savoir de plus, si ce n'est que je peux regarder les vidéos de mon pc windows en liaison WiFi sans souci de lag et que la raspberry est connectée en Ethernet.
J'utilise osmc.

Avatar du membre
cbalo
Raspinaute
Messages : 118
Enregistré le : sam. 24 août 2019 06:05
Contact :

Re: mise en cache Vidéo HD

Message par cbalo » dim. 17 nov. 2019 17:05

Bonjour,
Tu utilises le media center OSMC sur ton raspberry pour lire des vidéos au travers d'un portable connecté en wifi avec ton raspberry

Tu n'as pas de lag lorsque tu lis une vidéo d'un HDD branché en USB sur ton raspberry
==> donc pas de problème de "puissance" ni de mémoire ni de paramétrage des codecs sur ton Raspberry ni de wifi

Tu as des problèmes de lag si osmc tente de lire des vidéos provenant d'un HDD branché sur ta livebox
==>> C'est ta livebox qui rame soit au niveau der la connexion USB au HDD, soit au niveau du serveur de partage de fichier intégré

Donc tu cherches à augmenter le cache de OSMC
J'ai juste ?

Si oui, c'est une bonne approche.
Je ne connais pas OSMC mais tu as mis quoi comme valeurs ?
cbalo :lol: 2 Raspi3 dont 1 sous Retro Pie, l'autre pour Emby, 1 Raspi2 pour les Dev, 7 Raspi Zero

Bruno76133
Messages : 6
Enregistré le : dim. 17 nov. 2019 12:19

Re: mise en cache Vidéo HD

Message par Bruno76133 » dim. 17 nov. 2019 17:53

Tu as compris mon problème sauf que la connexion de ma pi se fait par un câble ethernet.
Je ne comprends pas pourquoi cela viendrait de la livebox car mon pc portable connecté en wifi fonctionne très bien.

J'ai ajouté les lignes suivantes


<cache>
<memorysize>157286400</memorysize>
<buffermode>4</buffermode>
<readfactor>20</readfactor>
</cache>

Bruno76133
Messages : 6
Enregistré le : dim. 17 nov. 2019 12:19

Re: mise en cache Vidéo HD

Message par Bruno76133 » dim. 17 nov. 2019 18:11

Pour info j'ai essayé une clé USB à la place du disque dur, même souci.
Le player figé l'image il marque mise en cache pendant une dizaine de secondes puis l'image est fluide 30s...

Avatar du membre
cbalo
Raspinaute
Messages : 118
Enregistré le : sam. 24 août 2019 06:05
Contact :

Re: mise en cache Vidéo HD

Message par cbalo » dim. 17 nov. 2019 19:24

La seule différence entre "problème de lag" et "pas de problème de lag" est que le périphérique est connecté en direct (USB) à la live box.
(dans tous les cas tu as le raspberry connecté à la livebox en filaire et ton portable à la boc en wifi).
Le problème ne se produit pas si tu est connecté directement au raspberry (USB)
Et le problème se produit sur plusieurs périphériques usb connecté à la livebox
Ca vient donc de la live box.

Il peut y avoir plein de raisons :
1) port usb moins performant que celui que tu as sur le raspberry
2) partage de fichier trop peu performant sur la livebox

Si j'étais dans ton cas :
- soit en jouant sur les paramètres de cache de OSMC je m'en sors (ou avec le cache d'un client vlc)
- soit pour en avoir le coeur net, je cherche à mesurer (va falloir utiliser google... je ne l'ai jamais fait) les débits d'un même périphérique vu du raspberry et connecter tantôt en direct (usb->Raspberry), tantôt via le réseau (périphérique connecté en usb à à la livebox)....sujet pas facile (je n'ai pas trouvé de doc sur internet permettant de tester les perfos d'un disque partagé)
cbalo :lol: 2 Raspi3 dont 1 sous Retro Pie, l'autre pour Emby, 1 Raspi2 pour les Dev, 7 Raspi Zero

Bruno76133
Messages : 6
Enregistré le : dim. 17 nov. 2019 12:19

Re: mise en cache Vidéo HD

Message par Bruno76133 » dim. 17 nov. 2019 20:12

Je crois que je vais devoir faire un NAS avec un autre raspberry et mon disque dur.
Pour en être sûr je pourrais partager le disque dur sur un pc équipé de Windows

Avatar du membre
cbalo
Raspinaute
Messages : 118
Enregistré le : sam. 24 août 2019 06:05
Contact :

Re: mise en cache Vidéo HD

Message par cbalo » dim. 17 nov. 2019 22:32

J'ai fais un test avec ma SFRBOX V6
Portable en wifi
Raspi 3B en filaire à la box qui est mon hot-spot wifi

La copie vers mon portable d'un gros fichier en provenance d'un HDD en usb sur le raspi, partagé par samba est bien plus rapide que la même copie du même fichier provenant du même disque mais cette fois connecté à ma SFRBOX.

Donc j'ai le même phénomène que toi.
cbalo :lol: 2 Raspi3 dont 1 sous Retro Pie, l'autre pour Emby, 1 Raspi2 pour les Dev, 7 Raspi Zero

Répondre

Retourner vers « Raspbmc (OSMC) »