[GENTOO] Pour ceux qui ont installé leur système avant 2017.

Parce qu'on ne peut pas avoir un forum pour chaque OS du Raspberry Pi...

Modérateur : Francois

Répondre
destroyedlolo
Raspinaute
Messages : 1295
Enregistré le : dim. 10 mai 2015 18:44
Localisation : Dans la campagne à côté d'Annecy
Contact :

[GENTOO] Pour ceux qui ont installé leur système avant 2017.

Message par destroyedlolo » sam. 6 juil. 2019 18:40

Bonjour,

Pour ceux qui ont installé leur Gentoo depuis très longtemps et qui bidouille pas mal, une info qui pourrait les interessés : https://www.gentoo.org/support/news-ite ... ation.html

Pour la petite histoire, j'ai plusieurs BananaPI dont un utilisé (entre autre) pour tester les Maj, mise à jour qui sont ensuite envoyée à mes autres machines en tant que BinPackages.
Sauf que là, j'essaie d'installer une nouvelle machine et c'est le drame : les ABI ont changé entre temps et le stage3 au gout du jour n'est plus compatible avec l'ancien, donc mes binpkgs.

Donc,
  • soit on réinstalle tout (et ca va prendre des plombes)
  • soit on tente le script indiqué : perso, je n'ai pas le temps actuellement, je tenterai peut etre après les vacances.
A noter aussi que POUR LE MOMENT, si vous ne faites pas d'échanges de packages entre machines, vous pouvez rester comme ca, mais les dev m'ont indiqué qu'ils ne testent plus l'anciene ABI et que certains packages (entre autre sys-devel/llvm) risque rapidement de poser pb.

Bref, espérant que ce lien évitera a d'autre de perdre leur temps comme moi :evil:

Bye
  • BananaPI : Gentoo, disque SATA de 2 To
  • Domotique : 1-wire, TéléInfo, Tablette passée sous Gentoo, ESP8266
  • Multimedia par DNLA
  • Et pleins d'idées ... et bien sûr, pas assez de temps.
Un descriptif de ma domotique 100% fait maison.

Répondre

Retourner vers « Les autres OS »