PI 3 et WIN 10 IOT

Parce qu'on ne peut pas avoir un forum pour chaque OS du Raspberry Pi...

Modérateur : Francois

gabrielle
Messages : 26
Enregistré le : ven. 17 mars 2017 12:06

PI 3 et WIN 10 IOT

Message par gabrielle » mar. 21 mars 2017 17:50

Bonjour à tous,

J'ai un Pi 3 qui apres plusieurs flash arrive enfin à déployer les exemples du dashbord ..à vrai dire étant une grande débutante certaines choses ont mis du temps.
La version de l'OS est la 14393.953.

Le remote client ne fonctionne pas malgré la case cochée dans la plateforme onglet remote et je n'arrive pas non plus à me connecter avec putty. et pour changer le mode pour certaines appli..bah c'est dommage. le message d'erreur est : ther are an issue connecting in the host..
J'ignore si c'est le mot de passe qui bugg...le nom j'ai rentré celui que j'avais donné au pi lors de la config et le MDP est également celui du pi que j'utilise pour aller sur la plateforme. j'ai tenté d'y inscrire raspberry ou bien p@ssw0rd mais non ..

si vous avez des protocoles à suivre qui permettrait de résoudre ces soucis, je suis preneuse...

n'étant pas une pro de l'informatique merci d'être très explicite svp...


Gabrielle

Bud Spencer
Raspinaute
Messages : 416
Enregistré le : lun. 15 août 2016 21:38

Re: PI 3 et WIN 10 IOT

Message par Bud Spencer » mar. 21 mars 2017 21:53

Bon, on va commencer par essayer de trouver pourquoi tu ne connectes pas.

Première chose impérative, se connecter en admin via powershell.

Tu lances IoT dashboard, puis tu fais un clic droit sur ton device puis tu sélectionnes ‘Démarrer PowerShell’.

Tu dois t’assurer que la fenêtre powershell est bien lancée en tant qu’administrateur. Si tu n’as pas ces autorisations sur ton pc de travail, pas la peine d’aller plus loin.
psh_admin.png
psh_admin.png (3.31 Kio) Vu 1208 fois
Dans ‘Nom d’utilisateur’ tu dois avoir xxx.xxx.xxx.xxx\Administrator (xxx.xxx.xxx.xxx est l'ipv4 du device correspondante à c'elle qui apparaît dans le Dashborad). Dans ‘Mot de passe’, saisies le mot de passe que tu utilises. Si cela ne fonctionne pas, essais avec le mot de passe p@ssw0rd (le 0 est un zéro, et non pas un o majuscule). Dans le doute, fait un copier/coller de p@ssw0rd. Je me souviens avoir eu une fois un problème azerty/qwerty et ça, tu ne le vois pas en saisissant le mot passe.
psh_administrator.png
psh_administrator.png (18.12 Kio) Vu 1208 fois
Une fois connectée tu dois avoir ça dans la console PowerShell (avec ton ip évidement).
psh_admin_prompt.png
psh_admin_prompt.png (6.08 Kio) Vu 1208 fois
Ensuite, essais une petite commande pour tester PowerShell. Tu saisies cette commande et tu valide par entrée : get-childitem env:
Cela doit te retourner tout un tas de valeurs (chemins, nom d’ordinateur, processeurs ect …)

Tant que tu ni arrives pas, c’est que les admin$ keys ne sont pas correct (sans doute le mot de passe) et on ne pourra pas aller plus loin. Il se peut aussi que les règles réseaux de ta boutique soient limitée ou que le compte utilisateur de ton pc ne soit pas autorisé a lancer des commandes en tant qu'admin, mais voyons déjà ou tu arrives avec tout ca.

Si tout fonctionne jusque-là, lances cette commande dans la console : schtasks.exe /query /tn \Microsoft\Windows\NanoRDP\Start /fo csv /nH

si le remote serveur est bien démarré sur le pi, cela doit te retourner un truc du genre :
"\Microsoft\Windows\NanoRDP\Start","N/A","Running"

J'attend tes résultats de tout ca pour continuer.

ps: tu peux 'copier' les commandes ici et click droit dans la console pour les 'coller'
Le premier ennemi de la connaissance n’est pas l’ignorance, c’est l’illusion de la connaissance (S. Hawking).

gabrielle
Messages : 26
Enregistré le : ven. 17 mars 2017 12:06

Re: PI 3 et WIN 10 IOT

Message par gabrielle » mer. 22 mars 2017 14:42

Bonjour, oui jusque là cava

]192.168.0.29]: PS C:\Data\Users\administrator\Documents>
[192.168.0.29]: PS C:\Data\Users\administrator\Documents> get-childitem env:

Name Value
---- -----
ALLUSERSPROFILE C:\Data\ProgramData
APPDATA C:\Data\Users\administrator\AppData\Roaming
CommonProgramFiles c:\Program Files\Common Files
COMPUTERNAME chacharasp
ComSpec C:\windows\system32\cmd.exe
LOCALAPPDATA C:\Data\Users\administrator\AppData\Local
NUMBER_OF_PROCESSORS 4
OS Windows_NT
Path C:\windows\system32;C:\windows;C:\windows\System32\Wbem;C:\windows\System32\WindowsPo...
PATHEXT .COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC
PROCESSOR_ARCHITECTURE ARM
PROCESSOR_IDENTIFIER ARM Family 7 Model D03 Revision 4, A
PROCESSOR_LEVEL 3331
PROCESSOR_REVISION 0004
ProgramData C:\Data\ProgramData
ProgramFiles c:\Program Files
PSMODULEPATH C:\Data\Users\administrator\Documents\WindowsPowerShell\Modules;c:\Program Files\Wind...
PUBLIC C:\Data\Users\Public
SystemDrive C:
SystemRoot C:\windows
TEMP C:\Data\Users\administrator\AppData\Local\Temp
TMP C:\Data\Users\administrator\AppData\Local\Temp
USERDOMAIN chacharasp
USERNAME Administrator
USERPROFILE C:\Data\Users\administrator
windir C:\windows


[192.168.0.29]: PS C:\Data\Users\administrator\Documents> schtasks.exe /query /tn \Microsoft\Windows\NanoRDP\Start /fo c
sv /nH
"\Microsoft\Windows\NanoRDP\Start","N/A","Running"
[192.168.0.29]: PS C:\Data\Users\administrator\Documents>

Bud Spencer
Raspinaute
Messages : 416
Enregistré le : lun. 15 août 2016 21:38

Re: PI 3 et WIN 10 IOT

Message par Bud Spencer » mer. 22 mars 2017 21:41

Bien. Le fait que tu connectes avec powershell nous confirme que tes admins keys sont correcte et nous permettra de voir d’autres choses plus tard.

Pour le client distant IoT essais cette procédure :
- Avant de démarrer le PI, si tu as un écran de connecté dessus, enlèves le.
- Une fois le Pi démarré, tu vas dans le Device Portal et dans le menu ‘Remote’ tu décoches ‘Enable Windows Iot Remote Server’
- Ensuite, toujours dans le device portal, tu reviens au menu ‘Home’ et tout en bas dans Display Résolution, tu sélectionnes ‘1024x768(75Hz)’ ou si cette résolution est déjà celle en cours, sélectionne en une autre plus basse (genre 1024x768(70Hz) ou plus bas) et tu réponds oui au message de reboot.
- Une fois le pi redémarré (sans avoir rebranché d’écran physique), tu retournes dans le Device Portal au menu ‘Remote’ et tu recoches la case pour activer le Remote Server.
- Après le message de confirmation, tu peux essayer de lancer le client distant Iot depuis IoT Dashboard.
- Si cela ne fonctionne toujours pas, assures toi de nouveau que le serveur est bien démarré, soit avec la commande PowerShell donnée précédemment ou simplement en allant dans le menu 'Processes' du Device Portal et en regardant si le service NanoRDPServer.exe est bien présent dans la liste. Si c'est le cas, on essayera autre chose
nanordp.png
nanordp.png (15.35 Kio) Vu 1178 fois
Sinon, vu que tu as des admin$ keys qui fonctionnent, pas de raison que tu ne puisses pas te connecter avec en ssh avec putty ou un autre client linux. Tu dois aussi pouvoir accéder aux partages administratif en entrant \\adresse_ip_du_pi\c$ dans l’explorateur de fichier de ton pc.
adm_share.png
adm_share.png (21.46 Kio) Vu 1178 fois
Si tu veux accéder au fichiers du pi en FTP, Executes la commande : start C:\Windows\System32\ftpd.exe depuis PowerShell pour démarrer le serveur ftp (non persistant mais faisable). Ensuite depuis l’explorateur de fichiers de ton pc tu peux y acceder avec l’entrée ftp://adresse_ip_du_pi
ftp.png
ftp.png (15.29 Kio) Vu 1178 fois

Bien sûr tout ça sous réserve de restrictions réseau ou firewall sur ton pc.
Le premier ennemi de la connaissance n’est pas l’ignorance, c’est l’illusion de la connaissance (S. Hawking).

gabrielle
Messages : 26
Enregistré le : ven. 17 mars 2017 12:06

Re: PI 3 et WIN 10 IOT

Message par gabrielle » jeu. 23 mars 2017 18:58

je viens juste de voir ton message désolé..le site ne m'avait rien notifié...
je fais cela ce soir..


désolé

gabrielle
Messages : 26
Enregistré le : ven. 17 mars 2017 12:06

Re: PI 3 et WIN 10 IOT

Message par gabrielle » jeu. 23 mars 2017 21:32

me revoila,
apres avoir changé la résolution, et cocher le remote à nouveau, le powershell me dit que ca roule et la commande NanoRDP est bien existante..mais le remote ne tourne pas..toujours la même erreur.

Enfin je n'arrive en effet pas à accéder en ftp au pi. j'ignore le truc réseau qui bloque..l'erreur est que j'ai mal renseigné ou bien que je n'ai pas l'autorisation d’accéder au serveur. (internet est tres lent sur ce pc, il tourne avec sa clé wifi et bon ..il est mou du cerveau..lol). D'ailleurs je n'avais pas réussi a créer l'emplacement réseau à l'époque (1 semaine)..l'acces était pour les mêmes erreur s impossible.


voilà pour les tests suivants :D

Bud Spencer
Raspinaute
Messages : 416
Enregistré le : lun. 15 août 2016 21:38

Re: PI 3 et WIN 10 IOT

Message par Bud Spencer » ven. 24 mars 2017 09:25

SI il ni avait que le problème du remote client, on pourrait faire d’autres tests le concernant, mais tant que tu n’arrives pas à avoir les autres modes d’accès, c’est qu’il y a un autre souci.

Si je récapitule, voila ce que ça donne (à confirmer)
Liste des modes d’acces au PI :

- IoT Dashboard : Ça c’est Ok, tu vois bien le PI dans la liste des devices.
- Device Portal : OK
- Powershell : OK
- Partage administratif : Marche pas
- Acces FTP : Marche pas (malgré le démarrage serveur FTP)
- SSH via PuTTy : Marche pas
- Remote client : Marche pas (malgré la présence de NanoRDPSever.exe dans la liste des process).

Perso, je vois plus un problème réseaux ou au niveau de ton pc que sur le PI.

Déjà, on considère que ton PC tourne sous Windows 10 et qu’il est correctement mis à jour et que tu ton navigateur par défaut est bien Edge.
Pour le coté réseaux. Il est préférable que le Pi soit connecté en filaire pour les accès dev et partages. Le Wifi du PI est très lent et peut poser des problèmes.
(Ces point ne sont pas impératif, mais très vivement conseillé pour éloigner les fantômes et éviter de tourner en rond le temps de trouver ce qui ne va pas)

Questions :
Les adresses IP du PI et du PC sont configurées comment ? static ? DHCP ? avec réservation ?
Est-ce que les 2 machines sont bien respectivement sur un masque réseaux commun ?
Quand tu essais d’accéder aux partages administratif du pi depuis ton PC (\\adresse_du_pi\c$ dans l’explorateur de fichier), est ce que cela te demande un nom d’utilisateur et un password ou est-ce que cela te retourne direct un message d’erreur ? si message erreur, que dit-il ?

As tu fais un essais en désactivant temporairement le firewall du PC (ca c'est pour les fantômes bloqueurs de ports) ?
Le premier ennemi de la connaissance n’est pas l’ignorance, c’est l’illusion de la connaissance (S. Hawking).

gabrielle
Messages : 26
Enregistré le : ven. 17 mars 2017 12:06

Re: PI 3 et WIN 10 IOT

Message par gabrielle » ven. 24 mars 2017 13:50

Donc ici les adresses sont automatiques
donc même masque.
le firewall non désactivé car en général c'est pas conseillé
donc je ne l'ai pas fait.

je viens de retrouver un câble donc je teste cela ce soir car je décolle(repas du samedi midi)

POur le partage admin , c'est un message d'erreur qui apparaît et je vois que l'accès au Pi est très lent jusqu'à ce que l'on me dise erreur de renseignement ou bien d'autorisation...
je tente de brancher en filaire..car c'est surement la solution et je te dis cela rapidement.

biz
Gabrielle

gabrielle
Messages : 26
Enregistré le : ven. 17 mars 2017 12:06

Re: PI 3 et WIN 10 IOT

Message par gabrielle » lun. 27 mars 2017 11:04

Bonjour du Lundi !
pour le moment en filaire ça ne marche pas. je viens de débrancher le hdmi mais bon...je me demande si le wifi gène pas.
Je regarde comment faire pour désactiver le wifi au cas où..
J'ai toujours ce même message d'erreur : there are an issus connecting to th host... :twisted:
Ce gars semble avoir le même soucis..
https://social.msdn.microsoft.com/Forum ... WindowsIoT

peux tu m'orienter pour vérifier quelques port un par un éventuellement ?
Après je peux essayer sur mon pc portable ...

Enfin dans iot dashboard, AJ soft ssid est apparu, j'ai cliqué pour faire configurer et un message d'erreur est apparu me disant : accès impossible au client distant..
Je ne sais pas pourquoi ce truc est apparu dans un premier temps, j'imagine que c'est à cause du filaire ?


Merci

Bud Spencer
Raspinaute
Messages : 416
Enregistré le : lun. 15 août 2016 21:38

Re: PI 3 et WIN 10 IOT

Message par Bud Spencer » lun. 27 mars 2017 21:14

Il y a d’autres choses à explorer pour les problèmes de connexion avec le remote client, mais tant que tu n’as pas accès aux autres protocoles, c'est qu'il y a déjà un autres soucis et ça ne sert à rien de tout bricoler.

Pour désactiver, le wifi, il suffit d’aller dans le Device Portal au menu ‘networking’ et de supprimer les profils dans la liste ‘wifi adapters’ (très simple à recréer ensuite si besoin). Tu peux aussi désactiver SoftAP et ALLJoyn dans le menu IoT Onboarding, mais ça ne changera pas grand-chose.

Pour le firewall, il est bien sur fortement déconseillé de le désactiver, mais c’est juste temporairement pour faire l’essai pour vérifier si c’est lui qui est en cause pour ensuite pouvoir résoudre les problèmes éventuels en passant au crible tous les ports requis. En plus tu es visiblement sur un réseau d’entreprise et sans doute dans un domaine AD, ce qui signifie qu’il peut y avoir des règles réseaux et des gpo qui mettent des restrictions, donc pas facile de mettre la main sur le problème.

Pour les partage réseaux $, ils sont normalement activés par défaut. Tu peux t'en assurant en ouvrant une session PowerShell (déjà vu plus haut) sur le PI et en tapant la commande net share. Tu devrais avoir en retour la liste des partages (C$, D$, IPC$ ect).

Juste pour info, j’ai fait une sd qui utilise exactement les mêmes versions que toi sur la même génération de PI et je n’ai aucun problème ni en filaire, ni en wifi pour aucun des modes d’accès depuis mon pc sous Windows 10. J'arrive même à me connecter sans problème au Device Portal en http mais aussi en ssh et en ftp depuis une vm linux et même depuis mon phone Android en wifi.
Le premier ennemi de la connaissance n’est pas l’ignorance, c’est l’illusion de la connaissance (S. Hawking).

Répondre

Retourner vers « Les autres OS »