jpeg segmenté

Pour les questions sur la PiCamera et les modèles compatibles

Modérateur : Francois

Répondre
bibi
Messages : 2
Enregistré le : mer. 31 déc. 2014 16:23
Localisation : Alsace

jpeg segmenté

Message par bibi » mer. 31 déc. 2014 17:58

Bonjour,

je possède une framboise modèle B avec un module camera et je lutte pour obtenir des images correctes avec l utilitaire raspistill. La commande raspistill s execute sans message d erreur et me fourni un fichier jpeg...jusque la tout va bien MAIS ce fichier jpeg n est pas vraiment utilisable car segmenté... (cf image jointe)

j observe le meme probleme avec mes 2 autres framboises et avec des cameras différentes... :cry:

l environnement:

utilisation via ssh et ftp uniquement (connection en rj45)

uname -a: Linux raspberrypi 3.12.35+ #730 PREEMPT Fri Dec 19 18:31:24 GMT 2014 armv6l GNU/Linux

vcgencmd version
Dec 29 2014 14:23:10
Copyright (c) 2012 Broadcom
version d3c15a3b57203798ff811c40ea65174834267d48 (clean) (release)

la commande:
pi@raspberrypi ~ $ raspistill -v -n -w 1280 -h 960 -o bibi.jpg

raspistill Camera App v1.3.8

Width 1280, Height 960, quality 85, filename bibi.jpg
Time delay 5000, Raw no
Thumbnail enabled Yes, width 64, height 48, quality 35
Link to latest frame enabled no
Full resolution preview No
Capture method : Single capture

Preview No, Full screen Yes
Preview window 0,0,1024,768
Opacity 255
Sharpness 0, Contrast 0, Brightness 50
Saturation 0, ISO 0, Video Stabilisation No, Exposure compensation 0
Exposure Mode 'auto', AWB Mode 'auto', Image Effect 'none'
Metering Mode 'average', Colour Effect Enabled No with U = 128, V = 128
Rotation 0, hflip No, vflip No
ROI x 0.000000, y 0.000000, w 1.000000 h 1.000000
Camera component done
Encoder component done
Starting component connection stage
Connecting camera preview port to video render.
Connecting camera stills port to encoder input port
Opening output file bibi.jpg
Enabling encoder output port
Starting capture 0
Finished capture 0
Closing down
Close down completed, all components disconnected, disabled and destroyed


Le resultat
bibi.jpg
bibi.jpg (658.7 Kio) Vu 1180 fois
Est ce que qqun a déjà observé ce genre de problème ?

Merci pour votre aide!

Benoit
«Le progrès ne vaut que s'il est partagé par tous»

bibi
Messages : 2
Enregistré le : mer. 31 déc. 2014 16:23
Localisation : Alsace

Re: jpeg segmenté

Message par bibi » jeu. 1 janv. 2015 08:59

J ai trouvé la cause de mes soucis :D
La corruption des fichiers jpeg est due aux transferts via wput, en activant le transfert en mode binaire l intégrité des fichiers est conservée!
«Le progrès ne vaut que s'il est partagé par tous»

Avatar du membre
vague nerd
Modérateur
Messages : 1465
Enregistré le : mar. 14 oct. 2014 11:42
Localisation : France !

Re: jpeg segmenté

Message par vague nerd » jeu. 1 janv. 2015 14:47

Ok, super.

Si vous estimez que votre problème est résolu, merci d'ajouter [RESOLU] au début du titre du sujet.
Pour ce faire, visualiser le premier Post que vous avez réalisé, cliquez sur "Editer", et ajouter [RESOLU] devant le titre.

Cela permet que le message soit tout de suite identifié comme ayant eu une réponse correspondant à la demande.
Ainsi, les visiteurs en sont informés, aussi bien lors d'une recherche sur le forum qu'au travers des moteurs de recherche.

Merci d'avance !

Cordialement.
Cordialement,

Vague Nerd

Répondre

Retourner vers « Le module caméra et ses clones »