Shield (hat) Adafruit pour commande Moteur stepper problème

Envie d'ajouter des fonctions à votre Raspberry Pi ? Faites un tour sur ce forum...

Modérateur : Francois

Khov
Messages : 1
Enregistré le : mer. 14 juin 2017 13:45

Shield (hat) Adafruit pour commande Moteur stepper problème

Messagepar Khov » mer. 14 juin 2017 13:48

Bonjour à tous,

Je suis nouveau sur Raspberry. J'essaie de contrôler un moteur NEMA 17 (modèle mt 1704hs168a) avec le shield de Adafruit visible sur le lien suivant https://learn.adafruit.com/adafruit-dc- ... i/overview.

J'ai bien suivi tout le tutoriel https://learn.adafruit.com/adafruit-dc- ... per-motors et je n'ai rien modifié au code .

Mon problème vient au moment où je compile ce programme. Le NEMA tourne par saccade, et encore tourner est un bien grand mot. J'ai vérifié les branchements, comme indiqué sur la datasheet (http://www.motechmotor.com/products_det ... =70&page=1) j'ai branché les fils bleu et rouge sur le M1 du shield de Adafruit, et les fils vert et noir sur le M2. J'ai essayé d'inverser les fils bleu et rouge pour voir si le problème venait de là mais pas de différence.

Aussi, l'alimentation que j'utilise sur le shield est une alim de PC 12V 5A, donc pas de souci au niveau de l'alim.

Voilà, si l'un d'entre vous peut me débloquer c'est vraiment sympa !

Bonne journée à tous,

spourre
Raspinaute
Messages : 573
Enregistré le : lun. 22 déc. 2014 17:50
Localisation : 67380 LINGOLSHEIM

Re: Shield (hat) Adafruit pour commande Moteur stepper problème

Messagepar spourre » mer. 14 juin 2017 14:12

Bonjour,

N'ayant pas l même matériel, je ne peux faire qu'une réponse de principe.
Il manque pas mal d'éléments pour apporter une réponse précise:

- Type du Raspberry.
- Version du système d’exploitation

en admettant que tout est correct (brochage, programmes..), le symptôme évoque une surcharge du processeur.
Savez-vous ouvrir un terminal et pouvez-vous passer la commande toip pour voir la charge du processeur et un éventuel swapp ?

Ajout:
Après lecture détaillé des caractéristiques du hat, en particulier de ce point:
Since the Raspberry Pi does not have a lot of PWM pins, we use a fully-dedicated PWM driver chip onboard to both control motor direction and speed. This chip handles all the motor and speed controls over I2C. Only two GPIO pins (SDA & SCL) are required to drive the multiple motors, and since it's I2C you can also connect any other I2C devices or HATs to the same pins.


Je ne pense pas qu'une charge CPU excessive soit la cause du problème. La carte embarque sont propre driver PWM et l'I2C ne sert qu'à envoyer les ordres.
Je laisse l'intégralité de ma première réponse pour la lisibilité de l'ensemble.
Modifié en dernier par spourre le jeu. 15 juin 2017 16:48, modifié 1 fois.

guillaume9344
Raspinaute
Messages : 616
Enregistré le : mar. 6 janv. 2015 20:44
Localisation : finistere

Re: Shield (hat) Adafruit pour commande Moteur stepper problème

Messagepar guillaume9344 » mer. 14 juin 2017 18:32

Bonsoir , dans le datasheet du moteur , il est spécifier "tension recommandé: 12-24v" alors que la hat alimente au max les moteurs en 12v, je pense que vos nema sont légèrement sous alimentés d'ou l'effets de saccade.
@+
rpi b+ ,osmc, motioneyes
rpi 2 raspbian , server minecraft 24h/24 , utilisation gpio
orange pi pc debian ,utilisation gpio, motion cam

romaxx
Messages : 78
Enregistré le : lun. 24 oct. 2016 10:59

Re: Shield (hat) Adafruit pour commande Moteur stepper problème

Messagepar romaxx » jeu. 15 juin 2017 14:39

Si tu as un oscillo, mesure les 4 tensions (avec une sonde diviseur de tension) que tu as en sortie de ta carte, c'est la seule approche rapide et fiable.
Si tu n'a pas d'oscillo :o , ça doit être ton premier projet, bien avant de vouloir piloter un moteur PaP. Un bricoleur électronicien digne de ce nom doit avoir les outils de base pour bien travailler:
un multimètre, un oscillo, une alimentation stabilisée (et pas une alim à découpage de PC qui ne te permet, ni de limiter le courant, ni de te fournir une tension sans harmoniques).

Sinon tu peux toujours passer des heures à essayer de bidouiller le code dans tous les sens, parfois ça marche..
--
Adhérent à l'A.F.S.T.L


Retourner vers « Les cartes d'extension pour le Raspberry Pi Model A et B »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité