Nouvelle carte X850 V3.0 suptronic

Pour en savoir plus sur les cartes réservées au Raspberry Pi Model B+, en particulier les cartes HAT

Modérateur : Francois

Répondre
Swson
Messages : 4
Enregistré le : mar. 20 nov. 2018 13:25

Nouvelle carte X850 V3.0 suptronic

Message par Swson » mar. 20 nov. 2018 13:31

Bonjour, j’ai un phénomène curieux lorsque le bridge USB de la carte est installé, je n’ai plus de wifi, l’icone En haut à droite indice 2 croix rouges et indique eth0: link is down et wlan0: not associated
Sans le bridge, le wifi se connecte directement à mon réseau sans problèmes une idée ?

Merci

Artemus24
Raspinaute
Messages : 231
Enregistré le : ven. 15 sept. 2017 19:15

Re: Nouvelle carte X850 V3.0 suptronic

Message par Artemus24 » jeu. 22 nov. 2018 13:45

Salut Swson.

Je suppose que vous parlez de ceci, la SupTronics X850 qui est une carte d'extension mSATA pour utiliser un ssd externe.
Et ce que vous appelez bridge est en fait un cavalier (USB Jumper en anglais), qui va se brancher sur la prise usb aussi bien du SupTronics X850 que sur le raspberry comme on peut le voir ci-dessous :

Image

Avez-vous utilisé la documentation en ligne : http://www.raspberrypiwiki.com/index.php/X850

Quelle version de la raspberry Pi utilisez-vous ?

Est-ce que vous avez configuré le wifi dans votre raspberry ?
Utilisez-vous une adresse fixe définie dans le dhcp de la box ou bien une adresse dynamique ?

D'après ce que j'ai pu comprendre, vous accédez en utilisant le bureau de la raspberry et non en ligne de commande.
Quand votre SupTronics X850 est installé, que donne la commande "ifconfig -a" ?

@+
--> Rpi0WH, Rpi2B, Rpi3A+, Rpi3B+
--> Tuner TV HAT

Swson
Messages : 4
Enregistré le : mar. 20 nov. 2018 13:25

Re: Nouvelle carte X850 V3.0 suptronic

Message par Swson » jeu. 22 nov. 2018 18:26

Bonjour

Pas du tout celle ci est la V1.2 ou 1.3 je parle de la V3.0 (voir new à gauche sur la page d’accueil de Suptronic) c’est une carte qui se monte sous le RB pas dessus.
Depuis ma question j’ai progressé j’ai découvert que le wifi 2.4 fonctionne si la carte n’est pas alimentée (pas de pont USB ni d’alim) mais avec le pont le wifi 2.4 ne marche plus mais le wifi 5Ghz oui! Donc je pense qu’il y a un problème de compatibilité EM entre la carte et le raspberry....
Il faudrait que j’intercale un isolant entre les’deux Pour voir. En attendant je travaille en 5Ghz
Ce qui est quand même curieux c’est que si je mets le pont USB après avoir démarré le RB et obtenu donc du wifi2.4 celui ci reste actif après que la carte ai démarré . Bien sur ce test a été fait avec la carte SD comme boot, maintenant que j’ai retiré la SD je dois mettre le pont au démarrage pour boiter sur le SSD donc plus possible de faire ça .

Artemus24
Raspinaute
Messages : 231
Enregistré le : ven. 15 sept. 2017 19:15

Re: Nouvelle carte X850 V3.0 suptronic

Message par Artemus24 » jeu. 22 nov. 2018 20:49

Salut swson.
swson a écrit :Pas du tout celle ci est la V1.2 ou 1.3 je parle de la V3.0
En effet, vous avez raison, il s'agit bin de la version 1.2.

Image

J'ai suivi votre conseil et voici l'extension suptronics x850 v3.0 :
--> http://www.suptronics.com/miniPCkits/x850_v3.0.html

Avez-vous lu comment configurer votre raspberry : http://www.suptronics.com/miniPCkits/x8 ... tware.html
Il s'agit de transformer votre raspberry afin de pouvoir booter sur le disque SSD, sans passer par la carte micro SD.
swson a écrit :c’est une carte qui se monte sous le RB pas dessus.
Oui, c'est ce que j'ai constaté :

Image
swson a écrit :maintenant que j’ai retiré la SD je dois mettre le pont au démarrage pour boiter sur le SSD donc plus possible de faire ça .
Si vous avez retiré la carte micro SD, vous pouvez maintenant démarrer votre rapsberry sur le disque SSD.

Avez-vous configuré le wifi dans votre disque SSD ? Je parle bien sur du fichier "/etc/wpa_supplicant/wpa_supplicant.conf".
Si vous ne l'avez pas fait, il est normal de ne pas avoir le wifi.
Exemple :

Code : Tout sélectionner

country = fr
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update-config = 1

network={
    ssid="celui de votre box"
    psk="mot de passe de votre box"
    id_str="un libellé de votre choix, par exemple 'maison'"
    priority=1
}
"Priority", c'est en cas de choix multiple. Celui qui aura la pririté la plus petite (1) sera pris en premier.

Autre chose, avec la version "stretch", j'ai ajouté dans le fichier "/boot/cmdline.txt", en fin de ligne :

Code : Tout sélectionner

net.ifnames=0"
Ceci permet d'utiliser les interfaces "eth0" et "wlan0", aulieu des adresses MAC.

(j'ai fait cela de mémoire, donc à vérifier).
swson a écrit :j’ai découvert que le wifi 2.4 fonctionne si la carte n’est pas alimentée (pas de pont USB ni d’alim) mais avec le pont le wifi 2.4 ne marche plus mais le wifi 5Ghz oui!
Si vous avez à la fois le 2.4Ghz et le 5Ghz, c'est que vous êtes en 802.11N, voire peut-être le 802.11AC.

Quand vous avez démarré votre raspberry, sans carte micro SD, qu'est-ce que vous obtenez par cette commande "ifconfig -a" ?

@+
--> Rpi0WH, Rpi2B, Rpi3A+, Rpi3B+
--> Tuner TV HAT

Swson
Messages : 4
Enregistré le : mar. 20 nov. 2018 13:25

Re: Nouvelle carte X850 V3.0 suptronic

Message par Swson » ven. 23 nov. 2018 16:11

Oui le RB démarre sans pb sur le SSD et le fichier supplicant est configuré pour le 2.4 et le 5 mais il démarre avec le 5 maintenant
Le if config - a est normal j’ai eth0 up broadcast multicast mais je n’ai pas branché la rj45, Lo up loop back running et wlan0 up broadcast running multicast
Par contre si je change de réseau dans l’interface graphique en haut à droite pour passer sur le 24 ça coince avec 2 croix rouges.....peut être il faudrait que je déconnecte le BT ou que je change de canal wifi faut que je vois ça demain

Répondre

Retourner vers « Les cartes d'extension pour le Raspberry Pi Model B+ »