Problème de lecture d'un LSM9DS1 en I2C

Des infos, des conseils sur les bus DSI,CSI, I2C, SPI... du Raspberry Pi

Modérateur : Francois

spourre
Raspinaute
Messages : 602
Enregistré le : lun. 22 déc. 2014 17:50
Localisation : 67380 LINGOLSHEIM

Re: Problème de lecture d'un LSM9DS1 en I2C

Messagepar spourre » mer. 15 mars 2017 13:42

Pinhapple a écrit :Je ne pense pas avoir votre niveau en RPi et autres, mais si je peux aider, même en vous faisant des retours sur mon projet de mon côté, n'hésitez pas ! ;)


Je pense qu'il sera intéressant pour tous ceux qui suivent cette discussion, même sans y participer, d'avoir un retour sur votre solution.
Je, l'ai déjà dit mais il y a toujours à apprendre. Même un débutant peut avoir une approche innovante parce que, par définition, il n'est pas encore prisonnier d'un mode de pensé ou d'une routine
J'espère que votre établissement à un laboratoire digne de ce nom et que vous pourrez nous donner de précieuses indications sur le comportement du Raspberry en charge et en tenue des signaux (on a déjà parlé de la dégradation de l'horloge SPI et Bud a fait état de problèmes avec le fast I2C).

A+

Sylvain

Bud Spencer
Raspinaute
Messages : 296
Enregistré le : lun. 15 août 2016 21:38

Re: Problème de lecture d'un LSM9DS1 en I2C

Messagepar Bud Spencer » mer. 15 mars 2017 21:33

[hors sujet][humour]
spourre a écrit :Ça ne devrait pas te surprendre, mais je partage ton point de vue ...

Tout a fait entre nous, si il y a bien encore une chose qui peut me surprendre ici, c'est bien qu'il y ait des gens qui puissent partager mon avis :lol:
[/hors sujet][/humour]

Pinhapple a écrit :Par contre, avoir modifié le baudrate doit gêner l'ATTINY88 qui pilote la matrice de DEL et le joystick, puisque ceux-ci ne sont plus utilisables avec l'API Sense HAT, et impossible d'y accéder en I2C à son adresse 0x46 (le i2cdetect -y 1 indique UU à cette adresse, ce qui indique apparemment qu'elle est déjà occupée)... :?

C'était écrit aussi ca ;) . J'essais en vain de retrouver un excellent article que j'avais trouvé sur le sujet et je ne manquerais pas de linker au cas ou ma recherche aboutirait. Par contre j'ai retrouvé celui la concernant les isr winring-pi : https://sites.google.com/site/hamlinhom ... rry-pi-isr

Pinhapple a écrit :Je ne pense pas avoir votre niveau en RPi et autres ...

Ne t'inquiète pas, tu nous dépasseras bien plus vite que nous n'avons appris. Dis toi juste que plus tu en sauras et plus les problèmes que tu te poseras seront compliqué à résoudre (scio me nihil scire ;) )

spourre
Raspinaute
Messages : 602
Enregistré le : lun. 22 déc. 2014 17:50
Localisation : 67380 LINGOLSHEIM

Re: Problème de lecture d'un LSM9DS1 en I2C

Messagepar spourre » jeu. 16 mars 2017 00:32

Bud Spencer a écrit :...
C'était écrit aussi ca ;) . J'essais en vain de retrouver un excellent article que j'avais trouvé sur le sujet et je ne manquerais pas de linker au cas ou ma recherche aboutirait. Par contre j'ai retrouvé celui la concernant les isr winring-pi : https://sites.google.com/site/hamlinhom ... rry-pi-isr
...


:twisted:

C'était aussi écrit ici:
http://www.framboise314.fr/i2c-plus-de- ... actualite/

NOSTAGIE ON
C'est bien le problème avec Internet, on finit par ne plus retrouver ce dont on a besoin, au moment où on en a besoin.
Un bon bouquin en vrai papier, avec plein de post-it, c'est plus pratique.
NOSTAGIE OFF

Pour l'ISR, C'est dommage que l'article (et le kernel) date de 2013. Dans ce domaine, c'est une éternité et , comme le précise l'auteur, l'API a été modifiée. 9a donne néanmoins un bon point de départ. Le sujet RT a été abordé dans un OpenSilicium.
si Pinhapple veut se lancer dans l'étude de la latence ,en user land ou dans le noyau, il ne faudra pas oublier de stresser le Raspberry (il y a des outils pour cela).

Sylvain

Pinhapple
Raspinaute
Messages : 125
Enregistré le : jeu. 23 févr. 2017 16:53
Localisation : Rouen

Re: Problème de lecture d'un LSM9DS1 en I2C

Messagepar Pinhapple » lun. 4 déc. 2017 15:22

Bonjour à tous,

Comme promis, mes retours concernant toutes mes questions à propos de mon stage, bien qu'avec un peu de retard.

Pour la première application (mesure de rotation, d'orientation, et d'accélération avec un Sense HAT), mon maître de stage et moi avons établi que ce n'était pas possible avec le matériel imposé à ma disposition ; l'idée était d'avoir un outil de mesure compact et bon marché, d'où le choix du combo RPi/Sense HAT. Malheureusement, on en demandait beaucoup au matériel (besoin d'une précision au millième de degré), et si le raisonnement et la démarche pour obtenir les résultats étaient corrects, ceux-ci étaient déformés par la dérive, cette dernière étant d'autant plus amplifiée que les résultats étaient serrés.

En ce qui concerne la seconde application, je n'ai pas obtenu un programme fonctionnel, mais j'ai néanmoins dégrossi le sujet afin d'éliminer des pistes : l'ethernet capricieux qui fonctionne quand bon lui semble, le serial trop lent même si on augmente sa vitesse, l'I2C trop lent, etc. Je pense que mesurer avec l'Arduino est suffisant et que transférer au RPi est une contrainte supplémentaire (pour rappel, environ 244 µs entre deux impulsions, donc un peu moins pour s'occuper du traitement des données).

Ma soutenance a eu lieu, j'ai pu mettre en avant le détail pour chaque sujet, et c'est mon maître de stage qui a bien insisté sur le fait que je n'ai pas travaillé pour rien : ce qui est fait n'est plus à faire, donc un éventuel prochain stagiaire pourra partir sur mes bases. Il a également souligné que j'avais "une mauvaise tolérance à l'échec", et que je prenais les choses trop personnellement : j'aurais dû l'alerter de mes difficultés et on aurait avisé. Bref, un bon stage dans l'ensemble malgré une petite baisse de motivation sur la fin.

J'ai reçu le fameux courrier il y a quelques semaines : je suis diplômé. :D

Voilà pour les nouvelles ! Merci encore à ceux qui m'ont aidé, c'était très apprécié. Bonne continuation à tous, à la prochaine sur le forum ! ;)
  • RPi 3 + RetroPie ; RPi 3 + Sense HAT ou Framboisedorf ; RPi B+ + OpenELEC
  • Arduino Mega, Uno, Nano
  • FRDM KL25Z

destroyedlolo
Raspinaute
Messages : 1047
Enregistré le : dim. 10 mai 2015 18:44
Localisation : Dans la campagne à côté d'Annecy
Contact :

Re: Problème de lecture d'un LSM9DS1 en I2C

Messagepar destroyedlolo » lun. 4 déc. 2017 15:58

Et bien félicitation pour ton diplôme et surtout merci pour le retour.

De toutes façons, on apprend tout autant (parfois plus) dans l'échec :)

A+
  • BananaPI : Gentoo, disque SATA de 2 To
  • Domotique : 1-wire, TéléInfo, Tablette passée sous Gentoo, ESP8266
  • Multimedia par DNLA
  • Et pleins d'idées ... et bien sûr, pas assez de temps.
Un descriptif de ma domotique 100% fait maison.

spourre
Raspinaute
Messages : 602
Enregistré le : lun. 22 déc. 2014 17:50
Localisation : 67380 LINGOLSHEIM

Re: Problème de lecture d'un LSM9DS1 en I2C

Messagepar spourre » lun. 4 déc. 2017 20:52

Pinhapple a écrit :
Voilà pour les nouvelles ! Merci encore à ceux qui m'ont aidé, c'était très apprécié. Bonne continuation à tous, à la prochaine sur le forum ! ;)


Bien content d'avoir de tes nouvelles et merci d'avoir pensé à les partager.
On avait bien constaté que tu étais très motivé et pugnace. Comme je l'avais souligné, ceci nous a conforté dans le désir de t'aider.
Tu peux le constater facilement, peu de fils de discussion ont atteint ce volume et ce nombre de lectures.

Sylvain


Retourner vers « Les BUS interfaces »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité