PB I2C sous Ubuntu Mate

Des infos, des conseils sur les bus DSI,CSI, I2C, SPI... du Raspberry Pi

Modérateur : Francois

Répondre
Nicouille83
Messages : 5
Enregistré le : mer. 18 mai 2016 10:40

PB I2C sous Ubuntu Mate

Message par Nicouille83 » mer. 18 mai 2016 11:01

Bonjour tous,
j'essaye actuellement, dans le cadre d'un projet, de faire fonctionner ma liaison I2C sur ma RPI sous Ubuntu Mate.

Aucun retex à ce sujet sur le net ne résout mon problème ; il se trouve que beaucoup utilisent vraisemblablement Raspian...

I2C tools installé, la commande "i2C-detect" me retourne :
"Error: Could not open file `/dev/i2c-0' or `/dev/i2c/0': No such file or directory"

effectivement aucun répertoire du type "i2c qqchose" ne se trouve sous /dev.

la commande lsmod me sort bien :
i2c_bcm2708 5006 0
i2c_dev 6108 0

ce qui me fait penser que les pilotes seraient bien montés.

J'ai passé sur "on" dans /boot/config.txt les lignes
#dtparam=i2c_arm=on

J'ai également ajouté dans le fichier /etc/modules-load.d/modules.conf les lignes
i2c-dev
i2c-bcm2708

Besoin d'aide, merci,

Avatar du membre
Manfraid
Modérateur
Messages : 1401
Enregistré le : ven. 3 oct. 2014 14:50
Contact :

Re: PB I2C sous Ubuntu Mate

Message par Manfraid » mer. 18 mai 2016 11:14

Salut avant le dtparam il faut supprimer le #
NAS : DIY OS Debian: DD250Go + 3x2To + 6To
Raspberry pi : 2B OS : Raspbian
Se tromper est humain, Vraiment foutre la merde nécessite le mot de passe de root.

Avatar du membre
vague nerd
Modérateur
Messages : 1469
Enregistré le : mar. 14 oct. 2014 11:42
Localisation : France !

Re: PB I2C sous Ubuntu Mate

Message par vague nerd » mer. 18 mai 2016 11:15

#dtparam=i2c_arm=on
Attention, le '#' signifie que la ligne est commentée.
Cdt.

EDIT : battu par manfraid !

Edit 2 : Bonjour sinon, dsl !
Cordialement,

Vague Nerd

Nicouille83
Messages : 5
Enregistré le : mer. 18 mai 2016 10:40

Re: PB I2C sous Ubuntu Mate

Message par Nicouille83 » mer. 18 mai 2016 18:40

AAArrrffffff.

Mille mercis !

Comment passer pour un noob en quelques lignes.
C'était si simple !

Je remercie le seigneur d'avoir mis autant d'imbécilité dans un seul homme.

Pour les débutants qui me liraient :
ce fichier contient des commentaires précédés de 2 #.
Je pensais que 1 seul # n'était plus un commentaire.

Il faut effectivement aucun # pour activer les fonctions.

Merci

Répondre

Retourner vers « Les BUS interfaces »