Accéléromètre LSM303D non détecté

Des infos, des conseils sur les bus DSI,CSI, I2C, SPI... du Raspberry Pi

Modérateur : Francois

Répondre
29manu29
Messages : 3
Enregistré le : sam. 17 janv. 2015 11:15

Accéléromètre LSM303D non détecté

Message par 29manu29 » sam. 17 janv. 2015 11:48

Bonjour,

Je me casse les dents depuis un petit moment sur le problème suivant :
J'ai un module minimu9 V3 (accéléromètre LSM303D + Gyroscope L3GD20H) que je connecte à non Raspberry PI 512Mo via la liaison I2C.
J'ai connectémon module comme décrit dans ce lien https://github.com/DavidEGrayson/minimu9-ahrs/wiki
lorsque j'exécute la commande i2cdetect -Y 1 j'obtiens le résultat suivant :
0 1 2 3 4 5 6 7 8 9 a b c d e f
00: -- -- -- -- -- -- -- -- -- -- -- -- --
10: -- -- -- -- -- -- -- -- -- -- -- UU -- -- -- --
20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
40: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
50: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
60: -- -- -- -- -- -- -- -- -- -- -- 6b -- -- -- --
70: -- -- -- -- -- -- -- --
L'@ 6b correspond bien au gyroscope et l'accéléromètre devrait être détecté à l'@ 1d. Pensant que le module était HS je l'ai renvoyé au fournisseur qui l'a testé sur un Arduino et ça fonctionne parfaitement. Dans le doute il m'a renvoyé un nouveau module et le résultat est le même. Le module n'étant pas en cause je suppose que c'est un problème de configuration de Raspbian.
Ci-dessous le contenu du fichier /etc/modprobe.d/raspi-blacklist.conf :
# blacklist spi and i2c by default (many users don't need them)

blacklist spi-bcm2708
blacklist i2c-bcm2708
blacklist snd-soc-pcm512x
blacklist snd-soc-wm8804

et du fichier /etc/modules
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.
# Parameters can be specified after the module name.

snd-bcm2835
i2c-bcm2708
i2c-dev

Si quelqu'un a une piste je suis preneur.

Manuel

Avatar du membre
vague nerd
Modérateur
Messages : 1464
Enregistré le : mar. 14 oct. 2014 11:42
Localisation : France !

Re: Accéléromètre LSM303D non détecté

Message par vague nerd » sam. 17 janv. 2015 16:21

Bonjour.
Juste une typo (vous avez lancé la bonne commande, mais faute de frappe ici) :

Code : Tout sélectionner

i2cdetect -y 1
plutôt que
i2cdetect -Y 1
Bizard comme symptôme. J'ai pensé un instant qu'il n'y avait qu'un device i1c et non deux, mais la doc le dit clairement
should contain two or three hex numbers, representing the addresses of I²C devices that were detected on the bus.
.
Avez vous bien vérifier 10 fois les droits (chapitre Device permissions) ? Peut-être qu'un seul device à les bonnes permissions...

Cdt.
Cordialement,

Vague Nerd

29manu29
Messages : 3
Enregistré le : sam. 17 janv. 2015 11:15

Re: Accéléromètre LSM303D non détecté

Message par 29manu29 » sam. 17 janv. 2015 20:56

Bonsoir,

Merci pour votre réponse.

Voici le résultat issu de la commande ls -l /dev/i2* :

ls -l /dev/i2*
crw-rw---T 1 root i2c 89, 1 janv. 17 10:42 /dev/i2c-1

Le group est bien i2c comme mentionné dans la doc

Manuel

Avatar du membre
vague nerd
Modérateur
Messages : 1464
Enregistré le : mar. 14 oct. 2014 11:42
Localisation : France !

Re: Accéléromètre LSM303D non détecté

Message par vague nerd » sam. 17 janv. 2015 22:05

Ok, mais votre utilisateur est-il bien dans ce groupe ?
Je pense que c'est l'objet de cette commande du tuto.

Code : Tout sélectionner

sudo usermod -a -G i2c `whoami`
Cordialement,

Vague Nerd

29manu29
Messages : 3
Enregistré le : sam. 17 janv. 2015 11:15

Re: Accéléromètre LSM303D non détecté

Message par 29manu29 » dim. 18 janv. 2015 10:23

Bonjour,

J'ai vérifié l'utilisateur sous lequel je suis logué appartient bien au groupe i2c.

Manuel

Répondre

Retourner vers « Les BUS interfaces »