[RESOLU] Problème alimentation console portable

Sujet sensible sur le Raspberry Pi, retrouvez ici les questions relatives aux alimentations utilisées

Modérateur : Francois

anachris
Messages : 17
Enregistré le : dim. 11 oct. 2015 17:34

[RESOLU] Problème alimentation console portable

Messagepar anachris » ven. 13 oct. 2017 14:17

Hello!
Voici un petit soucis que je rencontre.
Je suis en train de réaliser une console portable, sur batterie.
J'ai installé un pi3 , avec dessus recalbox, et un écran "officiel" 7 pouces (j'ai viré la partie tactile qui ne me sert pas).
J'alimente le tout avec un powerboost 1000c. Mon soucis est qu'un éclair apparaît et clignote en haut a droite de l'écran sous recalbox.
Après quelques recherches sur les forums j'ai appris que cela est dû à un soucis d'alimentation.
Mon transfo est un 5v 2500ma.
Il alimente le powerboost, et sur la sortie 5v usb du powerboost j'ai branché l'alim de l'écran ainsi que l'alimentation du raspberry.
Si je branche deux transfo, un pour le raspberry et un pour l'écran pas de pb.
Mais avec mon installation toujours l'éclair qui apparaît.
Le powerboost sort bien du 5V, mais je me demande si l'ampérage suffit à l'ensemble du système (sachant que j'ai également un ampli 8403 audio à brancher sur le 5V!).
Si je branche l'ampli audio cela fonctionne toujours, éclair qui clignote toujours, mais si je monte trop le son le système crash et redémarre. Je pense donc à un soucis d'alim.
Si quelqu'un a déjà eu le soucis help svp!!!!!!!!
Modifié en dernier par anachris le lun. 30 oct. 2017 12:07, modifié 1 fois.

Jojo
Messages : 25
Enregistré le : ven. 29 sept. 2017 11:49
Localisation : Pays De La Loire

Re: Problème alimentation console portable

Messagepar Jojo » ven. 13 oct. 2017 14:52

Salut,

Au vu de ce que tu dis je pense effectivement que l'ampérage est trop faible.
La fondation recommande 2A pour l'alimentation de la RPi + l'écran officiel donc ça me paraît limite surtout avec ton ampli dessus.
Si j'en crois ce que j'en vois sur internet ton ampli demande 5V et 3W ce qui nous fait du 600mA. Soit plus que 1,9 A pour le couple RPi / écran.
anachris a écrit :Si je branche l'ampli audio cela fonctionne toujours, éclair qui clignote toujours, mais si je monte trop le son le système crash et redémarre. Je pense donc à un soucis d'alim.

Je pense que le système est juste "limite" pour s'allumer quand l'ampli ne consomme que peu de puissance. Par contre dès que tu en demandes plus, il se met à "tirer" sur l'alimentation ce qui fait que ton système RPi + écran n'a plus assez de jus pour fonctionner.
anachris a écrit :Le powerboost sort bien du 5V, mais je me demande si l'ampérage suffit à l'ensemble du système (sachant que j'ai également un ampli 8403 audio à brancher sur le 5V!).

Tu le le branches via le powerboost ? Peu de chances que celui-ci puisse sortir du 5v/2,5 A.

Je suis loin d'être expert mais je pense que le problème vient de là.

A+
"Il ne faut jamais remettre au lendemain ce que l'on peut faire le surlendemain." ~ Alphonse Allais

anachris
Messages : 17
Enregistré le : dim. 11 oct. 2015 17:34

Re: Problème alimentation console portable

Messagepar anachris » ven. 13 oct. 2017 15:21

ok c'est bien ce que je pensai, mais maintenant je peux trouver des alim sur le net en 5v et 3a, mais c'est le powerboost qui alimente le système et je ne sais pas comment fonctionnent ses sorties 5v. En efft, pour moi même si je mets du 5v 20a(j'exagère) en entrée du powerboost mais qu'il ne sort que du 5v 1a , par exemple, j'aurai toujours le soucis non? A moins que le powerboost 1000c puisse sortir plus en fonction de l'alim que l'on lui mets? Là je ne suis pas sur , à votre avis????

Je me demande : et si je change le rpi3 pour mettre un pi2b, la conso du pi va diminuer et cela fonctionnerait peux être?

Artemus24
Messages : 98
Enregistré le : ven. 15 sept. 2017 19:15

Re: Problème alimentation console portable

Messagepar Artemus24 » sam. 14 oct. 2017 20:37

Salut jojo.

jojo a écrit :La fondation recommande 2A pour l'alimentation de la RPi

Pour un Raspberry Pi 2, c'est en effet 2 ampères.
Mais pour un Raspberry Pi 3, c'est 2,5 ampères.

@+

jelopo
Messages : 26
Enregistré le : mer. 11 oct. 2017 10:23

Re: Problème alimentation console portable

Messagepar jelopo » lun. 16 oct. 2017 08:11

Bonjour,

Pour info la source est dans les FAQ : https://www.raspberrypi.org/help/faqs/#powerReqs

A+

anachris
Messages : 17
Enregistré le : dim. 11 oct. 2015 17:34

Re: Problème alimentation console portable

Messagepar anachris » ven. 20 oct. 2017 20:32

hello, je me demandai si en ajoutant un powerboost 1000c sur lequel serait branchés juste l'écran et l'ampli audio cela fonctionnerai?
Ci-joint un petit schemas du principe auquel je pense
schemas rpi.png
schemas rpi.png (20.64 Kio) Vu 145 fois

Avatar de l’utilisateur
xGunMachine
Messages : 91
Enregistré le : jeu. 2 juin 2016 19:27

Re: Problème alimentation console portable

Messagepar xGunMachine » lun. 23 oct. 2017 07:26

Bonjour, cette dernière solution semble la plus viable mais cependant ce n'est pas très propre.
Chez moi ma raspberry pi 3 fonctionne très bien avec un écran 2,8 pouces (j'utilise également un powerboost 1000)
la raspberry pi 3 consomme dans les 600-700 mAh, plus en cas d'overclock, ton écran doit faire dépasser légèrement (> 1 ampères) mais le son fini par manger ce qu'il reste
Si tu a de la place tu peux essayer de mettre deux powerboost
1 A pour le Pi
1 A pour écran + son
Éviter de relier les deux sur la sortit, n'essaie pas de faire un seul de 2 A cela pourrait endommager ton appareil (à 25 euros le powerboost ...)


Envoyé de mon iPhone en utilisant Tapatalk Pro
Mes projets :
NES Pi : Émulateur Raspberry pi dans un boitier NES dans sont jus
GameBoy Pi : Émulateur Raspberry pi dans un boitier GameBoy Classic

anachris
Messages : 17
Enregistré le : dim. 11 oct. 2015 17:34

Re: Problème alimentation console portable

Messagepar anachris » lun. 23 oct. 2017 17:09

salut !
merci xGunMachine pour ta réponse.
J'ai commandé le deuxième powerboost.
Je vais tenter en branchant sur un powerboost le pi et sur l'autre l'ecran et l'ampli audio. (je croise les doigts!!!!!)
J'ai pris un chargeur Aukru Micro USB 5v 3000mA pour alimenter les powerboost, j'avai lu un avis favorable sur ce chargeur.
En espérant que cela fonctionne!!!!
Je te vous tiendrai au courant.

anachris
Messages : 17
Enregistré le : dim. 11 oct. 2015 17:34

Re: Problème alimentation console portable

Messagepar anachris » lun. 30 oct. 2017 09:50

Salut a tous!
Petit retour sur l'avancement du projet.
J'ai commandé un deuxième powerboost 1000c. J'ai donc un premier powerboost avec dessus le pi, et sur l'autre l'écran + l'ampli audio et résultat....
ca fonctionne!
Plus d'éclair m'indiquant une défaillance d'alimentation.
Système validé!


Retourner vers « Les alimentations »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité