Alimentation à LM317

Sujet sensible sur le Raspberry Pi, retrouvez ici les questions relatives aux alimentations utilisées

Modérateur : Francois

MSG
Messages : 15
Enregistré le : ven. 26 déc. 2014 18:31

Re: Alimentation à LM317

Message par MSG » lun. 29 déc. 2014 09:08

Bonjour ,

Après mûres réflexion et en cherchant un peu , je me rend compte de mon erreur . :oops:

En fait , la batterie , comme le transfo , est traversé par un courant , celui demandé par le RPi .
Si on prend du 12V et 700mA consommé par le RPi , il sort une puissance de 8,4W et ceux quelques soit la tension utilisé après dans le montage .
Si le RPi consomme 3,5W , la différence est forcément perdu et transformé sous une autre forme d'énergie , ici en chaleur .
Aux bornes du régulateur on trouve bien d'un côté 12V et en sortie 5V , on a donc 7V qui cherchent à passer et comme le courant est de 700mA , on a 4,9W qui restent bloqué à ce niveau et sont transformés forcément en chaleur .

En comparaison avec un robinet d'eau , l'énergie retenue ne se transforme pas en énergie thermique , mais en énergie mécanique beaucoup plus difficile à mesurer et a détecter .
On la ressent parfois quand on ferme rapidement une vanne 1/4 de tour , les tuyaux claquent , on appelle ça le coup de bélier .

Pour bien aller , il faudrait prend une source électrique la plus basse possible afin qu'aux bornes du régulateur il y ait le moins de tension bloqué .
Je pense partir sur une batterie au plomb de 6V ou transformateur de même tension .
J'aurais une puissance fournie de 6 x 0,7 = 4,2W , et plus que 4,2W - 3,5W = 0,7W perdus en chaleur .
0,7W / 4,2W = 0,166 soit 16,6% de rendement en pertes c'est mieux que les 4,9W / 8,4W = 0,583 soit 58,3% de pertes (plus de la moitié) avec une alim de 12V .

J'ai vu des accus au plomb de 6V à 7Ah ce qui donne 42Wh .
42Wh / 4,2W = 10h d'autonomie en théorie .
Si je part sur le maximum de 1,5A du régulateur pour alimenter un maximum d'accessoires , j'aurais 7,5W de consommés .
42Wh / 7,5W = 5,6h soit 5h36min d'autonomie dans le pire des cas .

A moins que je ne me penche sur le montage proposé par EVOTk , si celui-ci permet un meilleur rendement .
Faut que j'étudie ça de près .

MSG

MSG
Messages : 15
Enregistré le : ven. 26 déc. 2014 18:31

Re: Alimentation à LM317

Message par MSG » lun. 29 déc. 2014 10:39

Je viens de regarder les datasheet du LM2596 .
Il existe apparemment des version en tension fixe en sortie qui ne nécessitent pas les résistances sur le Feedback .
La version 5V est donnée pour un rendement de 80% soit 20% seulement en pertes .

Par contre on ne peux pas mettre n'importe quelle tension en entrée si on veut avoir un bon rendement .
Il faut une source de 2 à 3V supérieure à la tension souhaitée en sortie , pour le 5V il faut minimum 8V .
Apparemment la valeur de la self en sortie est en rapport avec la tension d'entrée .
22µH pour du 8 à 10V entrée et 33µH pour du 15V en entrée .

J'ai regardé les caractéristiques des self vendues à la pièce et celle que j'ai trouvé dépassent rarement 1A , ça va être dur de se monter se type d'alimentation à moins de l'acheter toute prête . Je doute que celles sans radiateur puissent fournir 3A sans chauffer .
A moins de se fabriquer soit même la self , c'est juste que du fil enroulé sur une ferrite , mais ça demande des connaissance et du matériel que je n'ai pas .

J'ai fait quelques calculs :
En pleine puissance et une source de 12V , on a 12V x 3A = 36W fournis , avec 80% de rendement ça donne 28,8W utilisés et 7,2W perdus en chaleur .
Rapporté à la consommation du RPi seul , on à 12V x 0,7 = 8,4W , avec 80% de rendement , ça donne 6,7W consommés et 1,7W perdus en chaleur .
Étant donné que le RPi consomme 3,5W environs , le rendement doit être moindre et variable .
A moins que le courant consommé en entrée soit moindre sinon , je ne vois pas .

MSG

MSG
Messages : 15
Enregistré le : ven. 26 déc. 2014 18:31

Re: Alimentation à LM317

Message par MSG » lun. 29 déc. 2014 15:05

Bonjour ,

Vu ce que j'ai lu sur le blog :
http://www.framboise314.fr/6-conseils-p ... pberry-pi/
Lors des phases de démarrage de votre Raspberry Pi, il se produit des appels de courant importants, par exemple lors de la mise en service du GPU. Si votre alim ne suit pas, la LED PWR va clignoter , indiquant une tension inférieure à 4,75v. Les nouveaux firmware intègrent eux-aussi un indicateur et ils affichent un carré multicolore en haut à droite de l’écran si l’alim descend en dessous de 4,65v.
Je me suis demandé si une batterie de 6V ferait l'affaire pour des montages embarqués .

J'ai trouvé quelques infos sur les batteries au plomb .

En charge , un élément de 2V ne doit pas dépasser 2,3V au maximum de sa charge soit +15% .
Et en décharge , il ne doit pas descendre en dessous de 1,75V soit environs -14% .

Sur une batterie de 6V , le niveau haut serait 6,9V et le niveau bas à 5,26V , ça laisse de la marge au RPi pour fonctionner sans que la tension tombe en dessous du seuil critique .

Je pensais même me faire un voltmètre pour signaler au RPi l'état de niveau bas et bas critique de la batterie lui laissant ainsi le temps de bien s'arrêter .
Je pensais à un LM3914 en mode barre , quand les diodes (optocoupleur) ne sont plus alimentés , l'info est signalé au RPi et éventuellement l'empêche de démarrer si la tension est vraiment trop basse (relais ou télécommande on/off sur le régulateur) .

MSG

Lemania
Messages : 4
Enregistré le : lun. 7 mars 2016 12:45

Re: Alimentation à LM317

Message par Lemania » lun. 7 mars 2016 13:40

Bonjour,

Ahh je suis contant de voir enfin des alimentations linéaires régulées, le LM317 est un bon choix !!

Je vais d’ailleurs m'en faire une au plus vite.

Je posterais ça ici

Lemania
Messages : 4
Enregistré le : lun. 7 mars 2016 12:45

Re: Alimentation à LM317

Message par Lemania » lun. 7 mars 2016 13:58

Au fait le raspberry 3 demande plus de courant ?

guillaume9344
Raspinaute
Messages : 629
Enregistré le : mar. 6 janv. 2015 19:44
Localisation : finistere

Re: Alimentation à LM317

Message par guillaume9344 » lun. 7 mars 2016 20:19

Lemania a écrit :Bonjour,

Ahh je suis contant de voir enfin des alimentations linéaires régulées, le LM317 est un bon choix !!

Je vais d’ailleurs m'en faire une au plus vite.

Je posterais ça ici
Pas d'accord(pour les raisons déjà évoquées plus haut) et en plus , si on veut à tout pris utiliser un régulateur linaire, autant utiliser la version à sortie fixe 5v: lm7805 .
Et par expérience un régulateur linéaire (lm317 ou 7805) alimenté en 02v et sortant du 5v en 2A, on approche de la valeur max avec un boitier TO3 et on la dépasse avec un boitier TO220 . de plus il faut un sacré radiateur pour refroidir le bousin.
En plus des considérations techniques , rentre en jeu aussi l'aspect financier, les modules régulateurs à découpage sont beaucoup moins chères que l 'ensembles lm317 radiateur....

Aprés le choix du régulateur linéaire peut être une solution si :
-on en a plein les tiroirs
-on veut expérimenter cette technologie
-on a récupéré un module ou une alim toute faite
-on fait parti de la secte des linéaire à tout pris et mort au découpages (certain portent des bonnets violets à pompons roses).

voilas , le lm317 n'est pas un bon choix , c'est un choix. :) ;)
@+
rpi b+ ,osmc, motioneyes
rpi 2 raspbian , server minecraft 24h/24 , utilisation gpio
orange pi pc debian ,utilisation gpio, motion cam

Lemania
Messages : 4
Enregistré le : lun. 7 mars 2016 12:45

Re: Alimentation à LM317

Message par Lemania » mar. 8 mars 2016 07:26

Bonjour,

J'en ai plein la cave d'où le réflexe, mais effectivement c'est un peu léger.

En prévision du P3 il faut de toute façon voir plus gros.

Répondre

Retourner vers « Les alimentations »