Craquement enceinte au lancement d'un son

La vidéo HDMI ou composite et la sortie audio PWM du Raspberry Pi

Modérateur : Francois

sylvainpi
Messages : 14
Enregistré le : mer. 27 avr. 2016 21:18

Craquement enceinte au lancement d'un son

Messagepar sylvainpi » mer. 26 oct. 2016 13:58

Bonjour,
j'ai branché en sortie audio de mon raspberry Pi 1B un modèle de carte ampli qui ressemble à ça et qui est alimenté par les sorties GND et 5V du RPi via les pins. Je suis agréablement surpris par le rendu sonore (j'ai des exigences limitées) mais il y a un petit truc que j'aimerais améliorer. Lorsque je lance un son sur le RPi, j'ai un craquement sur les enceintes. Il ne se reproduit pas par la suite mais simplement au lancement de la musique (j'utilise mpg321). Est-ce que quelqu'un aurait une piste pour supprimer ce craquement initial ? Rajout d'une résistance quelque part, changement de config logicielle ?

Merci par avance pour toutes pistes.
Premier projet : un jukebox pour enfants avec un RPi 1B.

sylvainpi
Messages : 14
Enregistré le : mer. 27 avr. 2016 21:18

Re: Craquement enceinte au lancement d'un son

Messagepar sylvainpi » ven. 28 oct. 2016 07:02

Bonjour,
je me réponds à moi-même après avoir trouvé quelques pistes sur d'autres forums. Il semblerait que l'utilisation de la sortie audio jack du RPi pourrait être une piste. Et en effet en essayant avec une petite carte son USB ça semble résoudre le problème.
Premier projet : un jukebox pour enfants avec un RPi 1B.


Retourner vers « Les sorties Vidéo et Audio du Raspberry Pi »

Qui est en ligne

Utilisateurs parcourant ce forum : Baidu [Spider] et 1 invité