[Lâchement abandonné] USB Serial

Comment utiliser ces ports USB du Raspberry Pi, gérer les problèmes qu'ils génèrent

Modérateur : Francois

Avatar de l’utilisateur
Laurent
Messages : 10
Enregistré le : sam. 14 févr. 2015 17:05
Localisation : Seine et Marne

Re: USB Serial

Messagepar Laurent » ven. 6 mars 2015 18:31

Bon me voilà de retour et j'ai enlevé la balise [RESOLU] car le problème ... vous avez compris la suite !
J'ai besoin de déverser mon fiel et ma rage, alors tant pis vous allez prendre !!! Je respire un grand coup... ça va mieux.

alors voilà, je retourne le module au vendeur (fabricant ???) et celui-ci me répond que le module fonctionne parfaitement chez lui.
J'ai eu beau lui demander le type de raspberry qu'il utilise, il n'a dit que "ancien modèle", mais j'ai réussi à lui arracher un dmesg :

Code : Tout sélectionner

root@raspberrypi:~# dmesg
[    0.000000] Booting Linux on physical CPU 0
[    0.000000] Initializing cgroup subsys cpu
[    0.000000] Linux version 3.6.11+ (smc@build-ssd) (gcc version 4.5.4 20120305 (prerelease) (GCC) ) #26 PREEMPT Tue Nov 26 18:19:51 SGT 2013
[    0.000000] CPU: ARMv6-compatible processor [410fb767] revision 7 (ARMv7), cr=00c5387d
[    0.000000] CPU: PIPT / VIPT nonaliasing data cache, VIPT nonaliasing instruction cache
[    0.000000] Machine: BCM2708


Moi c'est
Linux domo-1 3.18.7+ #755 PREEMPT Thu Feb 12 17:14:31 GMT 2015 armv6l GNU/Linux
et
Linux domo-1 3.18.8+ #764 PREEMPT Tue Mar 3 15:17:20 GMT 2015 armv6l GNU/Linux
depuis la dernière mise à jour.

>>> Donc il utilise un noyau 3.6.11 et moi 3.18.7, est-ce la source du problème ????

Je reçois le fameux merdeux fabuleux module, je fait des tests sous Windows XP 32 bits avec le driver fourni sur le site dudit vendeur, sous Windows 7 64 bits en laissant Windows se débrouiller sur internet pour le driver et sur ma framboise préférée, le constat est simple :
aucune données n'est lue pour une vitesse inférieure à 9600 bauds ! TIENS, mais c'était 115200 bauds la limite avant que je lui retourne le module :?:
Bien sûr le protocole étant 1200 bauds, les données lues à 9600 bauds sont inexploitables... sinon je serais pas en train pleurer comme une <CENSURE>

Le vendeur me conseil d'utiliser le driver suivant http://www.ftdichip.com/Drivers/D2XX/Linux/libftd2xx1.1.12.tar.gz, mais bon maintenant que ftdi_sio et usbserial sont inclus à l'intérieur du dedans du noyau, y a plus besoin (dixit kernel.org), alors j'hésite !
De plus je vais pas avoir le temps ce week-end de faire plus de tests (les mômes et leurs compétitions sportives, je vous jure !!!)

Alors si vous avez des idées, mieux des solutions, n'hésitez surtout pas !!!
Oui, toi là au fond du forum, bien cacher au fond qui se marre parce que tu connais LA solution, partage ton savoir !!! (tentative désespérée de piquage au vif de l'amour propre etc, etc)

Sur ce, une bonne soirée à tous !
Je veux être libre, libre de m'exprimer, libre de coder, libre de modifier...

Avatar de l’utilisateur
vague nerd
Modérateur
Messages : 1391
Enregistré le : mar. 14 oct. 2014 11:42
Localisation : France !

Re: USB Serial

Messagepar vague nerd » ven. 6 mars 2015 22:21

Bonjour.

Je compatis... :(

aucune données n'est lue pour une vitesse inférieure à 9600 bauds ! TIENS, mais c'était 115200 bauds la limite avant que je lui retourne le module

Vous êtes sûr que c'est le même module ? (traces spécifiques comme coup de feutre, rayures...)

Le vendeur me conseil d'utiliser le driver suivant http://www.ftdichip.com/Drivers/D2XX/Li ... .12.tar.gz, mais bon maintenant que ftdi_sio et usbserial sont inclus à l'intérieur du dedans du noyau, y a plus besoin (dixit kernel.org), alors j'hésite !

Vous avez raison d'hésiter ! Néanmoins, vous prouvez tester après une sauvegarde de la carte...

Cdt.
Cordialement,

Vague Nerd

Avatar de l’utilisateur
Laurent
Messages : 10
Enregistré le : sam. 14 févr. 2015 17:05
Localisation : Seine et Marne

Re: USB Serial

Messagepar Laurent » sam. 7 mars 2015 11:28

Bonjour,

Vous êtes sûr que c'est le même module ? (traces spécifiques comme coup de feutre, rayures...)

J'ai pris une photo du module avant de l'expédier et j'ai comparé au retour : pas de différences visibles... bon j'ai pas non plus un microscope :mrgreen:

Par contre je viens de déterrer un vieux module téléinfo/RS232 ET un câble convertisseur RS232/USB et ça marche !!!!!!!!! Sur la raspberry comme sous Windaub !
Un dmesg me permet de comparer entre les deux :

Le module USB qui refuse obstinément de faire son boulot :

Code : Tout sélectionner

[111448.412432] usb 1-1.3: new full-speed USB device number 6 using dwc_otg
[111448.538468] usb 1-1.3: New USB device found, idVendor=0403, idProduct=6001
[111448.538509] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[111448.538530] usb 1-1.3: Product: FT232R USB UART
[111448.538547] usb 1-1.3: Manufacturer: FTDI
[111448.538564] usb 1-1.3: SerialNumber: AD02DY77
[111448.551290] ftdi_sio 1-1.3:1.0: FTDI USB Serial Device converter detected
[111448.551531] usb 1-1.3: Detected FT232RL
[111448.553775] usb 1-1.3: FTDI USB Serial Device converter now attached to ttyUSB0


Le convertisseur USB/RS232 avec derrière le module RS232 qui, tel un dinosaure, continu de faire son taff en attendant son astéroïde :

Code : Tout sélectionner

[173210.663918] usb 1-1.2: new full-speed USB device number 7 using dwc_otg
[173210.791381] usb 1-1.2: New USB device found, idVendor=0403, idProduct=6001
[173210.791422] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[173210.791442] usb 1-1.2: Product: USB <-> Serial Cable
[173210.791460] usb 1-1.2: Manufacturer: FTDI
[173210.791477] usb 1-1.2: SerialNumber: FTSKAL95
[173210.804215] ftdi_sio 1-1.2:1.0: FTDI USB Serial Device converter detected
[173210.804454] usb 1-1.2: Detected FT232RL
[173210.805759] usb 1-1.2: FTDI USB Serial Device converter now attached to ttyUSB0


Bref, idVendor, idProduct, Mfr, Product, SerialNumber et Manufacturer identiques, on est en présence de la même puce ftdi... ou du moins 2 cousines extrêmement proches
Product et SerialNumber différents... ben oui, j'ai bien 2 éléments physiques différents dans les mains !

En gros je suis en train de me demander si le câbles mini USB/USB que j'utilise n'aurait pas un défaut de câblage, ou du moins différent de ce que j'aurais besoin. J'ai testé 3 câbles mini USB/USB (pas micro USB comme sur les téléphones, mais bien mini USB), même soucis ! D'un autre côté, pour mon téléphone j'ai 2 câbles USB identiques extérieurement, j'arrive à charger le tél avec l'un mais pas avec l'autre (ça allume le tél et c'est tout), donc il doit bien y avoir des différences de câblages possibles !!!

J'ai donc demandé au fabricant du module USB de relever le câblage de son câble mini USB / USB pour comparer avec les miens, on verra bien ! Si c'est pas ça, ben je ne sais pas, je ne sais plus !

Je vous tiens au courant de toute façon !
A+ et merci pour l'aide !

PS :
Néanmoins, vous prouvez tester après une sauvegarde de la carte...

Étant informaticien et donc fainéant, j'avais bien prévu la sauvegarde de la carte AVANT, histoire de pas recommencer l'install du bazar (1Wire, Z-Wave, domoticz, etc, etc)
Comme a dit un jour l'un de mes profs de terminal : "Soyez fainéants ! Un fainéant en fait autant que les autres en se fatiguant moins, c'est donc une preuve d'intelligence !" Du coup il s'est retrouvé avec une promo entière qui a décidée de devenir trèèèèèèèèèès intelligente 8-)
Je veux être libre, libre de m'exprimer, libre de coder, libre de modifier...

Avatar de l’utilisateur
Laurent
Messages : 10
Enregistré le : sam. 14 févr. 2015 17:05
Localisation : Seine et Marne

Re: [Lâchement abandonné] USB Serial

Messagepar Laurent » mer. 8 avr. 2015 10:18

Enfin de retour, mais pas pour une solution :oops:

Pour résumer, le fabricant m'assure que le montage fonctionne chez lui (le montage a fait un aller-retour chez lui).
Chez moi, impossible de le faire fonctionner sur 3 PCs différents, sous Windows 7 64 bits, Windows XP 32 bits (réel et virtuel), sous raspbian à jour sur ma framboise et sous archlinux plus à jour depuis quelques années et avec 5 câbles mini USB/USB ...
Le fabricant m'a proposé un remboursement, c'est fait... pas glorieux comme dénouement !

Bref, soit comme le dit Doc House, tout le monde ment, soit par une coïncidence rare, je n'ai que des câbles USB mal câblés, mais dans ce cas j'écoute Gibbs : Règle #39 : Les coïncidences, ça n'existe pas

A la prochaine pour une nouvelle prise de tête (suis spécialiste, toujours à vouloir un truc qui n'existe pas... ce week-end je me suis fabriqué une prise murale avec prise antenne satellite et 2 RJ45 (info et téléphone), le tout dans l'espace d'une seule prise... ben oui ça existe pas !!!)
Je veux être libre, libre de m'exprimer, libre de coder, libre de modifier...


Retourner vers « Les ports USB »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité