[Retour d'expérience] webcam + temperatures + 3G + antenne

Les applications du Raspberry Pi en contrôle d'accès, alarme et vidéosurveillance

Modérateur : Francois

Arnaud13
Messages : 58
Enregistré le : mar. 8 mars 2016 10:38

Re: [Retour d'expérience] webcam + temperatures + 3G + anten

Messagepar Arnaud13 » ven. 18 mars 2016 11:42

oui j'essaie de faire ça quand j'aurais un peu de temps, ce serait en effet intéressant d'avoir les avis "des pros"...

Pendant que j'y suis autre question:
je viens de connecter un second capteur de température/humdité sur le Pi.
Et maintenant il n'y en a qu'un qui fonctionne.... le second donne des infos incohérentes...

Voici ce que j'ai fait:

un fil branché sur GND sur le Pi. Ce fil se sépare en deux pour aller sur les 2 ports GND des capteurs.
un fil branché sur le 3.3v sur le Pi. Ce fil se sépare en deux pour aller sur les 2 ports VCC des capteurs.
un fil branché sur le GPIO4 du Pi, envoyé au port DATA de l'un des capteurs.
un fil branché sur le GPIO17 du Pi, envoyé au port DATA de l'autre capteur.

A priori ce n'est pas une défaillance du capteur, si je les inverses le problème persiste. L'un me retourne les bonnes infos, l'autre des infos bidons (genre 10°C et 145% humidité)
L'un des capteurs a 15m de cable, l'autre a 10m de cable.
Parfois le problème est sur un cable, parfois sur l'autre...

J'ai peut etre pris du fil electrique trop gros?
J'ai trop long de fil pour la totalité et l'alimentation associée?
Vous auriez d'autres idées?
Maison de montagne:
-Pi 2B + Clef 3G déportée + Antenne 3G + 3 USBWebcam ---> Vidéo Surveillance
-Pi 3 + 3 capteurs DHT22 + Relais ---> Démarrage radiateurs à distance
-Hub Ethernet entre les deux (Réseau privé et pas de Wifi, pas d'Adsl, etc...)

xavier1306
Messages : 72
Enregistré le : dim. 15 nov. 2015 00:00

Re: [Retour d'expérience] webcam + temperatures + 3G + anten

Messagepar xavier1306 » ven. 18 mars 2016 15:02

De mon côté je me suis rendu compte que ces montages étaient très sensibles aux perturbations électromagnétique.
Quel type de câbles ? Présence blindage ?
Cheminement prêt de câbles de puissance ?

Envoyé de mon GT-I9505 en utilisant Tapatalk

Arnaud13
Messages : 58
Enregistré le : mar. 8 mars 2016 10:38

Re: [Retour d'expérience] webcam + temperatures + 3G + anten

Messagepar Arnaud13 » ven. 18 mars 2016 15:07

ah.... :( ...
pour le moment ce sont des cables genre "fil electrique de base", du style de ce que l'on utilise pour une lampe de chevet.
Donc pas de blindage............ :)
Actuellement posés sur la table de mon salon, mais à terme ils seront dans une goulotte avec un cable electrique............. :evil: :evil:
Maison de montagne:
-Pi 2B + Clef 3G déportée + Antenne 3G + 3 USBWebcam ---> Vidéo Surveillance
-Pi 3 + 3 capteurs DHT22 + Relais ---> Démarrage radiateurs à distance
-Hub Ethernet entre les deux (Réseau privé et pas de Wifi, pas d'Adsl, etc...)

xavier1306
Messages : 72
Enregistré le : dim. 15 nov. 2015 00:00

Re: [Retour d'expérience] webcam + temperatures + 3G + anten

Messagepar xavier1306 » ven. 18 mars 2016 15:09

Utilise du câble réseau blindé type cat5. Ce sera sûrement déjà mieux.

Envoyé de mon GT-I9505 en utilisant Tapatalk

xavier1306
Messages : 72
Enregistré le : dim. 15 nov. 2015 00:00

Re: [Retour d'expérience] webcam + temperatures + 3G + anten

Messagepar xavier1306 » ven. 18 mars 2016 15:12

De mon côté je rencontre des problèmes mais je sais pourquoi : je fais passer différents niveaux de tension dans un même câble réseau...

Envoyé de mon GT-I9505 en utilisant Tapatalk

Arnaud13
Messages : 58
Enregistré le : mar. 8 mars 2016 10:38

Re: [Retour d'expérience] webcam + temperatures + 3G + anten

Messagepar Arnaud13 » mar. 29 mars 2016 09:41

bonjour à tous,
une petite question aux pros :mrgreen:

mon Pi active une connection 3G via le dongle & la carte SIM FREE. J'ai prévu un mode "remote débug" où j'ouvre cette connection pour 10min après la reception d'un SMS précis. Comme ceci, j'ai 10min pour bosser sur le Pi alors qu'il est super loin de chez moi.
Dès que j'ouvre cette connection, je dépose sur un FTP un fichier texte avec la config reseau & un "traceroute google.com" histoire de récupérer mon adresse IP distante. Mais... je récupère quelque chose de ce style:

Code : Tout sélectionner

eth0      Link encap:Ethernet  HWaddr b8:88:eb:9c:bf:19 
          adr inet6: fe80::9941:40a8:1987:49a5/64 Scope:Lien
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Boucle locale 
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:200 errors:0 dropped:0 overruns:0 frame:0
          TX packets:200 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:16656 (16.2 KiB)  TX bytes:16656 (16.2 KiB)

ppp0      Link encap:Protocole Point-Ã -Point 
          inet adr:100.111.14.141  P-t-P:10.64.64.64  Masque:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:5 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:3
          RX bytes:62 (62.0 B)  TX bytes:101 (101.0 B)


(j'ai changé volontairement quelques chiffres ci-dessus... donc pas de pb pour moi à le diffuser ici)
Mon problème est qu'à partir de ceci, je ne sais pas comment me connecter en SSH à distance?
Sur Putty je ne sais pas si je peux mettre une IP6...? Et encore moins "sous quel format"??
Bref, ma connection s'ouvre pendant 10min, mon "traceroute" fonctionne bien jusqu'à google.com, donc je suis bien connecté sur internet, mais je n'arrive pas à "le joindre" à distance.
Une idée??

:cry: :geek:
Maison de montagne:
-Pi 2B + Clef 3G déportée + Antenne 3G + 3 USBWebcam ---> Vidéo Surveillance
-Pi 3 + 3 capteurs DHT22 + Relais ---> Démarrage radiateurs à distance
-Hub Ethernet entre les deux (Réseau privé et pas de Wifi, pas d'Adsl, etc...)

xavier1306
Messages : 72
Enregistré le : dim. 15 nov. 2015 00:00

Re: [Retour d'expérience] webcam + temperatures + 3G + anten

Messagepar xavier1306 » mar. 29 mars 2016 10:35

Arnaud13 a écrit :bonjour à tous,
une petite question aux pros :mrgreen:

mon Pi active une connection 3G via le dongle & la carte SIM FREE. J'ai prévu un mode "remote débug" où j'ouvre cette connection pour 10min après la reception d'un SMS précis. Comme ceci, j'ai 10min pour bosser sur le Pi alors qu'il est super loin de chez moi.
Dès que j'ouvre cette connection, je dépose sur un FTP un fichier texte avec la config reseau & un "traceroute google.com" histoire de récupérer mon adresse IP distante. Mais... je récupère quelque chose de ce style:

Code : Tout sélectionner

eth0      Link encap:Ethernet  HWaddr b8:88:eb:9c:bf:19 
          adr inet6: fe80::9941:40a8:1987:49a5/64 Scope:Lien
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Boucle locale 
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:200 errors:0 dropped:0 overruns:0 frame:0
          TX packets:200 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:16656 (16.2 KiB)  TX bytes:16656 (16.2 KiB)

ppp0      Link encap:Protocole Point-Ã -Point 
          inet adr:100.111.14.141  P-t-P:10.64.64.64  Masque:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:5 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:3
          RX bytes:62 (62.0 B)  TX bytes:101 (101.0 B)


(j'ai changé volontairement quelques chiffres ci-dessus... donc pas de pb pour moi à le diffuser ici)
Mon problème est qu'à partir de ceci, je ne sais pas comment me connecter en SSH à distance?
Sur Putty je ne sais pas si je peux mettre une IP6...? Et encore moins "sous quel format"??
Bref, ma connection s'ouvre pendant 10min, mon "traceroute" fonctionne bien jusqu'à google.com, donc je suis bien connecté sur internet, mais je n'arrive pas à "le joindre" à distance.
Une idée??

:cry: :geek:

Tu te connectes avec les options par défaut de putty
En principe le port ssh est le 22.
As tu testé la connexion ssh depuis ton réseau local?

Envoyé de mon GT-I9505 en utilisant Tapatalk

Arnaud13
Messages : 58
Enregistré le : mar. 8 mars 2016 10:38

Re: [Retour d'expérience] webcam + temperatures + 3G + anten

Messagepar Arnaud13 » mar. 29 mars 2016 10:39

quand je suis en wifi sur le meme réseau que le Pi, oui via Putty ça fonctionne. Mais j'utilise une IPv4...
Là, avec l'IPv6 je ne sais pas quoi faire :mrgreen:
Maison de montagne:
-Pi 2B + Clef 3G déportée + Antenne 3G + 3 USBWebcam ---> Vidéo Surveillance
-Pi 3 + 3 capteurs DHT22 + Relais ---> Démarrage radiateurs à distance
-Hub Ethernet entre les deux (Réseau privé et pas de Wifi, pas d'Adsl, etc...)

xavier1306
Messages : 72
Enregistré le : dim. 15 nov. 2015 00:00

Re: [Retour d'expérience] webcam + temperatures + 3G + anten

Messagepar xavier1306 » mar. 29 mars 2016 11:09

Arnaud13 a écrit :quand je suis en wifi sur le meme réseau que le Pi, oui via Putty ça fonctionne. Mais j'utilise une IPv4...
Là, avec l'IPv6 je ne sais pas quoi faire :mrgreen:

Il me semblait que l'option pas défaut de putty était ipv4.
Je l'utilise quotidiennement sur pc ou Android (juicessh) sans m'être jamais posé la question.
Au pire choisit bien ipv4 si ce n'est pas le cas.

Envoyé de mon GT-I9505 en utilisant Tapatalk

Arnaud13
Messages : 58
Enregistré le : mar. 8 mars 2016 10:38

Re: [Retour d'expérience] webcam + temperatures + 3G + anten

Messagepar Arnaud13 » mar. 29 mars 2016 11:14

sur ipv4 tout fonctionne justement...
là, mon problème est que je ne sais pas comment utiliser les adresses ipv6 avec putty? (et je ne trouve pas sur le net...)
Maison de montagne:
-Pi 2B + Clef 3G déportée + Antenne 3G + 3 USBWebcam ---> Vidéo Surveillance
-Pi 3 + 3 capteurs DHT22 + Relais ---> Démarrage radiateurs à distance
-Hub Ethernet entre les deux (Réseau privé et pas de Wifi, pas d'Adsl, etc...)


Retourner vers « Accès, alarme et vidéosurveillance »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité