Motion ne démarre pas

Les applications du Raspberry Pi en contrôle d'accès, alarme et vidéosurveillance

Modérateur : Francois

Tcheub
Messages : 1
Enregistré le : mer. 28 déc. 2016 01:30

Motion ne démarre pas

Messagepar Tcheub » mer. 28 déc. 2016 01:46

Bonjour,
Tout d'abord, bonnes fêtes !

Ensuite mon problème :-)

Voici mon petit projet : connecter une foscam et une cam raspberry sur mon nas synology. Mon souci concerne évidemment la caméra du raspberry que je n'arrive pas à faire fonctionner.
Je n'ai pas besoin d'enregistrer des videos ou images, mais simplement de diffuser un flux video que le synology se chargera d'étudier et d'enregistrer en cas de mouvement détecté.

J'ai donc suivi le tuto de François. L'installation sous Jessis se passe bien mais motion ne démarre pas après un reboot (la led rouge ne s'allume pas).
La commande raspistill -o image.jpg fonctionne bien (j'ai l'image et la led rouge) donc cela ne vient pas de l'hardware.
Lorsque je démarre motion à la main, la led rouge s'allume un très bref instant puis s'éteint.
J'obtiens :
[0] [NTC] [ALL] conf_load: Processing thread 0 - config file/etc/motion.conf
[0] [NTC] [ALL] motion_startup: Motion mmaltest Started
[0] [NTC] [ALL] motion_startup: Logging to syslog
[0] [NTC] [ALL] motion_startup: Using log type (ALL) log level (INF)
[0] [NTC] [ALL] become_deamon: Motion going to deamon mode

Je suis débutant (avec notions) et j'ai quelques heures de patauge derrière moi pour tenter de résoudre ce problème.. :D

Merci d'avance pour votre aide.

stephaneK
Messages : 81
Enregistré le : mar. 13 sept. 2016 10:08

Re: Motion ne démarre pas

Messagepar stephaneK » mer. 28 déc. 2016 11:13

Bonjour,
Pour que motion se lance au reboot du pi, il faut modifier le fichier motion.conf situé dans répertoire /etc.
et activer le daemon sur "on", situer au début du fichier.

############################################################
# Daemon
############################################################

# Start in daemon (background) mode and release terminal (defAULT: OFF)
daemon off
############################################################

@++

Avatar de l’utilisateur
LeBorgne
Messages : 41
Enregistré le : sam. 26 nov. 2016 23:39

Re: Motion ne démarre pas

Messagepar LeBorgne » mer. 28 déc. 2016 20:24

il y a un mini serveur web pour l'administration
http://localhost:8080

il ne faut pas oublier de remonter toute l' arborescence après les modifications et effectuer un WRITE puis ACTION et RESTART

Enjoy


Retourner vers « Accès, alarme et vidéosurveillance »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité