Besoin de votre aide pour la réception d'un signal RF

Portail, portes, volets et stores de terrasse obéiront aux ordres du Raspberry Pi

Modérateur : Francois

seb38300
Messages : 6
Enregistré le : lun. 14 mars 2016 15:49

Besoin de votre aide pour la réception d'un signal RF

Message par seb38300 » lun. 14 mars 2016 15:56

Bonjour à tous !

Je suis un petit nouveau ici (et dans le monde de la framboise ^^) et j'arrive avec ma question....
J'ai un projet de domotique en route (qui fonctionne déjà via ma centrale d'alarme mais je voudrais le rendre "plus mieux bien")
J'ai donc sauté le pas du RASPBERRY....
Je n’ai pas encore attaqué le programme en lui même, je bloque sur mes tests préliminaires !
J'ai donc un PI 2 modèle B et un module de réception 433MHz (http://www.amazon.fr/gp/product/B00VG43 ... ge_o06_s00)
Mon problème est le suivant : après avoir installé wiringPi et 433Utils, je n'arrive pas à récupérer le signal de mes télécommandes, je n'ai absolument rien avec RFSniffer ...
En essayant de passer "manuellement" la broche du GPIO en entrée (gpio 7 en "in"), et en écoutant cette broche (gpio read 7) j'arrive a avoir de tps en tps des "1" en appuyant sur la télécommande....
Je pense donc que le câblage est ok et que le module fonctionne mais du coup pourquoi RFSniffer ne capte rien ? j'ai essayer avec 2 solutions alternatives et rien aussi ....

Si une âme charitable veux bien m'éclairer ça serait avec grand plaisir ! ^^

Merci d'avance a vous et un gros merci pour faire vivre des forums comme celui-la !

domi
Administrateur
Messages : 2138
Enregistré le : mer. 17 sept. 2014 18:12
Localisation : Seine et Marne

Re: Besoin de votre aide pour la réception d'un signal RF

Message par domi » lun. 14 mars 2016 17:49

Bonjour,

Première question qui me vient, est-ce que les télécommandes que tu testes sont bien en 433 Mhz ?

seb38300
Messages : 6
Enregistré le : lun. 14 mars 2016 15:49

Re: Besoin de votre aide pour la réception d'un signal RF

Message par seb38300 » mar. 15 mars 2016 07:44

Merci pour la réponse

J'ai testé avec 3 différentes qui sont normalement toutes en 433MHz, j'ai vérifié en en ouvrant une, le "quartz" est bien à 433MHz (ref HDR433M)

Korhm
Raspinaute
Messages : 219
Enregistré le : ven. 19 sept. 2014 08:13
Localisation : Val de Marne

Re: Besoin de votre aide pour la réception d'un signal RF

Message par Korhm » mar. 15 mars 2016 07:53

Bonjour,

Ce genre de récepteur 433Mhz nécessite une antenne pour améliorer la réception longue portée.
Est ce que tu en as une ? (Je ne me rappelle plus de la longueur idéale... Mais beaucoup de Tuto en parle)
Sinon, est que cela fonctionne si ta télécommande est à quelques centimètres du récepteur ?

seb38300
Messages : 6
Enregistré le : lun. 14 mars 2016 15:49

Re: Besoin de votre aide pour la réception d'un signal RF

Message par seb38300 » mar. 15 mars 2016 08:02

J'ai lu ca effectivement, j'ai prévu d'en rajouter une par la suite pour la mise en route au sous-sol du boitier terminé
Pour mes test j'ai moins d'un mètre entre les deux (je suis sur mon bureau) et n'ayant pas de signal, j'ai collé émetteur et récepteur mais rien non plus ....
un problème de logiciel peut-être ? La vraiment je sèche .....

domi
Administrateur
Messages : 2138
Enregistré le : mer. 17 sept. 2014 18:12
Localisation : Seine et Marne

Re: Besoin de votre aide pour la réception d'un signal RF

Message par domi » mar. 15 mars 2016 08:14

Bonjour,

Ce que tu peux faire pour tester, c'est connecter un LED entre la broche DATA et le GND du recepteur.
Normalement lorsque tu appuies sur la télécommande, la LED devrait clignoter. Cela te permettra déjà de vérifier si le problème est coté capture du signal RF433, ou coté programme.

Korhm
Raspinaute
Messages : 219
Enregistré le : ven. 19 sept. 2014 08:13
Localisation : Val de Marne

Re: Besoin de votre aide pour la réception d'un signal RF

Message par Korhm » mar. 15 mars 2016 08:17

Pour ma part il fallait que je sois vraiment proche, une 10aine de centimètres.
J'ai pas de quoi tester sans antenne là, j'avais grillé mon récepteur en le branchant mal à un moment :)

seb38300
Messages : 6
Enregistré le : lun. 14 mars 2016 15:49

Re: Besoin de votre aide pour la réception d'un signal RF

Message par seb38300 » mar. 15 mars 2016 08:22

oulala domi, j'ai limite honte de ne pas avoir pensé à faire ce test ^^
Bon je viens de tester le coup de la led entre "DATA" et "GND" : ca clignote lorsque j'appui sur le bouton de la télécommande !
en plus on voit bien la chaîne passer !

seb38300
Messages : 6
Enregistré le : lun. 14 mars 2016 15:49

Re: Besoin de votre aide pour la réception d'un signal RF

Message par seb38300 » mar. 15 mars 2016 08:23

Korhm a écrit :Pour ma part il fallait que je sois vraiment proche, une 10aine de centimètres.
J'ai pas de quoi tester sans antenne là, j'avais grillé mon récepteur en le branchant mal à un moment :)
Grace au test de domi, je confirme que ca marche a plus d'un mètre sans antenne ^^

Korhm
Raspinaute
Messages : 219
Enregistré le : ven. 19 sept. 2014 08:13
Localisation : Val de Marne

Re: Besoin de votre aide pour la réception d'un signal RF

Message par Korhm » mar. 15 mars 2016 08:33

J'avais pas vu le message de Domi :?

As tu essayé le script radioReception de ideman ? Il est spécifique au protocol utilise par chacon, mais si tu sait connais le c++ tu devrais pouvoir l'adapter à tes besoins :
http://blog.idleman.fr/raspberry-pi-10- ... par-radio/

Je me souviens que ce script marchait pour moi

Répondre

Retourner vers « Gestion centralisée ouverture/fermeture »