[resolu]probleme avec chromium

Vous venez de déballer votre Raspberry Pi et vous vous posez des questions ? C'est ici que ça se passe !

Modérateurs : Francois, EVOTk

Répondre
chuspyto27
Messages : 33
Enregistré le : lun. 10 août 2015 09:24

[resolu]probleme avec chromium

Message par chuspyto27 » mar. 18 août 2015 08:15

bonjour,

j'ai installer chromium via

Code : Tout sélectionner

sudo apt-get install chromium
, tout était normal.
puis j'ai fait de sorte pour lancer chromium en mode fullscreen au demarrage et voici le message d'erreur que j'obtient.
j'ai tenté de lancer chromium via 'ongle navigation et j,ai le meme résultat
chromium can not be as root
please start chromium as a normal user
merci
Modifié en dernier par chuspyto27 le dim. 23 août 2015 20:21, modifié 1 fois.

domi
Administrateur
Messages : 2623
Enregistré le : mer. 17 sept. 2014 18:12
Localisation : Seine et Marne

Re: probleme avec chromium

Message par domi » mar. 18 août 2015 10:38

Bonjour,

D'après le message, tu essais de lancer Chromium en étant connecté en tant que "Root", il demande de le lancer en tant que simple utilisateur sans droits root.

Avatar du membre
dbrion0606
Raspinaute
Messages : 164
Enregistré le : ven. 30 janv. 2015 15:51

Re: probleme avec chromium

Message par dbrion0606 » mar. 18 août 2015 12:48

Excusez moi, mais l'environnement graphique peut il être lancé comme super utilisateur, ou seulement comme utilisateur ordinaire ? Dans le dernier cas, lancer depuis l'environnement graphique ne devrait pas générer cette erreur...

domi
Administrateur
Messages : 2623
Enregistré le : mer. 17 sept. 2014 18:12
Localisation : Seine et Marne

Re: probleme avec chromium

Message par domi » mar. 18 août 2015 14:47

Je ne sais pas comment chuspyto27 lance son appli, mais en mode graphique on peut lancer une application graphique avec des droits root.

Sur ma machine, Debian et Gnome, je lance régulièrement la commande "sudo gedit" afin de modifier des fichiers nécessitants des droits root.

destroyedlolo
Raspinaute
Messages : 1317
Enregistré le : dim. 10 mai 2015 18:44
Localisation : Dans la campagne à côté d'Annecy
Contact :

Re: probleme avec chromium

Message par destroyedlolo » mar. 18 août 2015 16:42

Salut,

Malheureusement, le pb n'est pas là :
  • oui, root (comme n'importe quel utilisateur) peut lancé X
  • mais certaines applies, comme chromium visiblement, refusent de ce lancer en tant que root (c'est un choix du développeur qui rajoute un test au début du programme). Donc
    1. soit tu as une option pour forcer l'utilisation de root
    2. soit du fait un sudo vers un utilisateur lambda pour lancer chromium
Mais la question principale est : chuspyto27 as-tu vraiment besoin de le lancer en tant que root ? pourquoi ?
  • BananaPI : Gentoo, disque SATA de 2 To
  • Domotique : 1-wire, TéléInfo, Tablette passée sous Gentoo, ESP8266
  • Multimedia par DNLA
  • Et pleins d'idées ... et bien sûr, pas assez de temps.
Un descriptif de ma domotique 100% fait maison.

chuspyto27
Messages : 33
Enregistré le : lun. 10 août 2015 09:24

Re: probleme avec chromium

Message par chuspyto27 » mar. 18 août 2015 17:26

Tout simplement je voudrais t'afficher une page php au demarrage tout ce que j'ai obtenu avec midori c'est d'avoir à un moment donné une page blanche malgré un refresh d'active.donc suite à ca je me suis orienté vers Chromium mais je n'obtient rien d'où le test en sudo, même en essayant simplement d'ouvrir Chromium par l'interface

Avatar du membre
dbrion0606
Raspinaute
Messages : 164
Enregistré le : ven. 30 janv. 2015 15:51

Re: probleme avec chromium

Message par dbrion0606 » mer. 19 août 2015 17:25

Je sais que ça paraîtra ridicule, mais avez vous pensé à Dillo (ça veut dire idiot ou -incl.- fou en matesa), qui est très léger , simple à configurer : il m'a permis sous RPi B+ de consulter très confortablement des fichiers html locaux après l'avoir téléchargé depuis les dépôts officiels de rapsbian.

chuspyto27
Messages : 33
Enregistré le : lun. 10 août 2015 09:24

Re: probleme avec chromium

Message par chuspyto27 » sam. 22 août 2015 08:49

En fait j'ai besoin d'une pisé charge de .css et Javascript.pour le moment je n'arrive toujours pas a ouvrir un php avec chromium

Répondre

Retourner vers « Débutants »