Mise en ligne de mon serveur WEB

Vous venez de déballer votre Raspberry Pi et vous vous posez des questions ? C'est ici que ça se passe !

Modérateurs : Francois, EVOTk

darkprocess75
Messages : 88
Enregistré le : dim. 11 oct. 2015 21:17

Re: Mise en ligne de mon serveur WEB

Message par darkprocess75 » sam. 16 janv. 2016 14:12

Sauf que si la route du pi n'est pas en place impossible pour le pi de dialoguer avec l'exterieur d'ou ma demande de ping

darkprocess75
Messages : 88
Enregistré le : dim. 11 oct. 2015 21:17

Re: Mise en ligne de mon serveur WEB

Message par darkprocess75 » sam. 16 janv. 2016 14:14

Comment le pi est connecté au reseau ethernet ou wifi? Que donne la commande ifconfig?

darkprocess75
Messages : 88
Enregistré le : dim. 11 oct. 2015 21:17

Re: Mise en ligne de mon serveur WEB

Message par darkprocess75 » sam. 16 janv. 2016 14:15

Et la commande tracert www.google.fr

darkprocess75
Messages : 88
Enregistré le : dim. 11 oct. 2015 21:17

Re: Mise en ligne de mon serveur WEB

Message par darkprocess75 » sam. 16 janv. 2016 14:16

Et iptables -L

enzobes

Re: Mise en ligne de mon serveur WEB

Message par enzobes » sam. 16 janv. 2016 17:58

Oui c'est ça mon problème l'adresse que je ping depuis l'exterieur est du type : 82.239
et je ne pense pas avoir de Firewall sur mon RasPi étant donné que je n'ai rien installé de tel

J'ai même essayer la redirection DNS avec mon propre nom de domaine et toujours rien ....

domi
Administrateur
Messages : 2853
Enregistré le : mer. 17 sept. 2014 18:12
Localisation : Seine et Marne

Re: Mise en ligne de mon serveur WEB

Message par domi » sam. 16 janv. 2016 20:25

Si tu ping ton IP, la redirection du nom de domaine sera pour la seconde étape.

Tu dis avoir réalisé les redirections http et https sur ton routeur (ta box), tu n'as pas déjà les ports 80 et 443 de redirigés sur une autre machine ?

Tu utilises quoi pour owncloud, http ou https ?
Tu confirmes qu'en entrant l'adresse IP privée du Rpi (192.168.0.11) depuis ton réseau local, tu accèdes bien à Owncloud sur le Rpi ?
Passionné de Raspberry, Arduino, ESP8266, ESP32, et objets connectés :
Spécial débutant, concevez vous-même votre domotique DIY : https://www.youtube.com/c/DomoticDIY

enzobes

Re: Mise en ligne de mon serveur WEB

Message par enzobes » sam. 16 janv. 2016 21:37

domi a écrit :Si tu ping ton IP, la redirection du nom de domaine sera pour la seconde étape.

Tu dis avoir réalisé les redirections http et https sur ton routeur (ta box), tu n'as pas déjà les ports 80 et 443 de redirigés sur une autre machine ?

Tu utilises quoi pour owncloud, http ou https ?
Tu confirmes qu'en entrant l'adresse IP privée du Rpi (192.168.0.11) depuis ton réseau local, tu accèdes bien à Owncloud sur le Rpi ?
Je ne pense pas avoir déjà utilisés ces ports pour une autre machine c'est le premier serveur que je met en place.
Pour owncloud j'ai du http ( la case pour forcer le https dans les paramètres de owncloud est grisée et je ne peux pas cliqué dessus).
Si je tape l'adresse ip du pi (192.168.0.11) depuis mon PC Conncté en ethernet j'accede bien à owncloud.

domi
Administrateur
Messages : 2853
Enregistré le : mer. 17 sept. 2014 18:12
Localisation : Seine et Marne

Re: Mise en ligne de mon serveur WEB

Message par domi » sam. 16 janv. 2016 22:29

enzobes a écrit :Si je tape l'adresse ip du pi (192.168.0.11) depuis mon PC Conncté en ethernet j'accede bien à owncloud.
Le problème doit donc provenir du routage de la box, je vais essayé de t'aider, car si je connais le principe du routage, je ne connais pas l'interface de la freebox crystal :cry:
Il se fait comment le réglage sur la freebox crystal ?
il y a une interface intégrée comme la freebox révolution, ou c'est via le site Free comme pour la freebox v5 ?
Passionné de Raspberry, Arduino, ESP8266, ESP32, et objets connectés :
Spécial débutant, concevez vous-même votre domotique DIY : https://www.youtube.com/c/DomoticDIY

enzobes

Re: Mise en ligne de mon serveur WEB

Message par enzobes » dim. 17 janv. 2016 02:24

Merci pour ton aide :)
C'est directement depuis le site Free je n'ai pas accès à FreeOS avec la crystal

darkprocess75
Messages : 88
Enregistré le : dim. 11 oct. 2015 21:17

Re: Mise en ligne de mon serveur WEB

Message par darkprocess75 » dim. 17 janv. 2016 02:55

As tu rebooter la freebox pour quel prenne en compte tes regles de NAT?

Répondre

Retourner vers « Débutants »