Projet de débutant :)

Vous venez de déballer votre Raspberry Pi et vous vous posez des questions ? C'est ici que ça se passe !

Modérateurs : Francois, EVOTk

Avatar du membre
Oliver17
Raspinaute
Messages : 193
Enregistré le : lun. 18 avr. 2016 09:59

Re: Projet de débutant :)

Message par Oliver17 » mer. 8 juin 2016 17:12

vague nerd a écrit :
si ADAFRUIT avaient commencé par signaler ce problème, je n'aurais jamais acheter leurs faux produit lol
Rhôoo l'autre, il achète un clone à bas coût sur un site chinois (pour moins cher que la tva du produit initial), et ensuite et pourrit le gentil éditeur opensource :mrgreen: !
Cdt.
Je ne vais pas me gener, ils auraient du le signaler, imagine les gars qui achètent leurs module ADAFRUIT pour ce rendre compte que ça ne fonctionne pas sur python 3, super, bonne technique d'arnaque j'avoue. :)

MErci

Avatar du membre
vague nerd
Modérateur
Messages : 1471
Enregistré le : mar. 14 oct. 2014 11:42
Localisation : France !

Re: Projet de débutant :)

Message par vague nerd » mer. 8 juin 2016 17:38

Donc comme posté plus haut, comment je peux faire un upgrade :

Edit 11:04 : Bon j'ai refais la manip pour le python 3
https://github.com/adafruit/Adafruit-Ra ... ython-Code

le truc sur la fin c'est que ça me dit : sudo pip3 install rpi.gpio
et donc
Requirement already satisfied (use --upgrade to updrade): rpi.gpio in /usr/lib/python3/dist-packages
Cleaning up...


Ça ce trouve ça fonctionnera peut être après, faut tester mais je ne sais pas faire un upgrade d'un truc précis.
Je n'ai pas compris...
Je ne vais pas me gener, ils auraient du le signaler, imagine les gars qui achètent leurs module ADAFRUIT pour ce rendre compte que ça ne fonctionne pas sur python 3, super, bonne technique d'arnaque j'avoue.
Je ne suis pas d'accord avec toi. Adafruit fournit un module (opensource qui plus est). Adafruit n'est pas responsable de l'évolution d'un langage permettant ou pas de l'utiliser.
EDIT : en plus, je ne vois même pas où ils mentionnent que le module est compatible python ! Tu imagines s'ils devaient donner la liste des langages incompatible (pas compatible avec basic, turbo pascal, ...) !
Cdt.
Cordialement,

Vague Nerd

Avatar du membre
Oliver17
Raspinaute
Messages : 193
Enregistré le : lun. 18 avr. 2016 09:59

Re: Projet de débutant :)

Message par Oliver17 » mer. 8 juin 2016 17:42

Je n'ai pas compris...
Pas grave, je cherche une autre solution pour piloter beaucoup de servomoteurs et de préférence que ça tourne sur python 3 :)
Je ne suis pas d'accord avec toi. Adafruit fournit un module (opensource qui plus est). Adafruit n'est pas responsable de l'évolution d'un langage permettant ou pas de l'utiliser.
Pour fidéliser un client et en acquérir de nouveaux tu fais toujours en sorte de faire évoluer aussi ton produit, dans ce cas présent, il n'y a aucun intérêt à acheter ce module de chez ADAFRUIT si il n'est pas compatible avec certains langage qui eux évoluent, faut suivre le mouvement, ou le signaler (ne fonctionne pas avec python 3 etc etc), car pour un gars comme moi qui ne sais pas modifier ces programmes afin que tout tourne bien, et bien le module ne m'est d'aucune utilisé et donc incompatible.



Merci
Modifié en dernier par Oliver17 le mer. 8 juin 2016 17:48, modifié 1 fois.

Avatar du membre
vague nerd
Modérateur
Messages : 1471
Enregistré le : mar. 14 oct. 2014 11:42
Localisation : France !

Re: Projet de débutant :)

Message par vague nerd » mer. 8 juin 2016 17:46

Oups, j'ai édité mes posts précédents pendant que tu rédigeais. On se relit mutuellement ?
Cdt.
Cordialement,

Vague Nerd

Avatar du membre
Oliver17
Raspinaute
Messages : 193
Enregistré le : lun. 18 avr. 2016 09:59

Re: Projet de débutant :)

Message par Oliver17 » mer. 8 juin 2016 17:49

vague nerd a écrit :Oups, j'ai édité mes posts précédents pendant que tu rédigeais. On se relit mutuellement ?
Cdt.

Lol, pas de soucis :)

Avatar du membre
vague nerd
Modérateur
Messages : 1471
Enregistré le : mar. 14 oct. 2014 11:42
Localisation : France !

Re: Projet de débutant :)

Message par vague nerd » mer. 8 juin 2016 17:50

Tu es sûr de l'incompatibilité avec pithon 3 ?
Sur les GIT, je lis :
sudo apt-get update
sudo apt-get install -y python3 python3-pip python-dev
sudo pip3 install rpi.gpio
Je n'ai pas le module, je ne peux pas t'aider beaucoup...

Au fait, pourquoi veux-tu un module pour le pwm ? Pour ne pas monopoliser trop de GPIO ?

Cdt.
Cordialement,

Vague Nerd

Avatar du membre
Oliver17
Raspinaute
Messages : 193
Enregistré le : lun. 18 avr. 2016 09:59

Re: Projet de débutant :)

Message par Oliver17 » mer. 8 juin 2016 17:56

vague nerd a écrit :Tu es sûr de l'incompatibilité avec pithon 3 ?
Sur les GIT, je lis :
sudo apt-get update
sudo apt-get install -y python3 python3-pip python-dev
sudo pip3 install rpi.gpio
Je n'ai pas le module, je ne peux pas t'aider beaucoup...

Au fait, pourquoi veux-tu un module pour le pwm ? Pour ne pas monopoliser trop de GPIO ?

Cdt.
J'ai fais tout ça, mais je n'arrive à rien avec ce module (sans commentaire pour ne pas dénigrer leurs produits), et donc ce que j'ai acheté c'était dans l'espoir de pouvoir contrôler tout les servomoteurs et au moment venu d'en acheter un autre pour les autres servomoteurs.
Pour l'instant j'en ai 7, mais d'autres viendront plus tard (si j'arrive au moins à les controler).

MAis là je t'avoue que tout ce mélange du moins c'est épuisant (sans commentaire une nouvelle fois pour éviter de passer pour quelqu'un de désagréable lol).
...


Pas grave que tu n'es pas ce module, c'est déjà sympa à vous de prendre du temps pour m'aider :)
Je vais tout simplement chercher une autre solution. :p

Merci

Avatar du membre
vague nerd
Modérateur
Messages : 1471
Enregistré le : mar. 14 oct. 2014 11:42
Localisation : France !

Re: Projet de débutant :)

Message par vague nerd » mer. 8 juin 2016 18:00

Je ne sais pas si tu as vu, mais dans ce lien que tu as posté dans un autre thread, quelqu'un a adapté le code pour python 3...
Cdt.
Cordialement,

Vague Nerd

Avatar du membre
Oliver17
Raspinaute
Messages : 193
Enregistré le : lun. 18 avr. 2016 09:59

Re: Projet de débutant :)

Message par Oliver17 » mer. 8 juin 2016 18:16

vague nerd a écrit :Je ne sais pas si tu as vu, mais dans ce lien que tu as posté dans un autre thread, quelqu'un a adapté le code pour python 3...
Cdt.
Je sais, c'est ce que j'ai dis plus haut, mais j'ai pas réussi à en faire quoi que ce soit des fichiers du gars, j'ai cherché ou les coller pour faire de nouveau une install, mais non pas trouvé , sinon j'ai tout installer pour python 3 smbus et i2c via les liens que j'ai donné plus haut dans le git, dans le doute, mais rien y fais...


Merci

guillaume9344
Raspinaute
Messages : 629
Enregistré le : mar. 6 janv. 2015 19:44
Localisation : finistere

Re: Projet de débutant :)

Message par guillaume9344 » mer. 8 juin 2016 19:02

Oliver17 a écrit : sinon j'ai tout installer pour python 3 smbus et i2c via les liens que j'ai donné plus haut dans le git, dans le doute, mais rien y fais...
Merci
Donc vous avez un bus I2C fonctionnel avec Python3 ? (vos gyro sont peut etre aussi en I2C?) c'est a dire pouvoir envoyer une donnée à écrire et lire dans un registre d'un périférique I2C ?
Si c'est le cas avec le datasheet
http://pdf1.alldatasheet.fr/datasheet-p ... A9685.html
vous avez tous ce qui faut pour commander le module d'adafruit.
Souvant les programmes de démonstration des vendeurs sont trés pratiques pour vérifier q'un module fonctionne "out the box" mais sont moins souvant obtimisés pour toutes les fonctions ou possibilités des circuits internes .
Et même si les programmes de tests suffisent à l 'utilisation que l 'on a , c'est jamais une perte de temps de consulter la doc .
Loin de moi l 'idée de vouloir vous décourager , je propose même mon aide pour le déchifrage des datasheets (à plusieur on devrais s'en sortir) et pour l'essai du code ( bon Python je connais pas bien mais c'est peut etre l 'occase de mi m'etre.)

bon courage
@+
rpi b+ ,osmc, motioneyes
rpi 2 raspbian , server minecraft 24h/24 , utilisation gpio
orange pi pc debian ,utilisation gpio, motion cam

Répondre

Retourner vers « Débutants »