Mode graphique

Vous venez de déballer votre Raspberry Pi et vous vous posez des questions ? C'est ici que ça se passe !

Modérateurs : Francois, EVOTk

Difanel
Messages : 9
Enregistré le : sam. 5 août 2017 15:00

Mode graphique

Message par Difanel » sam. 5 août 2017 15:13

Bonjour
Je suis novice et je viens de recevoir mon RaspberryPi 3B. Je viens de l'installer et quand je le démarre l'ecran s'affiche en mode console et me demande mon mot de passe. Mais comme je n'ai pas de clavier, je me connecte en ssh via mon pc sous linux. Or je voudrai que mon Raspberry s'affiche en mode graphique. Comment faire ?
Merci de votre aide

spourre
Raspinaute
Messages : 735
Enregistré le : lun. 22 déc. 2014 16:50
Localisation : 67380 LINGOLSHEIM

Re: Mode graphique

Message par spourre » sam. 5 août 2017 19:34

Bonjour,

connectez-vous en ssh comme vous savez le faire.
au prompt, tapez la commande:

Code : Tout sélectionner

$ sudo raspi-config
C'est dans les options du boot.

Sylvain

Difanel
Messages : 9
Enregistré le : sam. 5 août 2017 15:00

Re: Mode graphique

Message par Difanel » sam. 5 août 2017 20:29

Merci Spoure
c'est ce que j'ai fait, mais j'ai plusieurs choix et je ne sais pas lequel prendre.
Dans Boot Options j'ai les lignes suivantes :
B1 Desktop / CLI
B2 Wait for Network at Boot
B3 Splash Screen

puis j'ai choisi B1 Desktop / CLI et dans ce choix plusieurs solutions
B1 Console Text console, requiring user to login
B2 Console autologin Text console, automatically logged in as 'pi' user
B3 Desktop Desktop GUI, requiring user to login
B4 Desktop Autologin Desktop GUI, automatically logged in as 'pi' user

Quelle ligne dois-je utiliser ?
Merci

spourre
Raspinaute
Messages : 735
Enregistré le : lun. 22 déc. 2014 16:50
Localisation : 67380 LINGOLSHEIM

Re: Mode graphique

Message par spourre » sam. 5 août 2017 23:43

CLI = Command Line Interface = ligne de commande (comme le vieux DOS).
GUI = Graphical User Interface = mode graphique.

Autologin = connexion automatique.

Donc, si vous souhaitez arriver directement au mode graphique, sans entrer de login ni de mot de passe, choisissez :
B4 Desktop Autologin Desktop GUI, automatically logged in as 'pi' user
Si vous souhaitez lancer automatiquement le mode graphique mais rentrer le login et le mot de passe, choisissez:
B3 Desktop Desktop GUI, requiring user to login
N'hésiez pas à redemander si ce n'est pas assez clair.

Sylvain

Difanel
Messages : 9
Enregistré le : sam. 5 août 2017 15:00

Re: Mode graphique

Message par Difanel » dim. 6 août 2017 10:06

Bonjour et merci Sylvain de ton aide
J'ai donc validé la ligne B1 Desktop / CLI, pluis B4 Desktop Autologin Desktop GUI, automatically logged in as 'pi' user
et là j'ai le message d'erreur suivant : There was an error running option B1 Desktop / CLI
et quelque soit la ligne que je valide j'ai le même message d'erreur.
Que faire ?
Bonne journée
Didier

spourre
Raspinaute
Messages : 735
Enregistré le : lun. 22 déc. 2014 16:50
Localisation : 67380 LINGOLSHEIM

Re: Mode graphique

Message par spourre » dim. 6 août 2017 10:27

On ne rappellera jamais assez que pour aider à dépanner, il faut un maximum d'information :twisted:
Quel est le système utilisé (Raspbian, autre ..)
Comment a-t-il été installé (direct sous Windows, sous Linux, avec noob...)
Comment est-tus loggé (ssh, console avec câble USB ...)
Comment l'écran est-il connecté (TV ou moniteur en HDMI...)
A+

Sylvain

Difanel
Messages : 9
Enregistré le : sam. 5 août 2017 15:00

Re: Mode graphique

Message par Difanel » dim. 6 août 2017 11:05

Merci de prendre un peu de temps pour m'aider
Réponse à tes questions :
Système Rapbian installé avec noob
Raspberry connecté à ma freebox par cable éthernet
Pas de clavier ni d'écran mais relié à ma Tv via cable Hdmi
A ta disposition

Didier

spourre
Raspinaute
Messages : 735
Enregistré le : lun. 22 déc. 2014 16:50
Localisation : 67380 LINGOLSHEIM

Re: Mode graphique

Message par spourre » dim. 6 août 2017 12:35

OK
La carte noob, elle est venue avec le Raspberry ou tu l'as téléchargée ?
Quelle version de Raspbian as-tu choisie ?

Par hasard, as-tu eu un message d'erreur dans une fenêtre à quitter avec ok, du style :

Code : Tout sélectionner

Do sudo apt-get install lightdm to allow configuration   │
                                    │ of boot to desktop                                     
Courage

Sylvain

Difanel
Messages : 9
Enregistré le : sam. 5 août 2017 15:00

Re: Mode graphique

Message par Difanel » dim. 6 août 2017 13:55

voila le msg d'erreur
/home/didier/Images/Capture du 2017-08-06 13-52-35.png

La carte noob était avec le raspberry, concernant la version il me semble que c'est la version complète

A+

Difanel
Messages : 9
Enregistré le : sam. 5 août 2017 15:00

Re: Mode graphique

Message par Difanel » dim. 6 août 2017 13:57

L'image n'apparait pas

Quand je valide par OK la dernière ligne, voici le msg d'erreur qui apparait

There was an error running option B1 Desktop / CLI │
│ │
│ │
│ │
│ │
│ │
│ │
│ │
│ │
│ │
│ │
│ │
│ │
│ │
│ │
│ <Ok> │
│ │
└───────────────────────────────────────────────────

Répondre

Retourner vers « Débutants »