mon login plante

Vous venez de déballer votre Raspberry Pi et vous vous posez des questions ? C'est ici que ça se passe !

Modérateurs : Francois, EVOTk

Ferois
Messages : 39
Enregistré le : jeu. 16 mars 2017 09:08

mon login plante

Message par Ferois » mar. 31 oct. 2017 10:46

Bonjour,

Après des manœuvres à l'arrache un peu trop hasardeuses, je me retrouve au démarrage de la bête avec une fenêtre qui me demande de choisir un utilisateur.
Si j'indique "pi" avec son mot de passe, l'écran passe au noir puis me présente à nouveau la même fenêtre passe au noir puis me présente à nouveau passe au noir puis me présente à nouveau etc.
Pour m'en sortir, avec "autre" j'indique "root".
J'ai essayé, avec raspi-config, l'option de boot "B4 Desktop Autologin Desktop GUI", mais cela ne marche pas.

Comment revenir à la situation initiale sans demande de mot de passe au lancement ?
Merci de votre aide !

jelopo
Raspinaute
Messages : 158
Enregistré le : mer. 11 oct. 2017 10:23

Re: mon login plante

Message par jelopo » mer. 1 nov. 2017 14:59

Bonjour,

Essayer de modifier /etc/lightdm/lightdm.conf avec autologin-user=pi
On sait jamais...

N.B. : Pour se connecter sur une autre fenêtre en non graphique "Ctrl+alt+F1"

A+

Ferois
Messages : 39
Enregistré le : jeu. 16 mars 2017 09:08

Re: mon login plante

Message par Ferois » jeu. 2 nov. 2017 22:07

J'ai déjà fait cette modif (autologin-user=pi et autologin-user-timeout=0) sans résultat.

Korhm
Raspinaute
Messages : 232
Enregistré le : ven. 19 sept. 2014 08:13
Localisation : Toulouse

Re: mon login plante

Message par Korhm » sam. 4 nov. 2017 12:32

Bonjour,

Pourrais tu donner le retour des commandes suivantes :
  • cat /etc/passwd
  • cat /home/pi/.xinitrc

Ferois
Messages : 39
Enregistré le : jeu. 16 mars 2017 09:08

Re: mon login plante

Message par Ferois » sam. 4 nov. 2017 14:30

Korhm a écrit :
Pourrais tu donner le retour des commandes suivantes :

cat /etc/passwd
cat /home/pi/.xinitrc

Code : Tout sélectionner

root@pi:~# cat /etc/passwd

root:x:0:0:root:/root:/bin/bash
daemon:x:1:1:daemon:/usr/sbin:/usr/sbin/nologin
bin:x:2:2:bin:/bin:/usr/sbin/nologin
sys:x:3:3:sys:/dev:/usr/sbin/nologin
sync:x:4:65534:sync:/bin:/bin/sync
games:x:5:60:games:/usr/games:/usr/sbin/nologin
man:x:6:12:man:/var/cache/man:/usr/sbin/nologin
lp:x:7:7:lp:/var/spool/lpd:/usr/sbin/nologin
mail:x:8:8:mail:/var/mail:/usr/sbin/nologin
news:x:9:9:news:/var/spool/news:/usr/sbin/nologin
uucp:x:10:10:uucp:/var/spool/uucp:/usr/sbin/nologin
proxy:x:13:13:proxy:/bin:/usr/sbin/nologin
www-data:x:33:33:www-data:/var/www:/usr/sbin/nologin
backup:x:34:34:backup:/var/backups:/usr/sbin/nologin
list:x:38:38:Mailing List Manager:/var/list:/usr/sbin/nologin
irc:x:39:39:ircd:/var/run/ircd:/usr/sbin/nologin
gnats:x:41:41:Gnats Bug-Reporting System (admin):/var/lib/gnats:/usr/sbin/nologin
nobody:x:65534:65534:nobody:/nonexistent:/usr/sbin/nologin
systemd-timesync:x:100:103:systemd Time Synchronization,,,:/run/systemd:/bin/false
systemd-network:x:101:104:systemd Network Management,,,:/run/systemd/netif:/bin/false
systemd-resolve:x:102:105:systemd Resolver,,,:/run/systemd/resolve:/bin/false
systemd-bus-proxy:x:103:106:systemd Bus Proxy,,,:/run/systemd:/bin/false
pi:x:1000:1000:,,,:/home/pi:/bin/bash
messagebus:x:104:109::/var/run/dbus:/bin/false
avahi:x:105:110:Avahi mDNS daemon,,,:/var/run/avahi-daemon:/bin/false
ntp:x:106:111::/home/ntp:/bin/false
sshd:x:107:65534::/var/run/sshd:/usr/sbin/nologin
statd:x:108:65534::/var/lib/nfs:/bin/false
lightdm:x:109:114:Light Display Manager:/var/lib/lightdm:/bin/false
pulse:x:110:116:PulseAudio daemon,,,:/var/run/pulse:/bin/false
rtkit:x:111:118:RealtimeKit,,,:/proc:/bin/false


Code : Tout sélectionner

root@pi:~# cat /home/pi/.xinitrc

cat: /home/pi/.xinitrc: Aucun fichier ou dossier de ce type

Korhm
Raspinaute
Messages : 232
Enregistré le : ven. 19 sept. 2014 08:13
Localisation : Toulouse

Re: mon login plante

Message par Korhm » sam. 4 nov. 2017 20:27

Et as tu un fichier /home/pi/bash_profile ?
C'est lui qui dit quoi faire quand le Shell (ici bash) se lance après le login de l'utilisateur en question

Ferois
Messages : 39
Enregistré le : jeu. 16 mars 2017 09:08

Re: mon login plante

Message par Ferois » sam. 4 nov. 2017 21:31

Trois bash : bash_history, bash_logout et bashrc, mais pas de bash_profile
par contre un .profil

Code : Tout sélectionner

# ~/.profile: executed by the command interpreter for login shells.
# This file is not read by bash(1), if ~/.bash_profile or ~/.bash_login
# exists.
# see /usr/share/doc/bash/examples/startup-files for examples.
# the files are located in the bash-doc package.

# the default umask is set in /etc/profile; for setting the umask
# for ssh logins, install and configure the libpam-umask package.
#umask 022

# if running bash
if [ -n "$BASH_VERSION" ]; then
    # include .bashrc if it exists
    if [ -f "$HOME/.bashrc" ]; then
        . "$HOME/.bashrc"
    fi
fi

# set PATH so it includes user's private bin if it exists
if [ -d "$HOME/bin" ] ; then
    PATH="$HOME/bin:$PATH"
fi

Artemus24
Raspinaute
Messages : 439
Enregistré le : ven. 15 sept. 2017 19:15

Re: mon login plante

Message par Artemus24 » dim. 5 nov. 2017 11:46

Salut Ferois.
Ferois a écrit :je me retrouve au démarrage de la bête avec une fenêtre qui me demande de choisir un utilisateur.
La bête ??? De quoi parlez-vous ? Si c'est une raspberry, de quel modèle ? Il y en a cinq actuellement : A, A+, B, B+, 2B et 3B ?

Ensuite, dans quel OS vous vous trouvez ? Raspbian ? Autre ? Si oui lequel ?

Vous parlez d'un démarrage, lequel ?
En branchant votre raspberry à un clavier, souris et sur votre téléviseur ou un monitor ?
Ou bien en SSH ?

Vous dites :
Ferois a écrit :J'ai essayé, avec raspi-config, l'option de boot "B4 Desktop Autologin Desktop GUI", mais cela ne marche pas.
Donc vous avez pu vous connecter.

Pourriez-vous nous donner une image de ce que vous obtenez, car votre problème n'est pas très clair.

@+
--> RPi0v1.3, RPi0W, Rpi3A+, Rpi3B+
--> Rpi0WH + Tuner TV HAT
--> RPi 2B + Joy-It I2C Serial 20x4 2004 LCD Module
--> RPi 2B + PIM273 Unicorn HAT HD 16x16 Leds RGB

Ferois
Messages : 39
Enregistré le : jeu. 16 mars 2017 09:08

Re: mon login plante

Message par Ferois » dim. 5 nov. 2017 13:08

Artemus24 a écrit :Donc vous avez pu vous connecter.
Oui, comme je l'indique :
Pour m'en sortir, avec "autre" j'indique "root".
Image

D'autant plus étrange que :
- en SSH je me connecte en pi sans problème, mais l'accès en root est refusé
- en VNC je me connecte en root sans problème, mais l'accès en pi est refusé
Bien sûr avec les mêmes mots de passe !

Je cherche quel est le programme qui gère la fenêtre de login, ici sur debian. Il ne doit pas y avoir beaucoup de différence, quel que sois la distribution ou la variété de framboise.
Il devrait se trouver dans la liste :

Code : Tout sélectionner

alsa-utils                0:off  1:off  2:off  3:off  4:off  5:off  6:off  S:on 
avahi-daemon              0:off  1:off  2:on   3:on   4:on   5:on   6:off
bluetooth                 0:off  1:off  2:on   3:on   4:on   5:on   6:off
bootlogs                  0:off  1:on   2:on   3:on   4:on   5:on   6:off
bootmisc.sh               0:off  1:off  2:off  3:off  4:off  5:off  6:off  S:on 
checkfs.sh                0:off  1:off  2:off  3:off  4:off  5:off  6:off  S:on 
checkroot-bootclean.sh    0:off  1:off  2:off  3:off  4:off  5:off  6:off  S:on 
checkroot.sh              0:off  1:off  2:off  3:off  4:off  5:off  6:off  S:on 
console-setup             0:off  1:off  2:off  3:off  4:off  5:off  6:off  S:on 
cron                      0:off  1:off  2:on   3:on   4:on   5:on   6:off
dbus                      0:off  1:off  2:on   3:on   4:on   5:on   6:off
dhcpcd                    0:off  1:off  2:on   3:on   4:on   5:on   6:off
dphys-swapfile            0:off  1:off  2:on   3:on   4:on   5:on   6:off
fake-hwclock              0:off  1:off  2:off  3:off  4:off  5:off  6:off  S:on 
hostname.sh               0:off  1:off  2:off  3:off  4:off  5:off  6:off  S:on 
hwclock.sh                0:off  1:off  2:off  3:off  4:off  5:off  6:off
kbd                       0:off  1:off  2:off  3:off  4:off  5:off  6:off  S:on 
keyboard-setup            0:off  1:off  2:off  3:off  4:off  5:off  6:off  S:on 
killprocs                 0:off  1:on   2:off  3:off  4:off  5:off  6:off
kmod                      0:off  1:off  2:off  3:off  4:off  5:off  6:off  S:on 
lightdm                   0:off  1:off  2:on   3:on   4:on   5:on   6:off
motd                      0:off  1:on   2:on   3:on   4:on   5:on   6:off
mountall-bootclean.sh     0:off  1:off  2:off  3:off  4:off  5:off  6:off  S:on 
mountall.sh               0:off  1:off  2:off  3:off  4:off  5:off  6:off  S:on 
mountdevsubfs.sh          0:off  1:off  2:off  3:off  4:off  5:off  6:off  S:on 
mountkernfs.sh            0:off  1:off  2:off  3:off  4:off  5:off  6:off  S:on 
mountnfs-bootclean.sh     0:off  1:off  2:off  3:off  4:off  5:off  6:off  S:on 
mountnfs.sh               0:off  1:off  2:off  3:off  4:off  5:off  6:off  S:on 
networking                0:off  1:off  2:off  3:off  4:off  5:off  6:off  S:on 
nfs-common                0:off  1:off  2:off  3:off  4:off  5:off  6:off
ntp                       0:off  1:off  2:on   3:on   4:on   5:on   6:off
plymouth                  0:off  1:off  2:on   3:on   4:on   5:on   6:off
plymouth-log              0:off  1:off  2:off  3:off  4:off  5:off  6:off  S:on 
procps                    0:off  1:off  2:off  3:off  4:off  5:off  6:off  S:on 
raspi-config              0:off  1:off  2:off  3:off  4:off  5:off  6:off  S:on 
rc.local                  0:off  1:off  2:on   3:on   4:on   5:on   6:off
rcS                       0:off  1:off  2:off  3:off  4:off  5:off  6:off
rmnologin                 0:off  1:off  2:on   3:on   4:on   5:on   6:off
rpcbind                   0:off  1:off  2:off  3:off  4:off  5:off  6:off
rsync                     0:off  1:off  2:on   3:on   4:on   5:on   6:off
rsyslog                   0:off  1:off  2:on   3:on   4:on   5:on   6:off
sendsigs                  0:off  1:off  2:off  3:off  4:off  5:off  6:off
ssh                       0:off  1:off  2:on   3:on   4:on   5:on   6:off
sudo                      0:off  1:off  2:off  3:off  4:off  5:off  6:off
triggerhappy              0:off  1:off  2:on   3:on   4:on   5:on   6:off
udev                      0:off  1:off  2:off  3:off  4:off  5:off  6:off  S:on 
udev-finish               0:off  1:off  2:off  3:off  4:off  5:off  6:off  S:on 
umountfs                  0:off  1:off  2:off  3:off  4:off  5:off  6:off
umountnfs.sh              0:off  1:off  2:off  3:off  4:off  5:off  6:off
umountroot                0:off  1:off  2:off  3:off  4:off  5:off  6:off
urandom                   0:off  1:off  2:off  3:off  4:off  5:off  6:off  S:on 
x11-common                0:off  1:off  2:off  3:off  4:off  5:off  6:off  S:on 
Modifié en dernier par Ferois le mar. 7 nov. 2017 11:49, modifié 1 fois.

Artemus24
Raspinaute
Messages : 439
Enregistré le : ven. 15 sept. 2017 19:15

Re: mon login plante

Message par Artemus24 » lun. 6 nov. 2017 10:40

Salut Ferois.

D'après l'image, vous accédez à votre raspberry en mode Bureau (ou graphique si vous préférez). Et il vous demande un compte et un mot de passe.
Normalement, par défaut, le login est automatique et c'est celui du compte PI.

Comment revenir dans ce mot par défaut ?
Dans le bureau, vous cliquez sur l'icône (la framboise) en haut à gauche et vous sélectionnez "préférence", puis "configuration du raspberry pi".
Une nouvelle fenêtre s'affiche. Vous sélectionnez l'onglet "système". A la ligne "connexion automatique", vous sélectionnez "pi".
Dorénavant, vous accéderez au compte Pi en mode automatique. Un reboot sera nécessaire pour que la modification soit prise en compte.

Pour SSH, vous devez activer le compte root.
Pour cela, vous devez vous mettre dans le compte "root", sinon les modifications suivantes ne seront pas prise en compte.
Si vous êtes dans le compte "pi", vous tapez "su root".

Vous vous rendez dans le répertoire "/etc/ssh". vous ouvrez le fichier "sshd_config".
Recherchez la ligne "#PermitRootLogin". En principe, vous devez avoir le paramètre "prohibit-password".

Vous supprimez le "#" devant la ligne et vous mettez comme paramètre : "yes". Ce qui donne maintenant : "PermitRootLogin yes".

Vous redémarrez votre raspberry (reboot) et en principe, cela devrait fonctionner.
J'espère que vous avez attrribué un mot de passe à votrre compte "root".

Pour VNC, je ne connais pas car je ne l'utilise pas.
J'accède à ma raspberry uniquement par SSH.

@+
--> RPi0v1.3, RPi0W, Rpi3A+, Rpi3B+
--> Rpi0WH + Tuner TV HAT
--> RPi 2B + Joy-It I2C Serial 20x4 2004 LCD Module
--> RPi 2B + PIM273 Unicorn HAT HD 16x16 Leds RGB

Répondre

Retourner vers « Débutants »