[RESOLU] Problème avec Huawei E220

Piloter son installation depuis son smartphone, envoyer ou recevoir des SMS d'alerte... C'est ici !

Modérateur : Francois

Répondre
Korhm
Raspinaute
Messages : 219
Enregistré le : ven. 19 sept. 2014 08:13
Localisation : Val de Marne

[RESOLU] Problème avec Huawei E220

Message par Korhm » lun. 16 nov. 2015 17:19

Bonjour à tous,

depuis quelques temps j'ai un problème avec mon dongle 3g Huawei E220.
Je m'en sers comme passerelle sms.
Le symptôme principal est le reset du boitier dès qu'il essai d'accrocher le réseau. C'est du moins l'impression que j'ai...
Tout marchait de manière correcte jusqu'à récemment


Au début je faisais des tests avec gammu, et les logs montraient que dès que le code pin était entré, le dongle redémare. C'est pour celà que j'en déduit que cela se passe au moment d'accrocher le réseau.
Pour valider celà, j'ai tenté directement avec des commandes AT

Le device est bien présent:

Code : Tout sélectionner

$ ll /dev/ttyUSB0
crw-rw---T 1 root dialout 188, 0 nov.  16 17:09 /dev/ttyUSB0
Connexion en série pour entrer le PIN :

Code : Tout sélectionner

$ sudo picocom -b 115200 /dev/ttyUSB0
picocom v1.7

port is        : /dev/ttyUSB0
flowcontrol    : none
baudrate is    : 115200
parity is      : none
databits are   : 8
escape is      : C-a
local echo is  : no
noinit is      : no
noreset is     : no
nolock is      : no
send_cmd is    : sz -vv
receive_cmd is : rz -vv
imap is        :
omap is        :
emap is        : crcrlf,delbs,

Terminal ready
AT+CPIN?
+CPIN: SIM PIN

OK
AT+CPIN=1234
OK

FATAL: term closed
term_exitfunc: reset failed for dev UNKNOWN: Input/output error
Le device est en train de rédémarrer :

Code : Tout sélectionner

$ ll /dev/ttyUSB0
ls: impossible d'accéder à /dev/ttyUSB0: Aucun fichier ou dossier de ce type

J'ai tenté plusieurs choses :
- deux cartes sim différentes (une free mobile dédiée à ce dongle normalement, une SFR)
- plusieurs câble usb, même un câble en Y

Seul le dongle n'a pas été changé, à ce prix je préféré être sur qu'il ai un problème avant de le changer, et pas moyen de m'en faire prêter un.

A priori il s'agit du dernier firmware dispo pour ce device

Code : Tout sélectionner

$ sudo gammu identify
Périphérique       : /dev/ttyUSB0
Fabricant            : Huawei
Modèle              : E220 (E220)
Firmware             : 11.313.02.00.01
IMEI                 : xxxxxxx
Est-ce que quelqu'un aurait une idée pour résoudre mon problème ? :D :?: :D
Modifié en dernier par Korhm le sam. 26 déc. 2015 19:28, modifié 1 fois.

Korhm
Raspinaute
Messages : 219
Enregistré le : ven. 19 sept. 2014 08:13
Localisation : Val de Marne

Re: Problème avec Huawei E220

Message par Korhm » sam. 26 déc. 2015 19:28

Bonsoir,

Bon finalement j'ai pu trouver un dongle de remplacement (Huawei E1752), et une fois desimlocké tout semble marcher parfaitement avec gammu :)

Répondre

Retourner vers « Téléphonie et télécommunication »