Relevé température ds1820

Au programme la régulation de température, la climatisation, les chauffe-eau...

Modérateur : Francois

Nanard
Messages : 22
Enregistré le : jeu. 15 déc. 2016 12:26

Relevé température ds1820

Message par Nanard » sam. 17 déc. 2016 16:03

Bonjour,

Je tente de solutionner mon problème grâce à votre aide.
Voila j'ai câblé une sonde ds1820 avec une résistance 4.7kOhm cependant lorsque je m'attache à configurer l'ensemble je bloque sur l'étape de code :
cat w1_slave

Le code du composant attribué est : 00-08000000000
Ce code me parait bizarre au vue des différents forum parcouru (je trouve qu'il y a trop de zero à mon gout)

Lorsque j'arrive à cette étape je trouve ce message :
cat: w1_slave: Aucun fichier ou dossier de ce type

Merci pour votre aide...

destroyedlolo
Raspinaute
Messages : 1234
Enregistré le : dim. 10 mai 2015 18:44
Localisation : Dans la campagne à côté d'Annecy
Contact :

Re: Relevé température ds1820

Message par destroyedlolo » sam. 17 déc. 2016 17:17

Salut,
Pour que ça marche, il faut que tu ais le module 1-wire chargé dans le kernel.
Est-ce le cas ?

Envoyé de mon E2303 en utilisant Tapatalk
  • BananaPI : Gentoo, disque SATA de 2 To
  • Domotique : 1-wire, TéléInfo, Tablette passée sous Gentoo, ESP8266
  • Multimedia par DNLA
  • Et pleins d'idées ... et bien sûr, pas assez de temps.
Un descriptif de ma domotique 100% fait maison.

Nanard
Messages : 22
Enregistré le : jeu. 15 déc. 2016 12:26

Re: Relevé température ds1820

Message par Nanard » sam. 17 déc. 2016 17:25

Etant débutant je ne serais pas te répondre.
Mais voici le site que j'ai suivi. https://www.domolio.fr/monitorer-la-tem ... bien-fait/
Est ce que dans le tuto y'a des étapes qui manques ?

Nanard
Messages : 22
Enregistré le : jeu. 15 déc. 2016 12:26

Re: Relevé température ds1820

Message par Nanard » sam. 17 déc. 2016 17:41

J'ai repris aussi ce tuto mais sans succès ...
http://blogmotion.fr/diy/raspberry-ds18b20-14038

guillaume9344
Raspinaute
Messages : 629
Enregistré le : mar. 6 janv. 2015 19:44
Localisation : finistere

Re: Relevé température ds1820

Message par guillaume9344 » sam. 17 déc. 2016 18:46

Bonsoir,
je n'ai pas eu de problémes pour installer ces sondes sur une orangepi , il y a les meme etapes que sur vos tutos , vérifiez bien les connections .
qu'avaez vous dans le fichier modules , avec la commande

Code : Tout sélectionner

nano /etc/modules
?
rpi b+ ,osmc, motioneyes
rpi 2 raspbian , server minecraft 24h/24 , utilisation gpio
orange pi pc debian ,utilisation gpio, motion cam

Nanard
Messages : 22
Enregistré le : jeu. 15 déc. 2016 12:26

Re: Relevé température ds1820

Message par Nanard » sam. 17 déc. 2016 18:52

Dans le fichier à la fin j'ai écrit

w1-gpio
w1-therm

Nanard
Messages : 22
Enregistré le : jeu. 15 déc. 2016 12:26

Re: Relevé température ds1820

Message par Nanard » sam. 17 déc. 2016 18:56

Voici deux images de mon câblage
Fichiers joints
IMG_0598.JPG
IMG_0598.JPG (1.43 Mio) Vu 1240 fois
IMG_0597.JPG
IMG_0597.JPG (1.35 Mio) Vu 1240 fois

destroyedlolo
Raspinaute
Messages : 1234
Enregistré le : dim. 10 mai 2015 18:44
Localisation : Dans la campagne à côté d'Annecy
Contact :

Re: Relevé température ds1820

Message par destroyedlolo » sam. 17 déc. 2016 20:21

Et

Code : Tout sélectionner

cat /proc/modules
te dit quoi ?
  • BananaPI : Gentoo, disque SATA de 2 To
  • Domotique : 1-wire, TéléInfo, Tablette passée sous Gentoo, ESP8266
  • Multimedia par DNLA
  • Et pleins d'idées ... et bien sûr, pas assez de temps.
Un descriptif de ma domotique 100% fait maison.

guillaume9344
Raspinaute
Messages : 629
Enregistré le : mar. 6 janv. 2015 19:44
Localisation : finistere

Re: Relevé température ds1820

Message par guillaume9344 » sam. 17 déc. 2016 21:07

+1 pour Destroyedlolo
et également cette commande:

Code : Tout sélectionner

ls /sys/bus/w1/devices
rpi b+ ,osmc, motioneyes
rpi 2 raspbian , server minecraft 24h/24 , utilisation gpio
orange pi pc debian ,utilisation gpio, motion cam

Nanard
Messages : 22
Enregistré le : jeu. 15 déc. 2016 12:26

Re: Relevé température ds1820

Message par Nanard » dim. 18 déc. 2016 15:21

Alors grand mystère, j'ai réussi à avoir le code de la sonde.
J'ai repris mon ancienne sauvegarde d'os et d'un coup c'est arrivé.
Peut être un bug quelque part.
Merci à vous tous d'avoir pris le temps de me répondre.

Répondre

Retourner vers « Gestion de la température »