Auto-montage de partage samba Errr -101

Vous avez réalisé ou vous voulez réaliser un truc impensable avec votre Raspberry Pi ? Cet endroit est pour vous...

Modérateur : Francois

Répondre
cbalo
Raspinaute
Messages : 272
Enregistré le : sam. 24 août 2019 06:05

Auto-montage de partage samba Errr -101

Message par cbalo » dim. 9 févr. 2020 10:09

Bonjour,
Je ne suis pas à mon premier paramétrage de samba mais là, j'ai un problème et je sèche : code retour -101 au montage (ce code retour n'est pas documenté)

J'explique :
- j'ai une box SFR avec un disque USB partagé (la box a un serveur SAMBA 1.0 intégré)
- j'ai un raspberry 4 (serveur emby, samba, et ftp) avec un autre disque en USB partagé via samba.
Ces partages sont read-write et sans identifications

Ces 2 disques sont accessibles à partir de tous mes périphériques réseaux (PC sous Win10 sous Linux Fedora, téléphones et tablettes via AndSmb)

J'ai un autre Raspberry (un 3B), qui accèdent sans soucis à ces disques si je les monte manuellement via l'explorateur de fichier.
Je veux que le montage soit fait au démarrage de ce raspberry.
Je modifie donc le fichier /etc/fstab comme suis :

Code : Tout sélectionner

//192.168.1.1/1to     /mnt/1to        cifs        auto,nouser,vers=1.0,rw     0 0
//raspi4/emby         /mnt/emby           cifs    auto,nouser,vers=1.0,rw    0 0
Je teste en lançant la commande

Code : Tout sélectionner

sudo mount -a
Et on me demande le mot de passe de root sur ce 1er partage !! c'est quoi ce binz ??

Code : Tout sélectionner

Password for root@//192.168.1.1/1to:

La colère me prends je me décide, pour test à être très explicite , je mets alors dans /Etc/fstab :

Code : Tout sélectionner

//192.168.1.1/1to     /mnt/1to        cifs        auto,user=,password=,vers=1.0,rw         0 0
//raspi4/emby         /mnt/emby           cifs    auto,user=,password=,vers=1.0,rw       0 0
Je teste en lançant la commande

Code : Tout sélectionner

sudo mount -a
Et là, ça fonctionne alors je suis content et je redémarre le raspberry en me disant : "c'est gagné"
Et bien non
Au redémarrage, mes sous-dossiers de mnt ne contiennent pas le contenu des 2 partages

Alors je cherche pourquoi :

Code : Tout sélectionner

sudo dmesg | grep fail 
Et là je vois :

Code : Tout sélectionner

[    8.466603] CIFS VFS: cifs_mount failed w/return code = -101
??? Quezacko ??

Là, je cherche en savoir plus sur ce code retour :

Code : Tout sélectionner

 man mount | grep 101
Ne donne rien et google ne donne rien

A noté : si je retire la directive vers=1.0, j'obtiens le message "host is down" qui correspond au cas où l'hôte utilise une autre version du protocole (d'où le vers=1.0)

Si vous avez une idée....

cbalo
Raspinaute
Messages : 272
Enregistré le : sam. 24 août 2019 06:05

Re: Auto-montage de partage samba Errr -101

Message par cbalo » dim. 9 févr. 2020 23:57

Bien, j'ai déjà une piste :
-101 n'est ni une erreur de samba ni une erreur de mount, c'est une erreur réseau
En fait, au boot, le système tente de monter le partage avant que le réseau ne soit disponible

Mais pour résoudre cela, il suffit normalement d'ajouter l'option _netdev à la ligne dans /etc/fstab

Ce que j'ai fait sur mon PC portable sous Fedora 31 et ça fonctionne.

Mais sur le raspberry, ça ne fonctionne pas, j'ai toujours la même erreur.
/var/log/boot.log me donne d'autres informations :

Code : Tout sélectionner

[FAILED] Failed to mount /mnt/emby.
See 'systemctl status mnt-emby.mount' for details.
En faisant systemctl status mnt-emby.mount
J'obtiens :

Code : Tout sélectionner

févr. 09 23:47:35 hifiberry systemd[1]: Mounting /mnt/emby...
févr. 09 23:47:35 hifiberry mount[415]: mount error(101): Network is unreachable
Donc Raspbian ne tient pas compte du paramètre _netdev présent dans /etc/fstab . Un bug sur Raspbian ??
Pour info, voici ce qu'est devenu mon fichier /etc/fstab (et qui fonctionne avec Fedora)

Code : Tout sélectionner

root@hifiberry:~# cat /etc/fstab 
proc            /proc           proc    defaults          0       0
PARTUUID=a294a7c7-01  /boot           vfat    defaults          0       2
PARTUUID=a294a7c7-02  /               ext4    defaults,noatime  0       1
# a swapfile is not a swap partition, no line here
#   use  dphys-swapfile swap[on|off]  for that
//192.168.1.1/1to     /mnt/1to            cifs     _netdev,username=guest,password=,uid=0,gid=0,file_mode=0775,dir_mode=0775,vers=1.0   0 0
//raspi4/emby         /mnt/emby           cifs     _netdev,username=guest,password=,uid=0,gid=0,file_mode=0775,dir_mode=0775,vers=1.0   0 0

dyox
Raspinaute
Messages : 589
Enregistré le : dim. 28 déc. 2014 15:28
Localisation : Le long de la côte, au dessus du pays des bigoudennes, aïe

Re: Auto-montage de partage samba Errr -101

Message par dyox » lun. 10 févr. 2020 08:03

Bonjour,

Je sais qu'il existe une option dans raspi-config et la gestion est différente. Faites une recherche "network" dans le fichier https://github.com/RPi-Distro/raspi-con ... spi-config.
Si cela peut vous aider.
Débutant sous RPi / linux

:arrow: :arrow: :arrow: [Pour bien commencer] Pour les nouveaux acquéreurs de Raspberry Pi (liste de liens utiles)

cbalo
Raspinaute
Messages : 272
Enregistré le : sam. 24 août 2019 06:05

Re: Auto-montage de partage samba Errr -101

Message par cbalo » lun. 10 févr. 2020 13:15

Tu veux dire :
Activer le "wait for network at boot " ? pour compenser le fait que Raspbian ne tient pas compte du paramètre _netdev dans /etc/fstab ??

Je n'active jamais ça car le titre fait peur (il n'est pas expliqué ce qui se passe exactement si le réseaux n'est pas disponible, d'après le titre, le raspberry ne démarrerait pas du tout ??)

Bref, je viens d'essayer, résultat :
- le fichier /var/log/boot.log affiche toujours la même erreur (-101) au montage de mes partages
- dmesg n'affiche plus d'erreur
- les partages sont bien montés au démarrage.

Donc en fait c'est une roue de secours pour contourner le problème : au premier montage : toujours le même problème, sauf que raspbian re-essaye ensuite de monter les partages et là ça fonctionne.

Bref, c'est juste une manière de contourner le bug qui reste présent.

Merci, dans l'attente d'une correction, ça me permettra au moins d'avancer.

dyox
Raspinaute
Messages : 589
Enregistré le : dim. 28 déc. 2014 15:28
Localisation : Le long de la côte, au dessus du pays des bigoudennes, aïe

Re: Auto-montage de partage samba Errr -101

Message par dyox » lun. 10 févr. 2020 14:44

C'est pourquoi j'ai donné le lien. Cette option crée un service avec "dhcpcd -q -w" qui se traduit par " Wait for an address to be assigned before forking to the background."
Débutant sous RPi / linux

:arrow: :arrow: :arrow: [Pour bien commencer] Pour les nouveaux acquéreurs de Raspberry Pi (liste de liens utiles)

Artemus24
Raspinaute
Messages : 514
Enregistré le : ven. 15 sept. 2017 19:15

Re: Auto-montage de partage samba Errr -101

Message par Artemus24 » mar. 11 févr. 2020 18:53

Salut à tous.

Quel est le modèle de ta BOX SFR ? NB6v2 comme chez moi, puisque je suis encore en ADSL.

Quel est le type du système de fichier qui a été utilisé pour le disque dur que vous partagez par la BOX SFR ? FAT32 . NTFS ?

Le problème de l'accès à la partition de la box SFR se présente-t-il sur la RPi 4B uniquement ou aussi sur la RPi 3B+ ?

Il s'agit de SAMBA client et non SAMBA server. Pour l'installer, il faut faire :

Code : Tout sélectionner

apt-get install  smbclient  cifs-utils
Pour tester l'accès à la BOX SFR, il suffit de taper :

Code : Tout sélectionner

smbclient  //192.168.1.1/nom_de_partage
Quand le mot de passe est demandé, je tape sur la touche ENTER.

Pour le monter à la main :

Code : Tout sélectionner

mount  -t cifs  //192.168.1.1/nom_de_partage  /mnt/boxsfr
Aupréalable, j'ai créé un répertoire de nom "/mnt/boxsfr".

Dans le fichier FSTAB, je mettais :

Code : Tout sélectionner

//192.168.1.1/nom_de_partage  /mnt/bosfr  cifs  credentials=/home/pi/.smbcredentials,x-systemd.automount,defaults  0  0
Aupréalable, il faut créer le fichier "/home/pi/.smbcredentials", avec :

Code : Tout sélectionner

user=
password=
Je ne mets rien pour le user et le mot de passe. Puis faire

Code : Tout sélectionner

chmod  600  /home/pi/.smbcredentials
--> https://www.framboise314.fr/partage-sam ... us-jessie/

Il n'existe pas une seule façon de monter la partition distante. Ce que j'ai indiqué cu-dessus, c'est ce que j'ai marqué dans mes cahiers quand j'ai fait les tests, sous Jessie.
Je n'utilise plus le partage de fichier au travers de la BOX SFR car le serveur SAMBA est fort ancien et utilise encore SMBv1.
La version SAMBA de la BOX SFR qui est utilisé est : SAMBA 3.6.5 !

Ce qui me surprend, c'est de ne pas voir le paramètre "defaults" dans le fstab.
Et si en ajoutant "nofail", cela pourrait empêcher l'apparition de l'erreur "-101".

--> https://raspberrypi.stackexchange.com/q ... -pi-client

Je propose ceci :

Code : Tout sélectionner

//192.168.1.1/nom_de_partage  /mnt/boxsfr  cifs  defaults,nofail,noauto,x-systemd.automount,x-systemd.requires=network-online.target,x-systemd.device-timeout=10,workgroup=workgroup  0 0
Le problème que tu rencontres est qu'il manque un paramètre pour avoir le bon comportement.

@+
--> RPi0v1.3, RPi0W, Rpi3A+, Rpi3B+
--> Rpi0WH + Tuner TV HAT
--> RPi 2B + Joy-It I2C Serial 20x4 2004 LCD Module
--> RPi 2B + PIM273 Unicorn HAT HD 16x16 Leds RGB

cbalo
Raspinaute
Messages : 272
Enregistré le : sam. 24 août 2019 06:05

Re: Auto-montage de partage samba Errr -101

Message par cbalo » mar. 11 févr. 2020 19:47

Le problème que tu rencontres est qu'il manque un paramètre
Ah pourquoi ça fonctionne avec un PC sous Fedora alors ?

Sinon, j'ai essayé ce que vous suggérerez :
si je retire user=,password=, le rapberry me demande le mot de passe d'accès au partage hors
  • il n'y en a pas
  • si je voulais en mettre un je ne pourrais pas (cette box SFR ne gère pas les utilisateurs sur les partages
Si je ne mets pas vers=1.0 cela ne fonctionne pas, j'obtiens "host is down" (et c'est normal, puisque par défaut, le protocole SMB 1.0 n'est pas utilisé)
Donc avec ceci, ça fonctionne le montage ets bien effectué au démarrage.

Code : Tout sélectionner

//192.168.1.1/1to  /mnt/1to  cifs  defaults,x-systemd.automount,x-systemd.requires=network-online.target,x-systemd.device-timeout=10,workgroup=WORKGROUP,user=,password=,vers=1.0  0 0
Cependant, ma première solution mettait bien en place automatiquement un service dans systemd (un par montage), aussi je pense que Raspbian a du juste omettre dans la création de ces services, la dépendance avec network-online.target (cbalo) car sur Fedora, ces services , qui ont été automatiquement créés ont la dépendance.

En tout cas, merci

Artemus24
Raspinaute
Messages : 514
Enregistré le : ven. 15 sept. 2017 19:15

Re: Auto-montage de partage samba Errr -101

Message par Artemus24 » mar. 11 févr. 2020 22:20

Salut à tous.
cbalo a écrit :Ah pourquoi ça fonctionne avec un PC sous Fedora alors ?
Autre environnement, autre règle.
cbalo a écrit :si je retire user=,password=, le rapberry me demande le mot de passe d'accès au partage hors
J'ai précisé que quand j'ai fait mes tests, c'était sous Jessie.
Depuis, il y a eu stretch et maintenant buster, donc certainement une évolution dans la prise en charge de smbclient.

Ce n'est pas sur le user et le password qu'il fallait se concentrer.
Mais sur "x-systemd.automount" pour le montage automatique.
Et sur "x-systemd.requires=network-online.target" pour l'attente de la disponibilité du réseau.
cbalo a écrit :En tout cas, merci
Le but recherché était de te rendre service.

@+
--> RPi0v1.3, RPi0W, Rpi3A+, Rpi3B+
--> Rpi0WH + Tuner TV HAT
--> RPi 2B + Joy-It I2C Serial 20x4 2004 LCD Module
--> RPi 2B + PIM273 Unicorn HAT HD 16x16 Leds RGB

cbalo
Raspinaute
Messages : 272
Enregistré le : sam. 24 août 2019 06:05

Re: Auto-montage de partage samba Errr -101

Message par cbalo » mar. 11 févr. 2020 23:11

Merci.
Je me rends compte que toute mon expérience (+ de 15 ans) sur Redhat, Cent OS et Fedora ne m'apportent finalement pas grand chose concernant les paramétrages système un peu "pointus", mais c'est vrai que ces systèmes mettent rapidement à disposition les dernières évolutions, contrairement à Debian qui attend longuement avant de faire de même.
Debian et ses clones sont d'un autre monde avec ses propres règles. :cry:

Artemus24
Raspinaute
Messages : 514
Enregistré le : ven. 15 sept. 2017 19:15

Re: Auto-montage de partage samba Errr -101

Message par Artemus24 » mar. 11 févr. 2020 23:51

Pas de quoi. :D

J'ai toujours considéré qu'un environnement avait ses propres règles et que le fait de connaitre un autre environnement n'apportait rien en valeur ajouté.
On aurait pu penser le contraire en connaissant les normes, mais je le constate encore une fois avec les SGBDR.
Si une règle est valable pour l'un, tu ne peux rien déduire sur la même règle par ailleurs.

Inversement, à quoi peut servir un autre environnement, s'il est identique au premier ? Réponse : à rien.
Pourquoi ? Parce que l'intérêt est de proposer une autre approche, une autre façon de résoudre les problèmes.

Attention, ne me fait pas dire ce que je n'ai pas dit.
Connaitre un autre environnement est aussi une forme d'enrichissement et de comprendre la logique sous-jacente.
Même si l'approche est différente, il y a quand même une idée commune, mais qui se décline différemment.

@+
--> RPi0v1.3, RPi0W, Rpi3A+, Rpi3B+
--> Rpi0WH + Tuner TV HAT
--> RPi 2B + Joy-It I2C Serial 20x4 2004 LCD Module
--> RPi 2B + PIM273 Unicorn HAT HD 16x16 Leds RGB

Répondre

Retourner vers « Utilisateurs avancés »