Chiffrement sous Luks

Vous avez réalisé ou vous voulez réaliser un truc impensable avec votre Raspberry Pi ? Cet endroit est pour vous...

Modérateur : Francois

Répondre
FredM
Messages : 65
Enregistré le : lun. 18 janv. 2016 00:05

Chiffrement sous Luks

Message par FredM » mer. 27 janv. 2016 17:18

Bonjour,

Voici ce que je fais pour crypter 2 partitions (sdb1 et sdb2)sur le disque externe relié au pi2.

cryptsetup luksFormat /dev/sdb1
phrase secrète : xxxxxx
cryptsetup luksFormat /dev/sdb2
phrase secrète : xxxxxx

Dévérouillage de la partition cryptée :
cryptsetup luksOpen /dev/sdb1 LinuxFred
cryptsetup luksOpen /dev/sdb2 Fred

Formatage
mkfs.ext4 /dev/mapper/LinuxFred
mkfs.ntfs /dev/mapper/Fred (pour NTFS) ou mkfs.vfat -F 32 /dev/mapper/Fred (pour FAT32)

Montage partitions :
mount /dev/mapper/LinuxFred /disque/LinuxFred
mount /dev/mapper/Fred /disque/Fred

Démontage :
umount /dev/mapper/Fred
cryptsetup luksClose Fred
umount /dev/mapper/LinuxFred
cryptsetup luksClose LinuxFred

Tout fonctionne bien. Maintenant, je voulais que le montage se fasse automatiquement au démarrage et que je n'ai qu'à renseigner la passphrase.
J'ai donc ajouté à mon /etc/fstab :
/dev/mapper/LinuxFred /disque/LinuxFred ext4 defaults 1 2
/dev/mapper/Fred /disque/Fred vfat defaults 1 2

et dans /etc/crypttab :
LinuxFred /dev/sdb1 none luks
Fred /dev/sdb2 none luks

Cela semble fonctionner puisque la commande :
cryptdisks_start Fred ou cryptdisks_start LinuxFred ouvre bien la partition.

Par contre au redémarrage, le raspberry ne boote plus ;(
En commentant les lignes dans /etc/fstab et /etc/crypttab cela repart !

Une idée ?
Merci
Fred

Répondre

Retourner vers « Utilisateurs avancés »