apli prévue pour version de raspbian antérieur.

Vous avez réalisé ou vous voulez réaliser un truc impensable avec votre Raspberry Pi ? Cet endroit est pour vous...

Modérateur : Francois

Répondre
maccoa
Messages : 38
Enregistré le : lun. 11 sept. 2017 17:19

apli prévue pour version de raspbian antérieur.

Message par maccoa » lun. 25 sept. 2017 12:10

bonjour.

sur ma rpi3 je tourne avec raspbian stretch version litle.

il y'a quelques années sur une rpi b+ , j avais installer une "apli" pour faire un suivie de chaudière .

j'ai donc réessayer avec la rpi3... sans succès
j'ai des erreurs durant l'execution du script ./install

comme le site source est en allemand j'ai vraiment du mal à comprendre même avec google trad.

voici la partie ou il y a des erreurs . auriez vous des idées ? ou tout simplement peut être n'est ce pas possible sous stretch ?

p4d Installieren
+ cd /p4d
+ git clone https://github.com/horchi/linux-p4d/
Clonage dans 'linux-p4d'...
remote: Counting objects: 2852, done.
remote: Total 2852 (delta 0), reused 0 (delta 0), pack-reused 2852
Réception d'objets: 100% (2852/2852), 2.62 MiB | 550.00 KiB/s, fait.
Résolution des deltas: 100% (2130/2130), fait.
+ cd linux-p4d
+ make
make: mysql_config : commande introuvable
make: xml2-config : commande introuvable
g++ -c -ggdb -O0 -fPIC -Wreturn-type -Wall -Wno-parentheses -Wformat -pedantic -Wunused-variable -Wunused-label -Wunused-value -Wunused-function -Wno-long-long -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -DTARGET='"p4d"' -DLOG_PREFIX='""' -DPLGDIR='""' -DUSEUUID -DUSEMD5 -DUSELIBXML -DUSELIBARCHIVE -DUSEJSON -DUSEGUNZIP -D_GNU_SOURCE -DTARGET='"p4d"' -DDEAMON=P4d -DUSEMD5 -DGIT_REV='"78ae588"' -o lib/db.o lib/db.c
lib/db.c:9:20: fatal error: errmsg.h: Aucun fichier ou dossier de ce type
#include <errmsg.h>
^
compilation terminated.
Make.config:53 : la recette pour la cible « lib/db.o » a échouée
make: *** [lib/db.o] Erreur 1
+ make install
make: mysql_config : commande introuvable
make: xml2-config : commande introuvable
g++ -c -ggdb -O0 -fPIC -Wreturn-type -Wall -Wno-parentheses -Wformat -pedantic -Wunused-variable -Wunused-label -Wunused-value -Wunused-function -Wno-long-long -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -DTARGET='"p4d"' -DLOG_PREFIX='""' -DPLGDIR='""' -DUSEUUID -DUSEMD5 -DUSELIBXML -DUSELIBARCHIVE -DUSEJSON -DUSEGUNZIP -D_GNU_SOURCE -DTARGET='"p4d"' -DDEAMON=P4d -DUSEMD5 -DGIT_REV='"78ae588"' -o lib/db.o lib/db.c
lib/db.c:9:20: fatal error: errmsg.h: Aucun fichier ou dossier de ce type
#include <errmsg.h>
^
compilation terminated.
Make.config:53 : la recette pour la cible « lib/db.o » a échouée
make: *** [lib/db.o] Erreur 1
+ cp contrib/p4d /etc/init.d/
+ cp contrib/runp4d /usr/local/bin/
+ cp htdocs/alertcfg.php htdocs/basecfg.php htdocs/base.css htdocs/chart2.php htdocs/chart.php htdocs/config.php htdocs/detail.php htdocs/error.php htdocs/err.php htdocs/footer.php htdocs/functions.php htdocs/header.php htdocs/hmcfg.php htdocs/img htdocs/index.php htdocs/jfunctions.js htdocs/jfunctions.php htdocs/LICENSE htdocs/login.php htdocs/logout.php htdocs/main.php htdocs/menu.php htdocs/normalize.css htdocs/schemacfg.php htdocs/schemadsp.php htdocs/schema.php htdocs/scriptcfg.php htdocs/settings.php htdocs/setup.php htdocs/stylesheet-blue.css htdocs/stylesheet.css htdocs/stylesheet-dark.css htdocs/stylesheet-yellow.css htdocs/test.php /var/www/
cp: -r not specified; omitting directory 'htdocs/img'
+ chmod 750 /etc/init.d/p4d
+ update-rc.d p4d defaults
+ green_msg 'pchart Installieren'
+ echo -e '\033[32;1mpchart Ins

domi
Administrateur
Messages : 2256
Enregistré le : mer. 17 sept. 2014 18:12
Localisation : Seine et Marne

Re: apli prévue pour version de raspbian antérieur.

Message par domi » lun. 25 sept. 2017 18:46

Bonjour,

Apparemment, il te manque quelques pré-requis.
Au vu de certain messages d'erreurs, je dirais déjà qu'il doit te manquer MySQL serveur, ou ses outils ?
Commence déjà de ce coté, surtout si tu es sur un strech Lite, il va y avoir quelques dépendances à installer.

PS : J'ai déplacé ce sujet, car nous sommes loin de la catégorie "Débutant" !!!

maccoa
Messages : 38
Enregistré le : lun. 11 sept. 2017 17:19

Re: apli prévue pour version de raspbian antérieur.

Message par maccoa » lun. 25 sept. 2017 22:17

merci pour l'orientation de mes recherches!!

je viens de tester avec jessie lite , tout c'est bien passé .

je vais de ce pas , continuer mes lectures , encore merci.

maccoa
Messages : 38
Enregistré le : lun. 11 sept. 2017 17:19

Re: apli prévue pour version de raspbian antérieur.

Message par maccoa » mar. 26 sept. 2017 12:35

j'ai edité le fichier install.sh pour voir un peut se qu'il y avait dedans , et par la meme ocasion essayer de comprendre .
en faisant les commande une à une pour voir ou ça coince
sudo apt-get install php5-mysql <- apparament sous stretch c'est pas simple.

tor_rpi
Messages : 6
Enregistré le : jeu. 16 nov. 2017 18:27

Re: apli prévue pour version de raspbian antérieur.

Message par tor_rpi » jeu. 16 nov. 2017 19:11

essayes un :

apt-cache search php | grep mysql

Et dis nous ce que ça donne ?
(si tu es encore vivant of course, car ce sujet me semble un peu vieux)

bisous

maccoa
Messages : 38
Enregistré le : lun. 11 sept. 2017 17:19

Re: apli prévue pour version de raspbian antérieur.

Message par maccoa » jeu. 16 nov. 2017 20:38

merci pour l'astuce, mais je suis passer sous stretch et je me suis lancer à essayer de faire mon propre "scada?"

ça pourra surment servir à d'autre :D

Répondre

Retourner vers « Utilisateurs avancés »