Under-voltage detected!

Vous avez réalisé ou vous voulez réaliser un truc impensable avec votre Raspberry Pi ? Cet endroit est pour vous...

Modérateur : Francois

Répondre
FredM
Messages : 64
Enregistré le : lun. 18 janv. 2016 00:05

Under-voltage detected!

Message par FredM » jeu. 12 avr. 2018 19:13

Bonjour,

J'utilise un pi3 avec un disque dur connecté en USB. Cela tourne très bien depuis plusieurs mois sans pb.
J'ai remarqué que depuis quelques semaines j'ai ce type de message dans le kernel.log :

Code : Tout sélectionner

pi3 kernel: [  474.234541] Under-voltage detected! (0x00050005)
pi3 kernel: [  484.634592] Voltage normalised (0x00000000)
Aucun message de ce type pour la même config avec un pi2 + disque usb.
Cette erreur ne semble pas poser de pb de stabilité mais m'interroge tout de même ;(
Je suis sous le kernel 4.14.33-v7+
Une idée ?
Merci
Fred

destroyedlolo
Raspinaute
Messages : 1160
Enregistré le : dim. 10 mai 2015 18:44
Localisation : Dans la campagne à côté d'Annecy
Contact :

Re: Under-voltage detected!

Message par destroyedlolo » jeu. 12 avr. 2018 23:35

Salut,

J'imagine que le PI est alimenté par une alim à découpage genre alim pour téléphone, non ?
Est-ce que le disque USB est alimenté par la même alim ?

Si c'est le cas, je te conseille fortement d'installer smartmontools et de surveillé qu'il n'y ait pas des Spin_Retry_Count à répétition.
Dans l'affirmative : il est possible (conditionnel) que ton alim soit sur le point de lacher ... et tu vas vers les problemes.

Tu peux le confirmer en la vérifiant avec un oscillo : si la tension n'est plus stabilisée ... change d'alim :mrgreen:
  • BananaPI : Gentoo, disque SATA de 2 To
  • Domotique : 1-wire, TéléInfo, Tablette passée sous Gentoo, ESP8266
  • Multimedia par DNLA
  • Et pleins d'idées ... et bien sûr, pas assez de temps.
Un descriptif de ma domotique 100% fait maison.

FredM
Messages : 64
Enregistré le : lun. 18 janv. 2016 00:05

Re: Under-voltage detected!

Message par FredM » ven. 13 avr. 2018 00:42

Salut,

Merci pour ta réponse.
Le pi est alimenté par l'alimentation du kit que l'on trouve sur amazon : "Aukru Super 3-en-1 Kit Raspberry Pi 3 Model B Transparent Case + 5v 3000mA Alimentation + dissipateur thermique Pour RASPBERRY PI 3 Model B "
Le disque USB est aussi alimenté par cette même alim.
C'est pourtant à priori l'alimentation recommandée pour le pi3 non ?

J'ai lancé : smartctl -a /dev/sda2
et j'obtiens :

Code : Tout sélectionner

=== START OF INFORMATION SECTION ===
Vendor:               Seagate
Product:              M3 Portable
Revision:             0708
Compliance:           SPC-4
User Capacity:        1 000 204 885 504 bytes [1,00 TB]
Logical block size:   512 bytes
LU is fully provisioned
Logical Unit id:      0x3e4d31334c395445
Serial number:        NM13L9TE
Device type:          disk
Local Time is:        Fri Apr 13 00:34:36 2018 CEST
SMART support is:     Unavailable - device lacks SMART capability.

=== START OF READ SMART DATA SECTION ===
Current Drive Temperature:     0 C
Drive Trip Temperature:        0 C

Error Counter logging not supported

SMART Self-test log
Num  Test              Status                 segment  LifeTime  LBA_first_err [SK ASC ASQ]
     Description                              number   (hours)
# 1  Background short  Completed                   -       0                 - [-   -    -]
Je ne sais pas si je lance la bonne commande ;(

Fred

destroyedlolo
Raspinaute
Messages : 1160
Enregistré le : dim. 10 mai 2015 18:44
Localisation : Dans la campagne à côté d'Annecy
Contact :

Re: Under-voltage detected!

Message par destroyedlolo » ven. 13 avr. 2018 01:03

Ben, quelle soit recommandée ou non, ca ne change rien au fait qu'un jour ou l'autre, elle lâchera.

Par contre, le fait qu'il dise
SMART support is: Unavailable - device lacks SMART capability
indique qu'il n'arrive pas a accédé aux infos smart. Donc ma méthode ne fonctionnera pas.

Il ne te reste donc que l'oscillo (ou un montage électronique pour détecter des chutes très ponctuelles de tension).
  • BananaPI : Gentoo, disque SATA de 2 To
  • Domotique : 1-wire, TéléInfo, Tablette passée sous Gentoo, ESP8266
  • Multimedia par DNLA
  • Et pleins d'idées ... et bien sûr, pas assez de temps.
Un descriptif de ma domotique 100% fait maison.

Avatar du membre
EVOTk
Modérateur
Messages : 797
Enregistré le : sam. 20 sept. 2014 02:36

Re: Under-voltage detected!

Message par EVOTk » ven. 13 avr. 2018 16:26

Salut
Le Pi3 consomme plus que le Pi2 peut etre que l'alim suffit pour le couple P2 + disque mais est trop juste pour Pi3 + Disque.
Le Pi3 demlande une alim de 2.5A il me semble combien consomme ton disque ? S'il demande plus de 0.5A sa peut etre problematique de plus ton alim a force d'etre utilisé au maximum de ses capacités fatigue peut etre !
NAS : DS3615xs Xpenology - 8To + 2x 3To + 2x 4To WD Red - APC Back-UPS Pro 900
Imprimante 3D : Dagoma DiscoEasy 200
Surveillance Réseau : Smokeping sur Rasp. B / Raspbian
Arcade : Raspberry Pi 3 sous RecalBox

spourre
Raspinaute
Messages : 718
Enregistré le : lun. 22 déc. 2014 16:50
Localisation : 67380 LINGOLSHEIM

Re: Under-voltage detected!

Message par spourre » ven. 13 avr. 2018 18:53

Bonjour,

Je ne suis pas concerné mais, de mémoire, il me semble qu'il faut modifier le fichier config.txt pour disposer du maximum de courant sur l'USB (tout en respectant la limite absolue).

Sylvain

FredM
Messages : 64
Enregistré le : lun. 18 janv. 2016 00:05

Re: Under-voltage detected!

Message par FredM » sam. 14 avr. 2018 00:48

Merci de vos réponses. Je vais changer l'alimentation voir si cela solutionne le pb sinon j'explorerai les autres pistes.

Fred

Répondre

Retourner vers « Utilisateurs avancés »