Erreur date en connexion rj45

Vous avez réalisé ou vous voulez réaliser un truc impensable avec votre Raspberry Pi ? Cet endroit est pour vous...

Modérateur : Francois

Philippe
Messages : 5
Enregistré le : lun. 27 août 2018 10:58

Erreur date en connexion rj45

Message par Philippe » lun. 27 août 2018 11:14

Bonjour,

j'utilise une raspberry pi 3.

Je l'utilise soit chez moi en wifi, soit dans un local d'association où nous n'avons pas le wifi mais internet sur un cable rj45 (pour différentes raisons non modifiable pour le moment).
Lorsque je suis en connexion wifi, tout marche trés bien.
Lorsque je me connecte en RJ45, la date n'est pas mise à jour depuis la derniere utilisation wifi, et soit:
*Si j'étais connecté en wifi longtemps avant (6 mois lorsque j'ai decouvert le probleme), cette erreur de date m'interdit l'accés aux sites internet qui vérifie la date. Je ne peux donc pas naviguer sur internet alors que je suis connecté en RJ45 sur une connexion qui fonctionne
*Si le décalage est faible, (je viens de tester avec environ 12h de décalage) je peux naviguer sans problème avec ma connexion en rj45, même si la date reste fausse.

Pourriez-vous m'indiquez comment proceder pour que la date se mette à jour lors de mes connexions en rj45.

Cordialement
Philippe

Artemus24
Raspinaute
Messages : 226
Enregistré le : ven. 15 sept. 2017 19:15

Re: Erreur date en connexion rj45

Message par Artemus24 » lun. 27 août 2018 11:53

Salut Philippe.

Avez-vous mis en place un firewall (iptables) ?

@+
--> Rpi2B, Rpi3B+

Philippe
Messages : 5
Enregistré le : lun. 27 août 2018 10:58

Re: Erreur date en connexion rj45

Message par Philippe » lun. 27 août 2018 14:38

Non, la carte est neuve de cette année.
je l'ai juste installé, et j'ai navigué 2 ou 3 fois sur internet.

mike913
Raspinaute
Messages : 112
Enregistré le : mar. 7 oct. 2014 09:46
Localisation : Morsang / Orge - Essonne
Contact :

Re: Erreur date en connexion rj45

Message par mike913 » lun. 27 août 2018 19:43

Bonjour
Si tu es sous raspbian: Vérifie si systemd-timesyncd est actif avec la commande: systemctl status systemd-timesyncd
ce qui donne chez moi:

Code : Tout sélectionner

● systemd-timesyncd.service - Network Time Synchronization
   Loaded: loaded (/lib/systemd/system/systemd-timesyncd.service; enabled; vendor preset: enabled)
  Drop-In: /lib/systemd/system/systemd-timesyncd.service.d
           └─disable-with-time-daemon.conf
   Active: active (running) since Tue 2018-06-05 23:31:04 CEST; 1min 46s ago
     Docs: man:systemd-timesyncd.service(8)
 Main PID: 1204 (systemd-timesyn)
   Status: "Synchronized to time server 212.27.38.253:123 (mafreebox.free.fr)."
   CGroup: /system.slice/systemd-timesyncd.service
           └─1204 /lib/systemd/systemd-timesyncd
Et le fichier “/etc/systemd/timesyncd.conf”:
chez moi il contient ceci:

Code : Tout sélectionner

[Time]
NTP=mafreebox.free.fr 
FallbackNTP=ntp2.jussieu.fr 0.fr.pool.ntp.org
redémarrage de timesyncd:
sudo systemctl restart systemd-timesyncd

ls -alrt /var/lib/systemd/clock te permet de connaitre l'heure de la derniéresynchronisation.

Code : Tout sélectionner

[19:41:16]  michel@RASPI-141:~$ ls -alrt /var/lib/systemd/clock
-rw-r--r-- 1 systemd-timesync systemd-timesync 0 août  27 19:09 /var/lib/systemd/clock
DS712+ 2x Western Digital WD10EADS-00L 1000 GB (SHR) - Firmware: DSM 6.1.6-15266
Raspberry - RFXTRX433 - Aeon Labs ZStick V2 - Domoticz
FreeBox v6
https://meteo.folcke.net
https://wiki.folcke.fr

Philippe
Messages : 5
Enregistré le : lun. 27 août 2018 10:58

Re: Erreur date en connexion rj45

Message par Philippe » lun. 27 août 2018 22:28

Bonsoir Mike913,

merci pour votre réponse. Voici les manipulation que je viens de faire (je suis chez moi en wifi à ce moment).

pi@raspberrypi:~ $ systemctl status systemd-timesyncd
● systemd-timesyncd.service - Network Time Synchronization
Loaded: loaded (/lib/systemd/system/systemd-timesyncd.service; disabled)
Active: inactive (dead)
Docs: man:systemd-timesyncd.service(8)
pi@raspberrypi:~ $ /etc/systemd/timesyncd.conf
bash: /etc/systemd/timesyncd.conf: Permission non accordée
pi@raspberrypi:~ $ sudo systemctl restart systemd-timesyncd
pi@raspberrypi:~ $ ls -alrt /var/lib/systemd/clock
-rw-r--r-- 1 systemd-timesync systemd-timesync 0 août 27 22:12 /var/lib/systemd/clock
pi@raspberrypi:~ $ systemctl status systemd-timesyncd
● systemd-timesyncd.service - Network Time Synchronization
Loaded: loaded (/lib/systemd/system/systemd-timesyncd.service; disabled)
Active: active (running) since lun. 2018-08-27 22:12:32 CEST; 1min 10s ago
Docs: man:systemd-timesyncd.service(8)
Main PID: 1303 (systemd-timesyn)
Status: "Using Time Server 80.74.64.2:123 (0.debian.pool.ntp.org)."
CGroup: /system.slice/systemd-timesyncd.service
└─1303 /lib/systemd/systemd-timesyncd
pi@raspberrypi:~ $ ls -alrt /var/lib/systemd/clock
-rw-r--r-- 1 systemd-timesync systemd-timesync 0 août 27 22:13 /var/lib/systemd/clock

Je ne m'y connais pas, je constate que le disabled est resté disabled, mais que l'inactif est devenu actif.
Quand pensez-vous? Je pourrais le tester en rj45 mercredi.

mike913
Raspinaute
Messages : 112
Enregistré le : mar. 7 oct. 2014 09:46
Localisation : Morsang / Orge - Essonne
Contact :

Re: Erreur date en connexion rj45

Message par mike913 » lun. 27 août 2018 23:14

Oui il faut tester maintenant en rj45.
DS712+ 2x Western Digital WD10EADS-00L 1000 GB (SHR) - Firmware: DSM 6.1.6-15266
Raspberry - RFXTRX433 - Aeon Labs ZStick V2 - Domoticz
FreeBox v6
https://meteo.folcke.net
https://wiki.folcke.fr

Artemus24
Raspinaute
Messages : 226
Enregistré le : ven. 15 sept. 2017 19:15

Re: Erreur date en connexion rj45

Message par Artemus24 » mar. 28 août 2018 10:16

Salut à tous.

Si la mise à jour de l'heure fonctionne en wifi mais pas avec éthernet, le problème ne vient pas de "Network Time Protocol".
La première des choses à faire est dé vérifier par un ping, si l'accès aux serveurs NTP se fait correctement.
D'où ma question sur le firewall car j'ai pensé qu'il y avait un blocage sur eth0 mais pas sur wlan0.

@+
--> Rpi2B, Rpi3B+

Philippe
Messages : 5
Enregistré le : lun. 27 août 2018 10:58

Re: Erreur date en connexion rj45

Message par Philippe » mer. 29 août 2018 10:41

Bonjour messieurs,

en redémarrant ma raspberry à l'asso, la date n'est pas mise à jour, mais la connexion fonction car le decalage n'est que de quelques heures (ping ok).
Je constate que systemctl est inactive, je le relance avec sudo... et ça marche :)

pi@raspberrypi:~ $ systemctl status systemd-timesyncd
● systemd-timesyncd.service - Network Time Synchronization
Loaded: loaded (/lib/systemd/system/systemd-timesyncd.service; disabled)
Active: inactive (dead)
Docs: man:systemd-timesyncd.service(8)
pi@raspberrypi:~ $ sudo systemctl restart systemd-timesyncd
pi@raspberrypi:~ $ systemctl status systemd-timesyncd
● systemd-timesyncd.service - Network Time Synchronization
Loaded: loaded (/lib/systemd/system/systemd-timesyncd.service; disabled)
Active: active (running) since lun. 2018-08-27 22:45:37 CEST; 1 day 11h ago
Docs: man:systemd-timesyncd.service(8)
Main PID: 1720 (systemd-timesyn)
Status: "Using Time Server 37.187.2.84:123 (0.debian.pool.ntp.org)."
CGroup: /system.slice/systemd-timesyncd.service
└─1720 /lib/systemd/systemd-timesyncd
pi@raspberrypi:~ $

Du coup, y a-t-il une solution pour que systemctl se lance automatiquement au démarrage de la raspberry pour régler définitivement le problème?

Artemus24
Raspinaute
Messages : 226
Enregistré le : ven. 15 sept. 2017 19:15

Re: Erreur date en connexion rj45

Message par Artemus24 » mer. 29 août 2018 13:55

Salut Philippe.

Pour lancer au démarrage un service, vous tapez :

Code : Tout sélectionner

systemctl enable systemd-timesyncd
Pour revenir à mon interrogation, c'est surprenant que ce service fonctionne avec le wifi et non avec l'internet.
Il y a surement autre chose comme problème, peut-être synchroniser le service avec l'accès au réseau.

@+
--> Rpi2B, Rpi3B+

dyox
Raspinaute
Messages : 459
Enregistré le : dim. 28 déc. 2014 15:28
Localisation : Le long de la côte, au dessus du pays des bigoudennes, aïe

Re: Erreur date en connexion rj45

Message par dyox » mer. 29 août 2018 14:46

Bonjour,

Peut-être faut-il cocher dans raspi-config l'option de boot quand le réseau est actif ? :?:
Débutant sous RPi / linux
[Pour bien commencer] Pour les nouveaux acquéreurs de Raspberry Pi (liste de liens utiles)

Répondre

Retourner vers « Utilisateurs avancés »