Dongle Wifi officiel de Raspberry qui ne fonctionne plus !

Vous avez réalisé ou vous voulez réaliser un truc impensable avec votre Raspberry Pi ? Cet endroit est pour vous...

Modérateur : Francois

Répondre
Artemus24
Raspinaute
Messages : 412
Enregistré le : ven. 15 sept. 2017 19:15

Dongle Wifi officiel de Raspberry qui ne fonctionne plus !

Message par Artemus24 » mer. 11 sept. 2019 02:06

Salut à tous.

Je possède un dongle wifi officiel de chez Raspberry. Il y a le LOGO de la framboise dessiné dessus et le dongle est blanc. Je l'ai acheté chez Kubii !
Je l'ai acheté chez Kubii, l'année dernière car il me semble qu'il n'est plus en vente.
Voici à quoi il ressemble :

Image

Jusqu'à présent, je l'utilisais sur ma raspberry pi zéro v1.3 et je n'avais pas de problème.
C'est normal car cette RPi Zéro V1.3 ne possède pas le wifi. Je n'ai jamais installé le driver dans la RPi Zéro, et jusqu'à présent il fonctionne sans !
Entre temps, je n'ai pas utilisé le dongle wifi sur cette raspberry.

Dernièrement, j'ai fait une mise à jour de ma carte micro SD qui contient le système d'exploitation Raspbian version Stretch :

Code : Tout sélectionner

~> uname -a
Linux RaspberryPi 4.19.66+ #1253 Thu Aug 15 11:37:30 BST 2019 armv6l GNU/Linux

~> lsb_release -a
No LSB modules are available.
Distributor ID: Raspbian
Description:    Raspbian GNU/Linux 9.11 (stretch)
Release:        9.11
Codename:       stretch
Et voila que mon dongle wifi ne récupère plus les adresses Ipv4 & Ipv6 défines de ma box sfr.
En changeant de dongle wifi, celui-ci récupère bien les adresses Ipv4 & IPv6 de ma box sfr.
Je pense que ce n'est pas un problème de configuration, sinon je n'aurai pas pu me connecter à ma box sfr avec l'autre dongle wifi qui fonctionne.

Voici ce que j'obtiens :

Code : Tout sélectionner

~> ifconfig -a
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.60  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 2a02:8435:342:3801:ffff:ffff:ffff:7f95  prefixlen 128  scopeid 0x0<global>
        inet6 fe80::aa70:e908:3479:c0ee  prefixlen 64  scopeid 0x20<link>
        ether 00:50:b6:b0:24:28  txqueuelen 1000  (Ethernet)
        RX packets 115  bytes 16600 (16.2 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 124  bytes 18067 (17.6 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Boucle locale)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

usb0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 26:81:f2:90:ac:e6  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 08:6a:0a:97:6a:a2  txqueuelen 1000  (Ethernet)
        RX packets 112  bytes 43956 (42.9 KiB)
        RX errors 0  dropped 112  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

~>
Je suis connecté par un câble éthernet comme on peut le voir, alors que le dongle wifi est branché.

Si je fais ceci :

Code : Tout sélectionner

~> ifdown wlan0
ifdown: unknown interface wlan0
~> ifup wlan0
ifup: unknown interface wlan0
~>
L'interface wlan0 n'est pas reconnu ??? et j ne sais pas pourquoi.
Alors que le dongle wifi est reconnu, puisque je vois l'adresse MAC "08:6a:0a:97:6a:a2".

Voici les caractéristiques de ce dongle wifi :

Code : Tout sélectionner

~> lsusb
Bus 001 Device 005: ID 0b95:772b ASIX Electronics Corp. AX88772B
Bus 001 Device 003: ID 05e3:0608 Genesys Logic, Inc. Hub
Bus 001 Device 004: ID 0a5c:bd1e Broadcom Corp. BCM43143 802.11bgn (1x1) Wireless Adapter
Bus 001 Device 002: ID 05e3:0608 Genesys Logic, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
~>
C'est le "device 004" : "Broadcom Corp. BCM43143 802.11bgn (1x1) Wireless Adapter".

J'ai trouvé ce lien :
--> https://wireless.wiki.kernel.org/en/use ... /brcm80211

Comment faire pour que je puisse à nouveau utiliser ce dongle wifi officiel ?

@+
--> RPi0v1.3, RPi0W, Rpi0WH + Tuner TV HAT, 2xRpi2B, Rpi3A+, Rpi3B+

Artemus24
Raspinaute
Messages : 412
Enregistré le : ven. 15 sept. 2017 19:15

Re: Dongle Wifi officiel de Raspberry qui ne fonctionne plus !

Message par Artemus24 » mer. 11 sept. 2019 16:51

Salut à tous.

Je rajoute ceci afin d'avoir les caractéristiques de ce dongle wifi :

Code : Tout sélectionner

~> lsusb
Bus 001 Device 005: ID 0b95:772b ASIX Electronics Corp. AX88772B
Bus 001 Device 003: ID 05e3:0608 Genesys Logic, Inc. Hub
Bus 001 Device 004: ID 0a5c:bd1e Broadcom Corp. BCM43143 802.11bgn (1x1) Wireless Adapter
Bus 001 Device 002: ID 05e3:0608 Genesys Logic, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

~> lsusb -D /dev/bus/usb/001/004
Device: ID 0a5c:bd1e Broadcom Corp. BCM43143 802.11bgn (1x1) Wireless Adapter
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass          255 Vendor Specific Class
  bDeviceSubClass         0
  bDeviceProtocol         0
  bMaxPacketSize0        64
  idVendor           0x0a5c Broadcom Corp.
  idProduct          0xbd1e BCM43143 802.11bgn (1x1) Wireless Adapter
  bcdDevice            0.01
  iManufacturer           1 Broadcom
  iProduct                2 BCMUSB 802.11 Wireless Adapter
  iSerial                 3 43143
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           46
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0
    bmAttributes         0xa0
      (Bus Powered)
      Remote Wakeup
    MaxPower              200mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           4
      bInterfaceClass       255 Vendor Specific Class
      bInterfaceSubClass      2
      bInterfaceProtocol    255
      iInterface              0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0010  1x 16 bytes
        bInterval               4
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x82  EP 2 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x83  EP 3 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x04  EP 4 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               1
Device Qualifier (for other device speed):
  bLength                10
  bDescriptorType         6
  bcdUSB               2.00
  bDeviceClass          255 Vendor Specific Class
  bDeviceSubClass         0
  bDeviceProtocol         0
  bMaxPacketSize0        64
  bNumConfigurations      1
Device Status:     0x0000
  (Bus Powered)
~>
Je me demande si ce dongle ne fonctionnerait plus.
Comment le savoir ?

@+
--> RPi0v1.3, RPi0W, Rpi0WH + Tuner TV HAT, 2xRpi2B, Rpi3A+, Rpi3B+

dyox
Raspinaute
Messages : 555
Enregistré le : dim. 28 déc. 2014 15:28
Localisation : Le long de la côte, au dessus du pays des bigoudennes, aïe

Re: Dongle Wifi officiel de Raspberry qui ne fonctionne plus !

Message par dyox » mer. 11 sept. 2019 17:57

Bonsoir Artemus24,

Si c'est pour savoir si la clé fonctionne encore, autant la tester sur PC ou en téléchargeant l'ancienne iso pour être sûr.

un pb de driver p-ê ?
sudo lsmod

Rien dans le journal de flagrant ?
$ dmesg

La garantie est de 2 ans donc vous pouvez la renvoyer si elle est HS.
Débutant sous RPi / linux

:arrow: :arrow: :arrow: [Pour bien commencer] Pour les nouveaux acquéreurs de Raspberry Pi (liste de liens utiles)

Artemus24
Raspinaute
Messages : 412
Enregistré le : ven. 15 sept. 2017 19:15

Re: Dongle Wifi officiel de Raspberry qui ne fonctionne plus !

Message par Artemus24 » mer. 11 sept. 2019 19:55

Salut à tous.

Bon, j'ai trouvé et c'est une connerie de ma part ! :oops:

Il y a quelques temps, ma box sfr a été remise à zéro par le service sfr.
J'ai réinstallé une sauvegarde que j'avais faite sans trop faire attention de ce qu'elle possédait comme configuration.
Entre autre, il manquait l'adresse MAC de ce dongle wifi dans le blocage wifi, ainsi que les adresses Ipv4 & Ipv6.

Tout est rentré dans l'ordre et ça fonctionne correctement maintenant.

@ dyox : j'ai cherché un peu partout sans avoir une quelconque piste à exploiter.
Ma dongle wifi était reconnu aussi bien par windows que par mes raspberry pi.
Et je ne comprenais pas pourquoi le DHCP ne donnait pas les adresses IPv4 & IPv6.
Même quand je les ai réinstallé dans la box sfr.
Et oui, j'avais oublié de vérifier les adresses MAC autorisées à se connecter par le wifi.

@+
--> RPi0v1.3, RPi0W, Rpi0WH + Tuner TV HAT, 2xRpi2B, Rpi3A+, Rpi3B+

Répondre

Retourner vers « Utilisateurs avancés »