Access Point : je veux juste accéder à mon raspberry.

Photographie ultra-rapide, pilotage d'imprimante 3D ou de CNC, fabrication de bière.... Enfin tout ce que le Raspberry peut gérer trouvera sa place dans cette rubrique

Modérateur : Francois

ManuelCQE
Messages : 15
Enregistré le : ven. 31 mai 2019 20:49

Re: Access Point : je veux juste accéder à mon raspberry.

Message par ManuelCQE » lun. 10 juin 2019 13:00

J'en perds mon latin. j'éteins ma RPI le temps que je fasse une sauvegarde de ma carte SD et je la relance et je suis revenu au point de départ... :evil:

ce que j'ai fait pour que ça marche :
- préparation de la carte SD avec raspbian stretch.
- commande : sudo raspi-config (changer le mot de passe et la taille de ma carte SD )
- commande : sudo apt update -y && sudo apt upgrade -y && sudo apt install dnsmasq hostapd -y (ce coup ci j'en avais marre d'attendre, je suis allé faire autre...)
- commande : sudo nano /etc/hostapd/hostapd.conf avec cette configuration :

Code : Tout sélectionner

interface=wlan0
# bridge=br0
driver=nl80211

logger_syslog=-1
logger_syslog_level=2
logger_stdout=-1
logger_stdout_level=2

ssid=MonAccesRPI
country_code=FR

hw_mode=g
channel=7

beacon_int=100
dtim_period=2
max_num_sta=255
rts_threshold=2347
fragm_threshold=2346

macaddr_acl=0
#accept_mac_file=/etc/hostapd/hostapd.accept

auth_algs=1
ignore_broadcast_ssid=0

ieee80211n=1

wmm_enabled=1
require_ht=1

wpa=2
wpa_passphrase=lesmysteresdelouest
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP CCMP
rsn_pairwise=CCMP

wps_state=0
- commande : sudo nano /etc/default/hostapd (pour DAEMON_CONF="/etc/hostapd/hostapd.conf")
- commande : sudo systemctl unmask hostapd
- commande : sudo systemctl enable hostapd
- commande : sudo hostapd -dd /etc/hostapd/hostapd.conf

Suite à cela j'ai vu mon SSID je me suis connecté. (youpi)
(pause déjeuné)
j’arrête ma RPI pour sauvegarder ma config pour ne pas recommencer à zéro...
Redémarrage de ma RPI.
Test de mon wifi pour voir si ça marche et je peux continuer ce que j'ai à faire : crash du RPI retour à la case départ

Question idiote, en faisant : sudo apt update -y && sudo apt upgrade -y && sudo apt install dnsmasq hostapd -y et la suite de mon paramétrage du hostapd, est ce que toutes les updates et tous les upgrade n’étaient pas effectif et donc une merdouille ou deux n’empêcheraient pas le hostapd de tourner avant de la manip de "redémarrage" ?

ManuelCQE
Messages : 15
Enregistré le : ven. 31 mai 2019 20:49

Re: Access Point : je veux juste accéder à mon raspberry.

Message par ManuelCQE » lun. 10 juin 2019 19:14

Bonsoir,

juste pour dire que j'ai pu un peu avancer grâce à la commande sudo hostapd -dd /etc/hostapd/hostapd.conf

déjà cette commande marche quand hostapd est hors service (sudo systemctl stop hostapd - quand les infos ne sont explicite, ce n'est pas évident pour certains...)

ensuite cette partie :

Code : Tout sélectionner

nl80211: Setup AP(wlan0) - device_ap_sme=1 use_monitor=0
nl80211: Subscribe to mgmt frames with AP handle 0xc34100 (device SME)
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0xc34100 match=04
nl80211: Register frame command failed (type=208): ret=-114 (Operation already in progress)
nl80211: Register frame match - hexdump(len=1): 04
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0xc34100 match=0501
nl80211: Register frame command failed (type=208): ret=-114 (Operation already in progress)
nl80211: Register frame match - hexdump(len=2): 05 01
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0xc34100 match=0504
nl80211: Register frame command failed (type=208): ret=-114 (Operation already in progress)
nl80211: Register frame match - hexdump(len=2): 05 04
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0xc34100 match=06
nl80211: Register frame command failed (type=208): ret=-114 (Operation already in progress)
nl80211: Register frame match - hexdump(len=1): 06
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0xc34100 match=08
nl80211: Register frame command failed (type=208): ret=-114 (Operation already in progress)
nl80211: Register frame match - hexdump(len=1): 08
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0xc34100 match=09
nl80211: Register frame command failed (type=208): ret=-114 (Operation already in progress)
nl80211: Register frame match - hexdump(len=1): 09
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0xc34100 match=0a
nl80211: Register frame command failed (type=208): ret=-114 (Operation already in progress)
nl80211: Register frame match - hexdump(len=1): 0a
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0xc34100 match=11
nl80211: Register frame command failed (type=208): ret=-114 (Operation already in progress)
nl80211: Register frame match - hexdump(len=1): 11
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0xc34100 match=7f
nl80211: Register frame command failed (type=208): ret=-114 (Operation already in progress)
nl80211: Register frame match - hexdump(len=1): 7f
nl80211: Failed to subscribe for mgmt frames from SME driver - trying to run without it
nl80211: Enable Probe Request reporting nl_preq=0xc34100
nl80211: Register frame type=0x40 (WLAN_FC_STYPE_PROBE_REQ) nl_handle=0xc34100 match=
nl80211: Register frame command failed (type=64): ret=-114 (Operation already in progress)
nl80211: Register frame match - hexdump(len=0): [NULL]
nl80211: Failed to enable Probe Request frame reporting in AP mode
rfkill: initial event: idx=0 type=1 op=0 soft=0 hard=0
nl80211: Add own interface ifindex 3 (ifidx_reason -1)
nl80211: if_indices[16]: 3(-1)
Est résolue :

Code : Tout sélectionner

nl80211: Setup AP(wlan0) - device_ap_sme=1 use_monitor=0
nl80211: Subscribe to mgmt frames with AP handle 0x1a55100 (device SME)
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0x1a55100 match=04
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0x1a55100 match=0501
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0x1a55100 match=0504
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0x1a55100 match=06
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0x1a55100 match=08
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0x1a55100 match=09
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0x1a55100 match=0a
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0x1a55100 match=11
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0x1a55100 match=7f
nl80211: Enable Probe Request reporting nl_preq=0x1a55160
nl80211: Register frame type=0x40 (WLAN_FC_STYPE_PROBE_REQ) nl_handle=0x1a55160 match=
rfkill: initial event: idx=0 type=1 op=0 soft=0 hard=0
nl80211: Add own interface ifindex 3 (ifidx_reason -1)
nl80211: if_indices[16]: 3(-1)
Grace à ce topic trouvé sur GitHub : https://github.com/jekader/hostapd-rtl/issues/12

J'ai juste créé un fichier 8192cu.conf dans /etc/modprobe.d/ (sudo nano /etc/modprobe.d/ 8192cu.conf)

Pour y mettre :

Code : Tout sélectionner

options 8192cu rtw_power_mgnt=0 rtw_enusbss=0 rtw_hwpwrp_detect=0 rtw_ips_mode=1
et un petit redémarrage...

Hélas même si ça avance je ne me logue pas ("crash du raspberry comme toujours"...) il me resterait à résoudre :

Code : Tout sélectionner

nl80211: sta_remove -> DEL_STATION wlan0 ff:ff:ff:ff:ff:ff --> -22 (Invalid argument)
[...]
nl80211: Set wlan0 operstate 0->1 (UP)
netlink: Operstate: ifindex=3 linkmode=-1 (no change), operstate=6 (IF_OPER_UP)
Failed to set TX queue parameters for queue 0.
Failed to set TX queue parameters for queue 1.
Failed to set TX queue parameters for queue 2.
Failed to set TX queue parameters for queue 3.
wlan0: interface state COUNTRY_UPDATE->ENABLED
wlan0: AP-ENABLED
wlan0: Setup of interface done.
ctrl_iface not configured!
 
bref le ff:ff:ff:ff:ff:ff invalide, les failed sur le TX et le "ctrl_iface not configured!"

Juste pour info j'ai configuré cette fois-ci le dhcpcd et le dnsmasq et j'ai bien une adresse ip attribué à wlan0...

(PS, j'ai l'impression de faire un monologue... :oops: )

ManuelCQE
Messages : 15
Enregistré le : ven. 31 mai 2019 20:49

Re: Access Point : je veux juste accéder à mon raspberry.

Message par ManuelCQE » lun. 10 juin 2019 20:43

juste pour infos voici les statuts de dhcpcd et dnsmasq :

Code : Tout sélectionner

pi@raspberrypi:~ $ sudo systemctl status dhcpcd
● dhcpcd.service - dhcpcd on all interfaces
   Loaded: loaded (/lib/systemd/system/dhcpcd.service; enabled; vendor preset: enabled)
  Drop-In: /etc/systemd/system/dhcpcd.service.d
           └─wait.conf
   Active: active (running) since Mon 2019-06-10 19:33:59 BST; 2min 31s ago
  Process: 345 ExecStart=/usr/lib/dhcpcd5/dhcpcd -q -w (code=exited, status=0/SUCCESS)
 Main PID: 449 (dhcpcd)
   CGroup: /system.slice/dhcpcd.service
           └─449 /sbin/dhcpcd -q -w

Jun 10 19:34:01 raspberrypi dhcpcd[449]: wlan0: IAID 38:5b:59:0e
Jun 10 19:34:01 raspberrypi dhcpcd[449]: wlan0: adding address fe80::17ef:50ce:404f:5d5f
Jun 10 19:34:01 raspberrypi dhcpcd[449]: wlan0: probing address 192.168.4.1/24
Jun 10 19:34:01 raspberrypi dhcpcd[449]: wlan0: soliciting an IPv6 router
Jun 10 19:34:03 raspberrypi dhcpcd[449]: eth0: leased 192.168.0.41 for 43200 seconds
Jun 10 19:34:03 raspberrypi dhcpcd[449]: eth0: adding route to 192.168.0.0/24
Jun 10 19:34:03 raspberrypi dhcpcd[449]: eth0: adding default route via 192.168.0.254
Jun 10 19:34:06 raspberrypi dhcpcd[449]: wlan0: using static address 192.168.4.1/24
Jun 10 19:34:06 raspberrypi dhcpcd[449]: wlan0: adding route to 192.168.4.0/24
Jun 10 19:34:14 raspberrypi dhcpcd[449]: wlan0: no IPv6 Routers available
Warning: dhcpcd.service changed on disk. Run 'systemctl daemon-reload' to reload units.
pi@raspberrypi:~ $ sudo systemctl status dnsmasq
● dnsmasq.service - dnsmasq - A lightweight DHCP and caching DNS server
   Loaded: loaded (/lib/systemd/system/dnsmasq.service; enabled; vendor preset: enabled)
   Active: active (running) since Mon 2019-06-10 19:34:01 BST; 3min 33s ago
  Process: 477 ExecStartPost=/etc/init.d/dnsmasq systemd-start-resolvconf (code=exited, status=0/SUCCESS)
  Process: 467 ExecStart=/etc/init.d/dnsmasq systemd-exec (code=exited, status=0/SUCCESS)
  Process: 454 ExecStartPre=/usr/sbin/dnsmasq --test (code=exited, status=0/SUCCESS)
 Main PID: 475 (dnsmasq)
   CGroup: /system.slice/dnsmasq.service
           └─475 /usr/sbin/dnsmasq -x /run/dnsmasq/dnsmasq.pid -u dnsmasq -r /run/dnsmasq/resolv.conf -7 /etc/dnsmasq.d,.dpkg-dist,.dpkg-

Jun 10 19:34:00 raspberrypi dnsmasq[475]: warning: interface wlan0 does not currently exist
Jun 10 19:34:00 raspberrypi dnsmasq-dhcp[475]: DHCP, IP range 192.168.4.100 -- 192.168.4.240, lease time 1d
Jun 10 19:34:00 raspberrypi dnsmasq[475]: reading /run/dnsmasq/resolv.conf
Jun 10 19:34:00 raspberrypi dnsmasq[475]: using nameserver fd0f:ee:b0::1#53
Jun 10 19:34:00 raspberrypi dnsmasq[475]: read /etc/hosts - 5 addresses
Jun 10 19:34:01 raspberrypi dnsmasq[477]: Too few arguments.
Jun 10 19:34:01 raspberrypi systemd[1]: Started dnsmasq - A lightweight DHCP and caching DNS server.
Jun 10 19:34:03 raspberrypi dnsmasq[475]: reading /run/dnsmasq/resolv.conf
Jun 10 19:34:03 raspberrypi dnsmasq[475]: using nameserver 192.168.0.254#53
Jun 10 19:34:03 raspberrypi dnsmasq[475]: using nameserver fd0f:ee:b0::1#53

ManuelCQE
Messages : 15
Enregistré le : ven. 31 mai 2019 20:49

Re: Access Point : je veux juste accéder à mon raspberry.

Message par ManuelCQE » mar. 11 juin 2019 20:28

Bonsoir,

à la question : est ce que mon RPI plante vraiment ? j'ai pu brancher un écran et un clavier, j'ai fait le test, et oui il plante.
Avec la commande sudo hostapd -dd /etc/hostapd/hostapd.conf j'ai pu voir que mon RPI vomissait un log (extrêmement long) que je n'ai pu sauvegardé à cause du plantage :shock:

ManuelCQE
Messages : 15
Enregistré le : ven. 31 mai 2019 20:49

Re: Access Point : je veux juste accéder à mon raspberry.

Message par ManuelCQE » mar. 11 juin 2019 23:01

Bonsoir,

y a t'il un moyen pour récupérer un log au moment du crash ?

dyox
Raspinaute
Messages : 506
Enregistré le : dim. 28 déc. 2014 15:28
Localisation : Le long de la côte, au dessus du pays des bigoudennes, aïe

Re: Access Point : je veux juste accéder à mon raspberry.

Message par dyox » mer. 12 juin 2019 09:18

Bonjour,

A dépanner comme ça, le réseau n'est jamais facile. Peut-être faut-il recommencer dès le début avec une nouvelle sd / clé usb ?

Sinon, tout est good avec le tuto concernant le nat ? https://www.raspberrypi.org/documentati ... s-point.md
Plus précisément avec iptables et ip_forward.
Débutant sous RPi / linux

:arrow: :arrow: :arrow: [Pour bien commencer] Pour les nouveaux acquéreurs de Raspberry Pi (liste de liens utiles)

ManuelCQE
Messages : 15
Enregistré le : ven. 31 mai 2019 20:49

Re: Access Point : je veux juste accéder à mon raspberry.

Message par ManuelCQE » mer. 12 juin 2019 23:23

Bonsoir,

Je prend note (quoique à chaque fois que je recommence à zéro je formate la carte SD, s'il y avait quelque chose qui déconnait mon windows m'aurait forcément envoyé en pleine tronche comme mon ancienne carte SD... RIP carte SD...) la clé usb : le dongle? je ne vois pas pourquoi vu que je l'ai testé en tant que client avec mon RPI elle ne m'a pas posé de pb...

Après je pense à autre chose : depuis le début je fais tout par SSH... Donc j'utilise le réseau pendant que je paramètre le réseau, certains services ne redémarrent p-e pas juste pour assurer la connexion en SSH... J'ai remarqué cela quand j'ai essayé de me connecter avec mon téléphone portable alors que "j'étais encore branché en SSH sur le port ethernet" : il ne s'est pas connecté, mais mon RPI n'a pas planté...! :shock:

Autre chose j'ai essayé de paramétrer le NAT (juste pour le fun normalement je ne l'aurais pas installé) il me sort une erreur :

iptables-restore v1.6.0: iptables-restore: unable to initialize table 'nat'

Error occurred at line: 2
Try `iptables-restore -h' or 'iptables-restore --help' for more information.

Si ça se trouve je dois tout configurer avec un clavier et un écran branché sur le RPI... (Chose qui serait p-e logique mais 1° je n'ai pas pensé et 2° ce n'est pas forcément défini dans les tutos... Après si quelqu'un a paramétrer un AP sur un RPI en SSH je suis preneur !)

ManuelCQE
Messages : 15
Enregistré le : ven. 31 mai 2019 20:49

Re: Access Point : je veux juste accéder à mon raspberry.

Message par ManuelCQE » ven. 14 juin 2019 20:22

bonsoir,

juste pour faire un point : j'ai fait une installation avec clavier et souris à partir de zéro (sur la même carte SD, j'ai fais un formatage complet au cas où RAS de ce coté)
rien n'a vraiment changé de ce coté la sauf que j'ai pu diagnostiqué le crash de ma RPI : kernel panic...

J'ai essayé de voir avec un collègue qu'est ce qui aurait pu en être le cause en vain :
  • Sur un topic en anglais on a pu lire que cela pouvait être le firmware (mon firmware était d'origine...) on à fait une MAJ (sudo rpi-update) cela s'est bien passé mais aucun effet escompté
  • Sur le même on a vu que cela pouvait venir d'une tension instable on a emprunté un chargeur de téléphone qui pouvait tenir 2A en charge, pas de pb sur la fluctuation de tension mais toujours kernel panic
  • Pour finir on a lu aussi que cela pouvait venir de la limitation d'ampérage sur les ports USB donc on a débridé l'intensité sur les port USB rien n'y fait...
Je sais pas, je n'ai plus d'idées pour me dépanner...

Si c'est effectivement ma clé usb qui déconne, je n'ai plus qu'une solution c'est d'acheter un RPI3 vu qu'il y a déjà un wifi intégré et je ne me vois pas investir dans un nouveau dongle au risque d'être dans la même situation...

je reviendrai sur ce topic d'ici là... Le temps que je me décide à investir sur un RPI3 vous aurez peut être trouvé une solution à mon problème... :roll:

dyox
Raspinaute
Messages : 506
Enregistré le : dim. 28 déc. 2014 15:28
Localisation : Le long de la côte, au dessus du pays des bigoudennes, aïe

Re: Access Point : je veux juste accéder à mon raspberry.

Message par dyox » ven. 14 juin 2019 22:25

Bonsoir,

Au cas où, regardez sur https://elinux.org/RPi_USB_Wi-Fi_Adapters en faisant une recherche du chipset wifi. J'y ai vu un fichier de conf de hostapd.
Débutant sous RPi / linux

:arrow: :arrow: :arrow: [Pour bien commencer] Pour les nouveaux acquéreurs de Raspberry Pi (liste de liens utiles)

Répondre

Retourner vers « Les applications spécialisées du Raspberry Pi »