Serveur web ok ! Mais après..?

Photographie ultra-rapide, pilotage d'imprimante 3D ou de CNC, fabrication de bière.... Enfin tout ce que le Raspberry peut gérer trouvera sa place dans cette rubrique

Modérateur : Francois

Bud Spencer
Raspinaute
Messages : 630
Enregistré le : lun. 15 août 2016 21:38

Re: Serveur web ok ! Mais après..?

Message par Bud Spencer » jeu. 6 oct. 2016 20:08

champi a écrit :lol, pourquoi des reproches..? bref :)
comme tu dis 'lol' :lol:
champi a écrit : Bon j'ai tout enlever et je vais essayer un autre tuto car je me suis cassé la tête et je pense qu'il est préférable de tout reprendre.
Mais c'est étrange que personne n'est installé Nginx sur la pi ici, alors que tout le monde dit qu'il est moins gourmand mais effectivement semble plus compliqué que Apache
J'avais installé Nginx et Lighttp pour faire des benchs comparé à Apache et je ne me souvient pas avoir beaucoup galéré pour ca. Bon après WordPress, j'ai pas essayé, mais si tu arrives sur ta page d'accueil, c'est que la partie serveur web fonctionne et que ton problème est forcement un problème de configuration spécifique. Pas de raison que ca ne fonctionne pas, d'ailleurs, si tu te documentes bien, tu pourras constater par toi même que de plus en plus de gros sites WordPress laisse tomber Apache pour passer sous NGinx.
Le premier ennemi de la connaissance n’est pas l’ignorance, c’est l’illusion de la connaissance (S. Hawking).

champi
Messages : 20
Enregistré le : jeu. 7 mai 2015 23:39

Re: Serveur web ok ! Mais après..?

Message par champi » mer. 2 nov. 2016 04:33

Au final j'ai tout réinstallé et j'ai suivi l'un des tutos sur ce site http://www.digitalocean.com/ Et tout fonctionne bien dépuis.
Bon maintenant ma question, avoir un blog c'est bien, héberger son blog c'est très bien, mais et la loi sur les cookies ? On est obligé d'informer les internautes des cookies mais avec notre propre serveur sa semble compliqué !
Comment faite vous ?

Alexidreaming
Raspinaute
Messages : 211
Enregistré le : mar. 16 août 2016 20:55
Contact :

Re: Serveur web ok ! Mais après..?

Message par Alexidreaming » mer. 2 nov. 2016 15:52

Salut, j'ai trouvé cet extrait sur la loi des cookies:
En application de la directive européenne dite " paquet télécom ", les internautes doivent être informés et donner leur consentement préalablement à l'insertion de traceurs. Ils doivent disposer d'une possibilité de choisir de ne pas être tracés lorsqu'ils visitent un site ou utilisent une application. Les éditeurs ont donc l'obligation de solliciter au préalable le consentement des utilisateurs. Ce consentement est valable 13 mois maximum. Certains traceurs sont cependant dispensés du recueil de ce consentement.
Mais dis moi, tu fais ton serveur en quoi, php ou html?

Si c'est html je peut te fournir ceci:

<script src="/votre-repertoire/cookiechoices.js"></script>
<script>document.addEventListener('DOMContentLoaded', function(event) {
cookieChoices.showCookieConsentBar('Votre message indiquant que votre site Web utilise des cookies',
'Pas de problème !', 'En savoir plus ...', 'http://votre-site.com/confidentialite/cookie.html');
});
</script>
(codé en html5)

En espérant t'avoir aidé...

ps: si ton blog/site est accessible partout sur le web, donne nous le lien stp.
Le pro du déterrage de topic est là!

Alexidreaming

champi
Messages : 20
Enregistré le : jeu. 7 mai 2015 23:39

Re: Serveur web ok ! Mais après..?

Message par champi » mer. 2 nov. 2016 16:22

Merci pour ta réponse rapide, non je suis en php... Malheureusement.

mes6favoris.serveblog.net voilà l'adresse de mon blog.

Va falloir que je me plonge encore dans une programmation lol, mais c'est un beau challenge... Qui donne de beau mal de tête, mais après tu es fière !

Alexidreaming
Raspinaute
Messages : 211
Enregistré le : mar. 16 août 2016 20:55
Contact :

Re: Serveur web ok ! Mais après..?

Message par Alexidreaming » ven. 4 nov. 2016 20:38

Salut, super le site, je sais pas si c'est toi mai il y a un bandeau qui s'affiche en bas de la page au chargement de la page...

Sinon je me servirais de ton site pour mes prochains invités

Bonne continuation!
Modifié en dernier par Alexidreaming le sam. 5 nov. 2016 12:09, modifié 1 fois.
Le pro du déterrage de topic est là!

Alexidreaming

destroyedlolo
Raspinaute
Messages : 1317
Enregistré le : dim. 10 mai 2015 18:44
Localisation : Dans la campagne à côté d'Annecy
Contact :

Re: Serveur web ok ! Mais après..?

Message par destroyedlolo » ven. 4 nov. 2016 21:29

champi a écrit :Merci pour ta réponse rapide, non je suis en php... Malheureusement.
Pourquoi malheureusement ?
T'as juste à rajouter le code donné plus haut dans les sections html de ton code php.

Sinon, j'aime bien ton site ;)
  • BananaPI : Gentoo, disque SATA de 2 To
  • Domotique : 1-wire, TéléInfo, Tablette passée sous Gentoo, ESP8266
  • Multimedia par DNLA
  • Et pleins d'idées ... et bien sûr, pas assez de temps.
Un descriptif de ma domotique 100% fait maison.

champi
Messages : 20
Enregistré le : jeu. 7 mai 2015 23:39

Re: Serveur web ok ! Mais après..?

Message par champi » lun. 19 déc. 2016 02:10

Merci d'être passé, hésité pas à laisser un commentaire ou de share à l'occasion ;)
De plus, je ferais un landing page^^

@le bandeau c'est l'avertissement pour les cookies qui est obligatoire, je devais faire des tests en installant un plugin (plus simple) quand tu a été probablement.

Alors, le truc c'est que j'ai appris que WordPress et Google ont décidé de forcer les utilisateurs à passer en https au lieu de ce bon vieux http (dès le janvier 2017 quoi :/)... mais quelle galère quoi sérieux T.T

Horace
Messages : 8
Enregistré le : mer. 15 juin 2016 19:08

Re: Serveur web ok ! Mais après..?

Message par Horace » mar. 28 févr. 2017 09:34

Salut à tous,
Je suis débutant en Html et Linux, et j'ai installé Nginx sur Framboiss pi 2 sous Raspian. J'ai suivi avec attention le tuto, et je n'ai eu aucun problème d'installation. Sauf que ... je n'ai pas pensé installer le log pour savoir qui s'est connecté. Mais c'est une autre histoire. Je me suis plongé dans Html, et là, j'ai du batailler pour que ce qui apparaît à l'écran soit conforme à mes idées. Après quelques litres de transpiration, j'y suis arrivé !
Allez voir http://www.reguin-elies.bzh
Puis j'ai installé Webmin, qui est un petit bijou !
Je vais me lancer dans un blog, et une boîte mail ... prochainement.
Cordialement
Horace

champi
Messages : 20
Enregistré le : jeu. 7 mai 2015 23:39

Re: Serveur web ok ! Mais après..?

Message par champi » ven. 7 avr. 2017 18:13

pas mal le site^^

Répondre

Retourner vers « Les applications spécialisées du Raspberry Pi »