Ma pi3 n'est pas vu dans le réseau

Paramétrer le Raspberry Pi B/B+ pour se connecter via Ethernet ou une clé WiFi USB

Modérateurs : Francois, maxty01

spourre
Raspinaute
Messages : 602
Enregistré le : lun. 22 déc. 2014 17:50
Localisation : 67380 LINGOLSHEIM

Re: Ma pi3 n'est pas vu dans le réseau

Messagepar spourre » mer. 6 déc. 2017 18:06

Fredcelmax a écrit :Bonjour et merci de votre collaboration,
Lorsque j'avais ma pi2 branchée / sur un routeur TPlink, je cliquais sur réseau (pc) et ma pi apparassait je rentrais admin et le mdp et je pouvais voir toutes mes photos faites et rentrer dans les réglages de la pi2.
...
.


Comme déjà dit, il faut y aller "pas à pas".
Avant d'être visible dans un environnement Windows, une machine Linux doit monter des services. Pour que ces services puissent fonctionner, il faut que le réseau, couche en dessous, fonctionne.
C'est comme un oignon :)

On va donc commencer par le niveau le plus bas, la connexion physique. Il faut relier votre Raspberry par un câble réseau, branché sur sa prise Ethernet et sur un port du switch (qui devra lui, être relié à la box). Vous pouvez aussi branché le Raspberry directement sur la box.
si la LED su port Ethernet du Raspberry est allumée (et celle du switch ou de la box aussi), c'est bon signe et cela signifie que les équipements se voient.

Pour les tests suivants, il serait plus simple d'avoir un écran relié au Raspberry (une simple TV HDMI), un clavier et une souris. On peut faire sans, mais c'est plus compliqué.
Questions:
-) Avez-vous ce matériel sous la main.
-) Si oui, après démarrage du Raspberry, arrivez-vous à vous connecter ?
En fonction de ces réponses, on verra la suite des tests.

Nota: Ça n’empêche pas de vérifier la configuration de la Freebox et de vérifier que la fonction routeur soit bien activée.

Sylvain

Fredcelmax
Messages : 9
Enregistré le : dim. 3 déc. 2017 21:25

Re: Ma pi3 n'est pas vu dans le réseau

Messagepar Fredcelmax » mer. 6 déc. 2017 21:50

Bonsoir,
Apparemment c'est un problème de fichier chargé dans la mini sd car la pi3 tourne en boucle lorsqu'elle est chargée sur ma tv.

Fredcelmax
Messages : 9
Enregistré le : dim. 3 déc. 2017 21:25

Re: Ma pi3 n'est pas vu dans le réseau

Messagepar Fredcelmax » mer. 6 déc. 2017 22:13

Pour répondre à Sylvain et je le remercie très sincèrement,
La prise rj45 derrière la pi3 ne s'allume pas donc pas bon signe !

spourre
Raspinaute
Messages : 602
Enregistré le : lun. 22 déc. 2014 17:50
Localisation : 67380 LINGOLSHEIM

Re: Ma pi3 n'est pas vu dans le réseau

Messagepar spourre » jeu. 7 déc. 2017 00:54

Fredcelmax a écrit :La prise rj45 derrière la pi3 ne s'allume pas donc pas bon signe !


C'est peut-être lié au phénomène que vous décrivez un post plus haut.
Quand vous écrivez " la pi3 tourne en boucle lorsqu'elle est chargée sur ma tv." pouvez-vous décrire ce qui se passe et, éventuellement, nous dire ce qui est affiché ?
Faut-il comprendre que le Raspberry ne démarre pas correctement ? Si c'est bien le cas, il faut déjà régler ce problème avant d'incriminer le réseau.
Je suppose que votre ordinateur tourne sous Windows. Avez-vous vérifié l'intégrité de votre fichier avant de le graver sur la carte SD (en général, un fichier checksum.txt est proposé au chargement avec le fichier *.img).

Sylvain

Fredcelmax
Messages : 9
Enregistré le : dim. 3 déc. 2017 21:25

Re: Ma pi3 n'est pas vu dans le réseau

Messagepar Fredcelmax » jeu. 7 déc. 2017 20:59

Bonsoir Sylvain,
Je fais ceci dès que la tv est disponible...
Je noterai peut être une photo également.
Mon pc est équipé de win 10 64 bits.
Je n'ai pas vérifié l'intégrité du fichier d'une part et d'autre part je n'en connais pas le détail du fichier à copier.

Fredcelmax
Messages : 9
Enregistré le : dim. 3 déc. 2017 21:25

Re: Ma pi3 n'est pas vu dans le réseau

Messagepar Fredcelmax » jeu. 7 déc. 2017 21:59

çà y est, en effet le chargement de ma pi3 branchée sur ma tv tourne en boucle.
Voici la photo.
J'espère que tu vas pouvoir la lire sans difficulté.
A bientôt, et encore merci à Sylvain.
Fredcelmax

IMG_1949-07-12-17-20-53.JPG
IMG_1949-07-12-17-20-53.JPG (476.2 Kio) Vu 42 fois

spourre
Raspinaute
Messages : 602
Enregistré le : lun. 22 déc. 2014 17:50
Localisation : 67380 LINGOLSHEIM

Re: Ma pi3 n'est pas vu dans le réseau

Messagepar spourre » ven. 8 déc. 2017 11:55

Donc me Raspberry ne démarre pas et on ne peut pas prendre la main dessus pour analyser ce qui se passe.
Je suis allé sur le site de motion-os mais je n'ai pas vu de fichier de checksum. C'est dommage car cela permet de vérifier que l'image chargée n'est pas altérée.
A ce niveau, ma suggestion serait de recharger l'image et de refaire la carte SD. Une autre possibilité, pour essais, est de charger l'image de la Raspbian.
L'objectif est de détecter si le problème vient de l'image, de la carte SD ou du Raspberry. Après, il sera temps de se pecher sur l'éventuel problème réseau.

Sylvain

Fredcelmax
Messages : 9
Enregistré le : dim. 3 déc. 2017 21:25

Re: Ma pi3 n'est pas vu dans le réseau

Messagepar Fredcelmax » sam. 9 déc. 2017 12:53

Bonjour Sylvain,
La sd est partitionnée en 2 est ce normal ?

spourre
Raspinaute
Messages : 602
Enregistré le : lun. 22 déc. 2014 17:50
Localisation : 67380 LINGOLSHEIM

Re: Ma pi3 n'est pas vu dans le réseau

Messagepar spourre » sam. 9 déc. 2017 13:57

Fredcelmax a écrit :Bonjour Sylvain,
La sd est partitionnée en 2 est ce normal ?


C'est tout à fait normal.
La première partition, petite, est obligatoirement formatée en fat32 (un format historique de Windows). C'est dû au mode de démarrage du Raspberry qui n'a pas de BIOS, comme un vrai PC, et qui démarre sur le contrôleur graphique (GPU). A cette étape, il ne sait pas gérer autre chose.
La 2 ème partition (bien plus grande) comporte le système des fichiers nécessaires au système (RFS), les programmes et les données de l'utilisateur.
Ceci est très bien décrit dans un très bon article (comme toujours) de François à chercher dans les articles du Blog.

Nota: il a a d'autres possibilités de démarrage mais, pour le moment, je fais "simple" pour ne pas vous noyer.

Sylvain

Fredcelmax
Messages : 9
Enregistré le : dim. 3 déc. 2017 21:25

Re: Ma pi3 n'est pas vu dans le réseau

Messagepar Fredcelmax » sam. 9 déc. 2017 21:26

Ais-je le droit de te copier le lien vers lequel je vais ?
Je n'arrive pas avancé !


Retourner vers « Le réseau sur le Raspberry Pï »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité