Ethernet branché, plus de réponse du Wifi

Paramétrer le Raspberry Pi B/B+ pour se connecter via Ethernet ou une clé WiFi USB

Modérateurs : Francois, maxty01

Répondre
Minus
Messages : 18
Enregistré le : jeu. 14 avr. 2016 10:02

Ethernet branché, plus de réponse du Wifi

Message par Minus » mar. 10 mai 2016 12:31

Bonjour à tous !

Voilà mon problème, j'aimerai me connecter à un appareil distant connecté en ethernet au Raspberry grâce à un MAC.
Pour cela, je configure mon Raspberry comme un routeur sur lequel je colle un réseau dhcp sur les interfaces wlan0 et eth0. En connectant un Mac en wifi, je peux accéder facilement à tout autre appareils connectés en wifi (ordinateurs, portable etc). Mais, lorsque je branche un appareil en ethernet au Raspberry (un autre Mac, que j'appellerai "Mac1". "Mac" désignera l'ordinateur connecté en wifi), le wifi ne fonctionne plus comme avant, je n'obtient plus de réponses lorsque je ping l'adresse IP affecté au Mac connecté en wifi. En revanche, lorsque je ping "Mac1" j'ai une réponse. En débranchant le cable ethernet, j'obtient à nouveau une réponse en pingant "Mac". Voici les réponses à la commande netstat -rn :

Uniquement en wifi:

Code : Tout sélectionner

pi@be1:~ $ netstat -rn
Table de routage IP du noyau
Destination   Passerelle      Genmask         Indic   MSS Fenêtre irtt Iface
0.0.0.0         192.168.2.1     0.0.0.0         UG        0 0          0 wlan0
192.168.2.0     0.0.0.0         255.255.255.0   U         0 0          0 wlan0
Uniquement en ethernet:

Code : Tout sélectionner

pi@be1:~ $ netstat -rn
Table de routage IP du noyau
Destination     Passerelle      Genmask         Indic   MSS Fenêtre irtt Iface
0.0.0.0         192.168.2.1     0.0.0.0         UG        0 0          0 eth0
192.168.2.0     0.0.0.0         255.255.255.0   U         0 0          0 eth0
En ethernet + wifi:

Code : Tout sélectionner

pi@be1:~ $ netstat -rn
Table de routage IP du noyau
Destination     Passerelle      Genmask         Indic   MSS Fenêtre irtt Iface
0.0.0.0         192.168.2.1     0.0.0.0         UG        0 0          0 eth0
192.168.2.0     0.0.0.0         255.255.255.0   U         0 0          0 eth0
Je vois donc qu'il y a un problème, mais je ne sais pas comment faire pour le régler... Avez-vous des idées ?

Merci d'avance et bonne journée ! :D

Minus
Messages : 18
Enregistré le : jeu. 14 avr. 2016 10:02

Re: Ethernet branché, plus de réponse du Wifi

Message par Minus » ven. 20 mai 2016 09:39

Big Up à mon post ! :D
J'ai toujours pas trouvé de réponse :/

maxty01
Modérateur
Messages : 738
Enregistré le : dim. 16 nov. 2014 20:53
Localisation : Charleroi - Belgique

Re: Ethernet branché, plus de réponse du Wifi

Message par maxty01 » ven. 20 mai 2016 23:22

Bonsoir,

Est-il possible de connaître les différentes adresses IP attribuées aux interface du RPI ainsi qu'à tous les autres "mac".

Peux tu nous dire quels sont les techniques que tu as utilisé pour arriver à tes fins ?

Bonne soirée,
Il n'y a pas de question stupide, il n'y a que des imbéciles qui ne posent pas de question !
RaspBerry Pi : 1 x B+ Raspbian 1 x RPI2 MiniBian
Mieux me connaître ? Regarder mon LinkedIn

Minus
Messages : 18
Enregistré le : jeu. 14 avr. 2016 10:02

Re: Ethernet branché, plus de réponse du Wifi

Message par Minus » mar. 24 mai 2016 09:47

Bonjour,

Pour la configuration du serveur dhcp j'ai utilisé le service isc-dhcp-server avec comme configuration :

Code : Tout sélectionner

subnet 192.168.2.0 netmask 255.255.255.0{
   range 192.168.2.10 192.168.2.100;
   option broadcast-address 192.168.2.255;
   option routers 192.168.2.1;
   default-lease-time 600;
   max-lease-time 7200;
}
Dans le fichier /etc/default/isc-dhcp-server j'ai mis à la ligne INTERFACES:

INTERFACES=“wlan0 eth0“

de tel sorte que le serveur dhcp se mette sur l'ethernet et le wifi.

En configuration routeur je n'utilise pas de “bridge“ pour lancer mon service hostapd. Etant sous Jessie je passes par le fichier de configuration /etc/dhcpcd.conf pour donner des adresses IP fixes. J'ai configuré la même adresse IP au eth0 et wlan0.

Code : Tout sélectionner

interface wlan0
   static ip_address=192.168.2.1/24
   static routeurs=192.168.2.1
   static domain_name_servers=192.168.2.1

Code : Tout sélectionner

interface eth0
   static ip_address=192.168.2.1/24
   static routeurs=192.168.2.1
   static domain_name_servers=192.168.2.1
Les appareils distants se connectant au routeur (wifi ou ethernet) se voient affecter une adresse IP entre 192.168.2.10 et 192.168.2.100.

maxty01
Modérateur
Messages : 738
Enregistré le : dim. 16 nov. 2014 20:53
Localisation : Charleroi - Belgique

Re: Ethernet branché, plus de réponse du Wifi

Message par maxty01 » mar. 24 mai 2016 22:42

Bonsoir,

Mettre la même adresse IP sur 2 interfaces et donc deux segments différents, voila la source la plus probable du problème.

Je te propose de partir sur un "brigde", autrement dit, tu fait en sorte que le système (ton RPI) considère ton interface réseau file et ton interface wifi comme une et une seule carte réseau.

A partir de ce moment là, tu verra toujours tes interfaces eth0 et wlan0, mais sans adresse IP configurée.
Par contre, tu va avoir une nouvelle interface "br0" qui aura ton adresse IP :

Code : Tout sélectionner

interface br0
   static ip_address=192.168.2.1/24
   static routeurs=192.168.2.1
   static domain_name_servers=192.168.2.1
Comme cela, ton RPI fera le lien entre les deux segments.

Pour le challenge, je te laisse regarder de ton coté ce que tu trouve et que tu reviennes expliquer ce que tu as trouvé.
Je garderai un oeil sur ce sujet et je corrigerai si nécessaire.

Bonne soirée,
Il n'y a pas de question stupide, il n'y a que des imbéciles qui ne posent pas de question !
RaspBerry Pi : 1 x B+ Raspbian 1 x RPI2 MiniBian
Mieux me connaître ? Regarder mon LinkedIn

Avatar du membre
vague nerd
Modérateur
Messages : 1473
Enregistré le : mar. 14 oct. 2014 11:42
Localisation : France !

Re: Ethernet branché, plus de réponse du Wifi

Message par vague nerd » mer. 25 mai 2016 11:54

Bonjour.
Je garderai un oeil sur ce sujet
+1
Cdt.
Cordialement,

Vague Nerd

Répondre

Retourner vers « Le réseau sur le Raspberry Pï »