pb de wifi ...

Paramétrer le Raspberry Pi B/B+ pour se connecter via Ethernet ou une clé WiFi USB

Modérateurs : Francois, maxty01

Répondre
hatoupix
Messages : 11
Enregistré le : ven. 7 oct. 2016 14:25

pb de wifi ...

Message par hatoupix » lun. 10 oct. 2016 22:08

Bonjour à tous,

je viens d'avoir mon Raspberry pi 3 et j'ai installé dessus une "Debian Jessie Lite". Tout fonctionne très bien en ethernet mais rien de rien en wifi !

j'ai bien sur suivi le tuto http://www.framboise314.fr/le-wifi-avec ... -commande/ :oops:

j'ai démarré le wlan : sudo iwconfig wlan0 power on

le fichier interface fait bien référence au fichier wpa_supplicant.conf :
auto wlan0
allow-hotplug wlan0
iface wlan0 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

j'ai modifié le fichier wpa_supplicant.conf (les données ssid et psk sont bien case sensitive ?)
country=FR
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
network={
ssid="SSID"
psk="clef_wifi"
}

lsusb
Bus 001 Device 004: ID 0b0e:034c GN Netcom
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

lsusb -t
/: Bus 01.Port 1: Dev 1, Class=root_hub, Driver=dwc_otg/1p, 480M
|__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/5p, 480M
|__ Port 1: Dev 3, If 0, Class=Vendor Specific Class, Driver=smsc95xx, 480M
|__ Port 4: Dev 4, If 0, Class=Audio, Driver=snd-usb-audio, 12M
|__ Port 4: Dev 4, If 1, Class=Audio, Driver=snd-usb-audio, 12M
|__ Port 4: Dev 4, If 2, Class=Audio, Driver=snd-usb-audio, 12M
|__ Port 4: Dev 4, If 3, Class=Human Interface Device, Driver=usbhid, 12M


... je ne vois pas la carte wifi ... :?:




Merci pour votre aide !
Hatoupix

dyox
Raspinaute
Messages : 687
Enregistré le : dim. 28 déc. 2014 15:28
Localisation : Le long de la côte, au dessus du pays des bigoudennes, aïe

Re: pb de wifi ...

Message par dyox » mer. 26 oct. 2016 19:24

Bonsoir,

Je cite un commentaire que j'avais noté dans mon calepin sur un pb similaire :

Fais dmesg | grep 'brcmfmac\|cfg80211'.
Ça devrait te donner les infos concernant la détection du Wifi. Je viens de tester sur le mien, ça me renvoie les informations du module wifi.

Personnellement, j'essaierai d'abord avec une "Debian Jessie FULL" puis un apt-get update / upgrade pour être sûr que les drivers soient bien installés

hatoupix
Messages : 11
Enregistré le : ven. 7 oct. 2016 14:25

Re: pb de wifi ...

Message par hatoupix » mer. 26 oct. 2016 19:53

oups ... j'ai oublié de préciser sur ce forum que j'avais trouvé la solution : mon ancien accès était avec une clef WEP ... depuis j'ai mis en WAP et là au miracle ca marche !!!

Répondre

Retourner vers « Le réseau sur le Raspberry Pï »