Impossible de monter l'interface reseau wifi (wlan0)

Paramétrer le Raspberry Pi B/B+ pour se connecter via Ethernet ou une clé WiFi USB

Modérateurs : Francois, maxty01

Avatar du membre
marco123
Raspinaute
Messages : 423
Enregistré le : sam. 30 janv. 2016 07:59
Localisation : Val d'Oise

Re: Impossible de monter l'interface reseau wifi (wlan0)

Message par marco123 » mer. 8 févr. 2017 11:59

tu peux essayer un etc/network/interfaces simple .

voici le mien sur pi3:
auto lo
iface lo inet loopback
auto wlan0
allow-hotplug wlan0
iface wlan0 inet dhcp
wpa-ssid "mon-ssid"
wpa-psk "mon_mot_de_passe"

Shaaken
Messages : 14
Enregistré le : jeu. 2 févr. 2017 14:30

Re: Impossible de monter l'interface reseau wifi (wlan0)

Message par Shaaken » mer. 8 févr. 2017 21:11

Merci pour l'idée

Et en fait il y a eu une étrange réaction :
je configure le fichier et reboot

et la je vois l'interface wlan0 (mais sans ip)

tout content je ne touche a rien et pour voir si au moins c'est stable, je reboot

...et elle disparait à nouveau . :evil:

on dirait bien un truc aléatoire ...du coup ça penche quand même bien pour un pxb de hardware.

manau
Raspinaute
Messages : 136
Enregistré le : ven. 4 mars 2016 20:53
Localisation : Seine Maritime

Re: Impossible de monter l'interface reseau wifi (wlan0)

Message par manau » mer. 8 févr. 2017 22:42

Pour certaines personnes, la connexion wifi ne se fait pas à cause d'un problème de canal. Pour régler ça, il faut aller dans les paramètres de la box et en tester d'autres. ça arrive à certaines marques de pc; la box est inexistante.

il faudrait que tu essayes quelque choses, pour la première installation tu l'as installé en Ethernet donc les paramètres ont été paramétré par défaut dans le fichier "/etc/network/interfaces". il faudrait recommencer l'installation, mais cette fois-ci en wifi, comme ça tous les paramètres qui ont été par défaut ou modifié, qui peuvent éventuellement faire conflits seront effacés. Normalement, si le wifi fonctionne, il y aura juste besoin de modifier le fichier wpa_supplicant.conf dans "/etc/wpa_supplicant/wpa_supplicant.conf" pour rajouter les lignes :

Code : Tout sélectionner

network={
    ssid="nomDeLaBox"
    psk="cléDeSécurité"
    key_mgmt=WPA-PSK
}

Manau

Shaaken
Messages : 14
Enregistré le : jeu. 2 févr. 2017 14:30

Re: Impossible de monter l'interface reseau wifi (wlan0)

Message par Shaaken » jeu. 9 févr. 2017 12:59

ok
je tente ça ce soir en repartant directement de ma carte SD remise à zero depuis la dernière raspian pour voir
en me connectant sans reseau au depart, je ferai juste une modif du wpa _supplicant puis reboot
merci

manau
Raspinaute
Messages : 136
Enregistré le : ven. 4 mars 2016 20:53
Localisation : Seine Maritime

Re: Impossible de monter l'interface reseau wifi (wlan0)

Message par manau » jeu. 9 févr. 2017 15:00

ok
pour avoir plus de facilité dans la configuration de raspbian et des paramètres wifi il y a les version Noobs ou Noobs lite qui propose tout au début de l'installation de choisir sous quel réseau wifi se connecter, et ensuite ça propose plusieurs OS pour l'installation. le défaut, c'est que les versions Noobs demande plus de place que les version raspbian installé seul sur carte SD.
si c'est un problème matériel, de toute façon ça ne fonctionnera pas mais si c'est un problème de réglage (de la RPI ou de box), alors ça peut t'aider à voir si tu détectes au moins les box aux alentours.

Manau

Shaaken
Messages : 14
Enregistré le : jeu. 2 févr. 2017 14:30

Re: Impossible de monter l'interface reseau wifi (wlan0)

Message par Shaaken » jeu. 9 févr. 2017 22:13

Bon j'ai pu faire un autre essai.

Un ami m'a prèté un autre rpi3 et j'y ai juste inséré ma carte sd avec mes confs wifi de bas (wpa_supplicant de départ).
Et le wifi fonctionne bien directement.
je repasse sur mon rpi3 et ça ne marche pas.
j ai un pb sur ma carte.
il semble bien possible au vu des pb identiques sur certains forums qu'une série soit défectueuse.

Pour le fun je vais quand même essayer noobs demain.au cas ou cela soit aussi des pb de drivers ou autre.

Merci pour l'aide apportée.

episol
Messages : 4
Enregistré le : lun. 15 févr. 2016 14:48
Localisation : Honfleur

Re: Impossible de monter l'interface reseau wifi (wlan0)

Message par episol » dim. 2 juil. 2017 23:23

bonsoir
tapez en ligne de commande : lsmod
et vous verrez que rfkill bloque bluetooth , cfg80211
j'ai ce pb depuis que je suis passé de jessie a stretch
j'ai killer rfkill mais rien n'y fait .....

personne n'en parles BIZARRE

au plaisir de vous lire

Répondre

Retourner vers « Le réseau sur le Raspberry Pï »