Impression depuis l'extérieur avec OpenVPN  [RESOLU]

Paramétrer le Raspberry Pi B/B+ pour se connecter via Ethernet ou une clé WiFi USB

Modérateurs : Francois, maxty01

patsherbrooke
Messages : 11
Enregistré le : lun. 17 avr. 2017 15:18

Impression depuis l'extérieur avec OpenVPN

Message par patsherbrooke » lun. 17 avr. 2017 15:25

Bonjour !
J'ai un rpì3 sous Raspbian avec OpenVPN installé.
Je voudrais utiliser mon imprimante wifi locale depuis l'extérieur via mon VPN.
Quelqu'un pourrai-t-il m'indiquer la procédure à suivre ?
Golum a fait un post à ce sujet mais il a utilisé une solution ne passant pas par le VPN...
Remarque : j'arrive à faire un ping sur mon imprimante depuis mon RPI3.
Merci pour vos réponses !

maxty01
Modérateur
Messages : 738
Enregistré le : dim. 16 nov. 2014 20:53
Localisation : Charleroi - Belgique

Re: Impression depuis l'extérieur avec OpenVPN

Message par maxty01 » lun. 17 avr. 2017 16:11

Bonjour,

Afin d'adapter au mieux la réponse, est-il possible de nous quels sont vos connaissance en informatique et plus particulièrement en réseaux.

Je demande cela car ce que vous souhaitez faire requiers quelques notions importantes.

Est-il également possible de détailler votre projet et les outils que vous possédez.

Bien à vous,
Il n'y a pas de question stupide, il n'y a que des imbéciles qui ne posent pas de question !
RaspBerry Pi : 1 x B+ Raspbian 1 x RPI2 MiniBian
Mieux me connaître ? Regarder mon LinkedIn

patsherbrooke
Messages : 11
Enregistré le : lun. 17 avr. 2017 15:18

Re: Impression depuis l'extérieur avec OpenVPN

Message par patsherbrooke » lun. 17 avr. 2017 16:49

Bonjour,
J'ai été développeur client-serveur et mes connaissances en réseaux sont élémentaires. Je sais, il faudrait vraiment que je m'y mette une bonne fois pour toute :D
j'ai installé mon VPN pour accéder à mon DD externe local (branché sur mon RPI3 + install de Openmediavault) et cela fonctionne bien.
Mon but maintenant est de pouvoir imprimer un document de n'importe où grâce au VPN que j'ai installé sur mon RPI3 local.
Comme je l'ai mentionné, la solution de Golum fonctionne mais j'en souhaite une qui passe par le VPN et que je pourrai étendre à n'importe quel périphérique à l'avenir.
J'ai vu sur quelques forums que l'on peut installer un serveur d'impression sur le RPI comme 'CUPS' mais je me demandais s'il y avait une solution plus 'simple'...

maxty01
Modérateur
Messages : 738
Enregistré le : dim. 16 nov. 2014 20:53
Localisation : Charleroi - Belgique

Re: Impression depuis l'extérieur avec OpenVPN

Message par maxty01 » lun. 17 avr. 2017 17:01

Bonjour,

D'après ce que je lis, j'en déduis que c'est une imprimante réseau.
L'OpenVPN est déjà installé sur le raspberry.

En fait, il ne manque plus que l'accès au réseau local, ce qui se fait via la configuration de l'OpenVPN.

afin d'avoir une idée plus précise de la situation :

Est-il possible (EN OFFUSQUANT LES DONNÉES DE SÉCURITÉ !!!) d'avoir la configuration du VPN ?

Est-il possible d'en savoir plus le router/box qui relie le réseau local à internet ?

Bien à vous,
Il n'y a pas de question stupide, il n'y a que des imbéciles qui ne posent pas de question !
RaspBerry Pi : 1 x B+ Raspbian 1 x RPI2 MiniBian
Mieux me connaître ? Regarder mon LinkedIn

patsherbrooke
Messages : 11
Enregistré le : lun. 17 avr. 2017 15:18

Re: Impression depuis l'extérieur avec OpenVPN

Message par patsherbrooke » lun. 17 avr. 2017 18:36

Oui, c'est une imprimante réseau et l'OpenVPN est sur le RPI3.
Que veux-tu avoir sur la configuration de l'OpenVPN ?

Les infos de id addr donnent :
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
link/ether b8:27:eb:8c:30:c2 brd ff:ff:ff:ff:ff:ff
inet 192.168.50.244/24 brd 192.168.50.255 scope global eth0
valid_lft forever preferred_lft forever
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
link/ether b8:27:eb:d9:65:97 brd ff:ff:ff:ff:ff:ff
4: tun0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 100
link/none
inet 10.8.0.1/24 brd 10.8.0.255 scope global tun0
valid_lft forever preferred_lft forever

Le log de connexion est :
Mon Apr 17 12:31:11 2017 OpenVPN 2.4.1 x86_64-w64-mingw32 [SSL (OpenSSL)] [LZO] [LZ4] [PKCS11] [AEAD] built on Mar 22 2017
Mon Apr 17 12:31:11 2017 Windows version 6.1 (Windows 7) 64bit
Mon Apr 17 12:31:11 2017 library versions: OpenSSL 1.0.2k 26 Jan 2017, LZO 2.09
Enter Management Password:
Mon Apr 17 12:31:11 2017 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
Mon Apr 17 12:31:11 2017 TCP/UDP: Preserving recently used remote address: [AF_INET]XXX.XXX.XXX.XXX:11948
Mon Apr 17 12:31:11 2017 UDP link local: (not bound)
Mon Apr 17 12:31:11 2017 UDP link remote: [AF_INET]XXX.XXX.XXX.XXX:11948
Mon Apr 17 12:31:12 2017 [server] Peer Connection Initiated with [AF_INET]XXX.XXX.XXX.XXX:11948
Mon Apr 17 12:31:13 2017 open_tun
Mon Apr 17 12:31:13 2017 TAP-WIN32 device [Connexion au réseau local] opened: \\.\Global\{9D233730-585B-4921-A991-3E8D0D49B3DE}.tap
Mon Apr 17 12:31:13 2017 Set TAP-Windows TUN subnet mode network/local/netmask = 10.8.0.0/10.8.0.2/255.255.255.0 [SUCCEEDED]
Mon Apr 17 12:31:13 2017 Notified TAP-Windows driver to set a DHCP IP/netmask of 10.8.0.2/255.255.255.0 on interface {9D233730-585B-4921-A991-3E8D0D49B3DE} [DHCP-serv: 10.8.0.254, lease-time: 31536000]
Mon Apr 17 12:31:13 2017 Successful ARP Flush on interface [25] {9D233730-585B-4921-A991-3E8D0D49B3DE}
Mon Apr 17 12:31:13 2017 do_ifconfig, tt->did_ifconfig_ipv6_setup=0
Mon Apr 17 12:31:18 2017 Initialization Sequence Completed


Le modem est celui de mon FAI. Un routeur y est connecté. Que veux-tu savoir sur cette config ?
A noter que sur mon routeur j'ai redirigé le port 11948 vers l'IP de mon RPI3 (192.168.50.244)...

maxty01
Modérateur
Messages : 738
Enregistré le : dim. 16 nov. 2014 20:53
Localisation : Charleroi - Belgique

Re: Impression depuis l'extérieur avec OpenVPN

Message par maxty01 » lun. 17 avr. 2017 18:48

Bonsoir,
patsherbrooke a écrit :Oui, c'est une imprimante réseau et l'OpenVPN est sur le RPI3.
Que veux-tu avoir sur la configuration de l'OpenVPN ?
Je veux savoir quelles sont les configurations à ajouter ou à modifier.
patsherbrooke a écrit :Le modem est celui de mon FAI. Un routeur y est connecté. Que veux-tu savoir sur cette config ?
A noter que sur mon routeur j'ai redirigé le port 11948 vers l'IP de mon RPI3 (192.168.50.244)...
Peux-tu me donner la marque et le modèle. Je veux savoir s'il est capable de gérer du routage.

Bonne soirée,
Il n'y a pas de question stupide, il n'y a que des imbéciles qui ne posent pas de question !
RaspBerry Pi : 1 x B+ Raspbian 1 x RPI2 MiniBian
Mieux me connaître ? Regarder mon LinkedIn

patsherbrooke
Messages : 11
Enregistré le : lun. 17 avr. 2017 15:18

Re: Impression depuis l'extérieur avec OpenVPN

Message par patsherbrooke » lun. 17 avr. 2017 18:52

Bonsoir,
Quel fichier ou résultat de commande veux-tu que je te transmette ?
Mon routeur est un ASUS RTN600.

maxty01
Modérateur
Messages : 738
Enregistré le : dim. 16 nov. 2014 20:53
Localisation : Charleroi - Belgique

Re: Impression depuis l'extérieur avec OpenVPN

Message par maxty01 » lun. 17 avr. 2017 19:00

Bonsoir,

Première bonne nouvelle, si c'est le bon routeur, il est capable de faire du routage ( page 48 - en Anglais) :
http://dlcdnet.asus.com/pub/ASUS/wirele ... Manual.pdf

Concernant OpenVPN, je souhaiterai avec le fichier de configuration.
Probablement à cet emplacement : /etc/openvpn/server.conf

Bonne soirée,
Il n'y a pas de question stupide, il n'y a que des imbéciles qui ne posent pas de question !
RaspBerry Pi : 1 x B+ Raspbian 1 x RPI2 MiniBian
Mieux me connaître ? Regarder mon LinkedIn

patsherbrooke
Messages : 11
Enregistré le : lun. 17 avr. 2017 15:18

Re: Impression depuis l'extérieur avec OpenVPN

Message par patsherbrooke » lun. 17 avr. 2017 19:06

Bonjour !

Voici le contenu du fichier /etc/openvpn/server.conf :

dev tun
proto udp
port 11948
ca /etc/openvpn/easy-rsa/pki/ca.crt
cert /etc/openvpn/easy-rsa/pki/issued/server.crt
key /etc/openvpn/easy-rsa/pki/private/server.key
dh /etc/openvpn/easy-rsa/pki/dh2048.pem
topology subnet
server 10.8.0.0 255.255.255.0
# server and remote endpoints
ifconfig 10.8.0.1 10.8.0.2
# Add route to Client routing table for the OpenVPN Server
push "route 10.8.0.1 255.255.255.255"
# Add route to Client routing table for the OPenVPN Subnet
push "route 10.8.0.0 255.255.255.0"
# your local subnet
push "route 192.168.50.0 255.255.255.0"
# Set your primary domain name server address for clients
push "dhcp-option DNS 8.8.8.8"
push "dhcp-option DNS 8.8.4.4"
# Override the Client default gateway by using 0.0.0.0/1 and
# 128.0.0.0/1 rather than 0.0.0.0/0. This has the benefit of
# overriding but not wiping out the original default gateway.
push "redirect-gateway def1"
client-to-client
duplicate-cn
keepalive 10 120
tls-version-min 1.2
tls-auth /etc/openvpn/easy-rsa/pki/ta.key 0
cipher AES-256-CBC
auth SHA256
comp-lzo
user nobody
group nogroup
persist-key
persist-tun
#crl-verify /etc/openvpn/crl.pem
status /var/log/openvpn-status.log 20
status-version 3
log /var/log/openvpn.log
verb 1
# Generated for use by PiVPN.io

En tout cas, merci bcp pour passer du temps sur mon pb...

maxty01
Modérateur
Messages : 738
Enregistré le : dim. 16 nov. 2014 20:53
Localisation : Charleroi - Belgique

Re: Impression depuis l'extérieur avec OpenVPN

Message par maxty01 » mar. 18 avr. 2017 00:41

Bonsoir,

Ton Ovpn pousse bien la route de ton réseau ... donc rien à ajouter ou modifier.

Maintenant, il faut signaler à ton routeur la route de ton réseau VPN (10.8.0.0 255.255.255.0).
Tu dois créer une route sur ton VPN en lui disant de passer par ton raspberry, cela doit ressembler à ceci :
Network: 10.8.0.0/24 - Gateway 192.168.50.244

Dernier point, tu dois activer le routage en ipv4 sur ton rapsberry :
Dans le fichier : /etc/sysctl.conf
Décommente la ligne : net.ipv4.ip_forward=1
Redémarre ton RPI.

Pour finir, vérifie que ton imprimante à comme passerelle par défaut (default gateway) ton routeur.

Bonne soi... nuit !
Bonne nuit,
Il n'y a pas de question stupide, il n'y a que des imbéciles qui ne posent pas de question !
RaspBerry Pi : 1 x B+ Raspbian 1 x RPI2 MiniBian
Mieux me connaître ? Regarder mon LinkedIn

Répondre

Retourner vers « Le réseau sur le Raspberry Pï »