wifi ok mais pas de connexion internet  [RESOLU]

Paramétrer le Raspberry Pi B/B+ pour se connecter via Ethernet ou une clé WiFi USB

Modérateurs : Francois, maxty01

LYSANDRE
Messages : 4
Enregistré le : sam. 6 mai 2017 13:15

wifi ok mais pas de connexion internet

Message par LYSANDRE » sam. 6 mai 2017 13:23

Bonjour,

je viens de faire l'acquisition d'un raspberry pi 3.
Le wifi fonctionne sur ma freebox et sur mon portable avec le mode partagé mais impossible de naviguer sur internet avec chromium ou epiphany.

Tout me parait ok mais pourtant ça ne fonctionne pas !
Est-ce un problème matériel ou doit-on faire une manip spécial ?

je suis sur raspbian dernière version

Merci d'avance pour votre aide.

maxty01
Modérateur
Messages : 740
Enregistré le : dim. 16 nov. 2014 20:53
Localisation : Charleroi - Belgique

Re: wifi ok mais pas de connexion internet

Message par maxty01 » sam. 6 mai 2017 22:22

Bonsoir,

Est-il possible de connaître l'adresse IP de votre routeur ainsi que la sortie de ces 3 commandes : «ip addr show», «ip route list» et «cat /etc/resolv.conf»

Bonne soirée,
Il n'y a pas de question stupide, il n'y a que des imbéciles qui ne posent pas de question !
RaspBerry Pi : 1 x B+ Raspbian 1 x RPI2 MiniBian
Mieux me connaître ? Regarder mon LinkedIn

LYSANDRE
Messages : 4
Enregistré le : sam. 6 mai 2017 13:15

Re: wifi ok mais pas de connexion internet

Message par LYSANDRE » dim. 7 mai 2017 22:00

Voici l'adresse IP de mon routeur : 192.168.0.254

Résultat pour la commande «ip addr show» :

Code : Tout sélectionner

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether b8:27:eb:7e:ca:9a brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether b8:27:eb:2b:9f:cf brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.20/24 brd 192.168.0.255 scope global wlan0
       valid_lft forever preferred_lft forever
    inet6 fe80::7f0b:1678:fa54:d093/64 scope link 
       valid_lft forever preferred_lft forever
ip route list

Code : Tout sélectionner

192.168.0.0/24 dev eth0  proto kernel  scope link  src 192.168.0.20  metric 202 
192.168.0.0/24 dev wlan0  proto kernel  scope link  src 192.168.0.20  metric 303 
cat /etc/resolv.conf

Code : Tout sélectionner

# Generated by resolvconf
# Generated by resolvconf
J'ai branché le raspberry pi directement avec un câble.
J'ai le même problème..

maxty01
Modérateur
Messages : 740
Enregistré le : dim. 16 nov. 2014 20:53
Localisation : Charleroi - Belgique

Re: wifi ok mais pas de connexion internet

Message par maxty01 » dim. 7 mai 2017 23:33

Bonsoir,

Il semblerai que tu ai configuré manuellement ta cartes réseau.

Pour avoir accès à internet, il faut impérativement 4 éléments :
1. L'adresse IP.
2. Le masque sous réseau.
3. La passerelle par défaut, autrement dis, ton routeur.
4. Au moins un serveur DNS, le mieux est de mettre ton routeur.

Il te manque les éléments 3 & 4.

Je te laisse regarder de ton coté comment faire.

Bien évidement, si tu éprouves quelques difficultés, n'hésite pas à demander.

Bonne soirée,
Il n'y a pas de question stupide, il n'y a que des imbéciles qui ne posent pas de question !
RaspBerry Pi : 1 x B+ Raspbian 1 x RPI2 MiniBian
Mieux me connaître ? Regarder mon LinkedIn

spourre
Raspinaute
Messages : 735
Enregistré le : lun. 22 déc. 2014 16:50
Localisation : 67380 LINGOLSHEIM

Re: wifi ok mais pas de connexion internet

Message par spourre » dim. 7 mai 2017 23:55

Bonsoir,

AMHA, on ne dira jamais assez que, sauf cas particulier, il est préférable d'opter pour le DHCP.
Si on a besoin d'une @IP fixe (redirection de ports par exemple), on peut choisir un bail infini ou lier l'@IP à la MAC de la carte. A ma connaissance, toutes les box (et routeurs) le permettent (en général dans leur page web de paramétrage)..

Sylvain

maxty01
Modérateur
Messages : 740
Enregistré le : dim. 16 nov. 2014 20:53
Localisation : Charleroi - Belgique

Re: wifi ok mais pas de connexion internet

Message par maxty01 » lun. 8 mai 2017 00:00

Bonsoir,
spourre a écrit :Bonsoir,

AMHA, on ne dira jamais assez que, sauf cas particulier, il est préférable d'opter pour le DHCP.
Si on a besoin d'une @IP fixe (redirection de ports par exemple), on peut choisir un bail infini ou lier l'@IP à la MAC de la carte. A ma connaissance, toutes les box (et routeurs) le permettent (en général dans leur page web de paramétrage)..

Sylvain
Je suis assez d'accord avec ce que tu dis, sauf dans un cas particulier : Quand un RPI est lui même un serveur DHCP, ce qui est mon cas.

Bonne soirée,
Il n'y a pas de question stupide, il n'y a que des imbéciles qui ne posent pas de question !
RaspBerry Pi : 1 x B+ Raspbian 1 x RPI2 MiniBian
Mieux me connaître ? Regarder mon LinkedIn

LYSANDRE
Messages : 4
Enregistré le : sam. 6 mai 2017 13:15

Re: wifi ok mais pas de connexion internet

Message par LYSANDRE » lun. 8 mai 2017 12:05

maxty01 a écrit :Bonsoir,

Il semblerai que tu ai configuré manuellement ta cartes réseau.

Pour avoir accès à internet, il faut impérativement 4 éléments :
1. L'adresse IP.
2. Le masque sous réseau.
3. La passerelle par défaut, autrement dis, ton routeur.
4. Au moins un serveur DNS, le mieux est de mettre ton routeur.

Il te manque les éléments 3 & 4.

Je te laisse regarder de ton coté comment faire.

Bien évidement, si tu éprouves quelques difficultés, n'hésite pas à demander.

Bonne soirée,
Hummm je suis loin de maîtriser les réseaux
Ou dois-je inscrire les éléments ci-dessous ?
J ai installé Ubuntu Mate est mon réseau fonctionne parfaitement
Dois-je comparer les fichiers de configuration réseau entre les 2 systèmes​ pour trouver l erreur ?

spourre
Raspinaute
Messages : 735
Enregistré le : lun. 22 déc. 2014 16:50
Localisation : 67380 LINGOLSHEIM

Re: wifi ok mais pas de connexion internet  [RESOLU]

Message par spourre » lun. 8 mai 2017 14:22

maxty01 a écrit : Je suis assez d'accord avec ce que tu dis, sauf dans un cas particulier : Quand un RPI est lui même un serveur DHCP, ce qui est mon cas.
...
,
C'est pour ouvrir ce genre de cas particulier (ou WIFI ad hoc par exemple) que j'ai laissé une petite ouverture.
Dans 99 % des cas, surtout sans connaissances réseaux,, le DHCP est la voie royale (et il pousse tous ces éléments).
une petite discussion sur notre site à nous qu'on aime:
http://www.framboise314.fr/allouer-une- ... raspberry/
Sylvain

PS) merci à l'équipe des admins et des modos (pas féroces) :)

domi
Administrateur
Messages : 2853
Enregistré le : mer. 17 sept. 2014 18:12
Localisation : Seine et Marne

Re: wifi ok mais pas de connexion internet

Message par domi » lun. 8 mai 2017 16:26

spourre a écrit :PS) merci à l'équipe des admins et des modos (pas féroces) :)
De rien mais pourquoi ? ;-)
Passionné de Raspberry, Arduino, ESP8266, ESP32, et objets connectés :
Spécial débutant, concevez vous-même votre domotique DIY : https://www.youtube.com/c/DomoticDIY

spourre
Raspinaute
Messages : 735
Enregistré le : lun. 22 déc. 2014 16:50
Localisation : 67380 LINGOLSHEIM

Re: wifi ok mais pas de connexion internet

Message par spourre » lun. 8 mai 2017 16:53

domi a écrit :
spourre a écrit :PS) merci à l'équipe des admins et des modos (pas féroces) :)
De rien mais pourquoi ? ;-)
Pour leur boulot en coulisses. Souvent peu perçu par les utilisateurs, mais indispensable à la bonne marche du forum.

Sylvain
Message Modérateur :
C'est vrai, pour ma part, en tant qu'admin je ne fais que superviser, mais merci aux modérateurs qui font vivre les forums, et ce fil de discussion en est a nouveau la preuve.
Je répond dans ton message afin de ne pas dériver le sujet initial
- domi

Répondre

Retourner vers « Le réseau sur le Raspberry Pï »