Blocage intempestif SSH et Freebox

Paramétrer le Raspberry Pi B/B+ pour se connecter via Ethernet ou une clé WiFi USB

Modérateurs : Francois, maxty01

Répondre
Arnaudduluoz
Messages : 9
Enregistré le : lun. 4 avr. 2016 15:56

Blocage intempestif SSH et Freebox

Message par Arnaudduluoz » dim. 4 juin 2017 14:28

Bonjour à tous,
Depuis maintenant un an, je fais tourner un serveur web+mail+cloud sur mon raspberry Pi 2 et j'en suis très heureux.
Depuis quelques jours cependant, un problème se présente que je ne comprends pas : si je redémarre mon raspberry, la connection SSH devient impossible :

Mac-mini-de-A:~ A$ ssh arnaud@192.168.0.50 -p 1986
ssh: connect to host 192.168.0.50 port 1986: Connection refused
Mac-mini-de-A:~ A$ ssh arnaud@192.168.0.50 -p 1986
ssh: connect to host 192.168.0.50 port 1986: Connection refused
Mac-mini-de-A:~ A$ ssh arnaud@192.168.0.50 -p 1986
ssh: connect to host 192.168.0.50 port 1986: Connection refused
Mac-mini-de-A:~ A$ ssh arnaud@192.168.0.50 -p 1986
ssh: connect to host 192.168.0.50 port 1986: Connection refused
Mac-mini-de-A:~ A$ ssh arnaud@192.168.0.50 -p 1986
ssh: connect to host 192.168.0.50 port 1986: Connection refused

Parfois le message est "Host is down".
En réalité le raspberry démarre bien (il tourne sur Raspbian), et le seul moyen que j'aie trouvé pour résoudre le problème est de débrancher puis rebrancher la Freebox sur laquelle il tourne : après redémarrage ou redémarrage des deux en même temps, SSH repart sans souci.
Auriez-vous une idée ?
Merci par avance,
Arnaud

maxty01
Modérateur
Messages : 738
Enregistré le : dim. 16 nov. 2014 20:53
Localisation : Charleroi - Belgique

Re: Blocage intempestif SSH et Freebox

Message par maxty01 » dim. 4 juin 2017 21:51

Bonsoir,

Est-il possible d'avoir les log contenu dans le fichier /var/log/syslog ?

Bonne soirée,
Il n'y a pas de question stupide, il n'y a que des imbéciles qui ne posent pas de question !
RaspBerry Pi : 1 x B+ Raspbian 1 x RPI2 MiniBian
Mieux me connaître ? Regarder mon LinkedIn

Arnaudduluoz
Messages : 9
Enregistré le : lun. 4 avr. 2016 15:56

Re: Blocage intempestif SSH et Freebox

Message par Arnaudduluoz » dim. 4 juin 2017 22:21

Bonsoir,

Voici les logs. Pour info, j'ai coupé mon RPI (sudo reboot now) à 22h05. A 22h07 toujours aucune connexion SH possible. Serveur mail, web et cloud inaccessibles. A 22h08, je débranche Freebox et RPI et rebranche tout ce petit monde : ça repart.

Je joins aussi un autre extrait du même syslog mais avec | grep dhcp.

Je pédale sévèrement là-dessus et n'y comprends rien : l'adresse IP fixe (192.168.0.50) est attribuée à l'adresse mac du raspberry dans les paramètres freebox. Le fichier interfaces est quant à lui paramétré ainsi :

Code : Tout sélectionner

sudo nano /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

iface eth0 inet manual

allow-hotplug wlan0
iface wlan0 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

allow-hotplug wlan1
iface wlan1 inet manual

[b]iface eth0 inet manual[/b]

allow-hotplug wlan0
iface wlan0 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

allow-hotplug wlan1
iface wlan1 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

Merci d'avance pour votre aide...
Fichiers joints
syslog.txt
(98.07 Kio) Téléchargé 33 fois
logsgrepdhcp.txt
(12.15 Kio) Téléchargé 30 fois

maxty01
Modérateur
Messages : 738
Enregistré le : dim. 16 nov. 2014 20:53
Localisation : Charleroi - Belgique

Re: Blocage intempestif SSH et Freebox

Message par maxty01 » lun. 5 juin 2017 00:06

Bonsoir,

Mon constat :
Il y a un creux dans les logs entre 21:18:11 et 22:09:07 ...
Il y a aussi des incohérences dans les heures ... ils passent de 22:05:38 à 21:17:04 à la ligne suivante (sans information d'une possible correction du NTP).

Le premier point à tester est l'alimentation :
Si j'ai bien compris, c'est ta freebox qui alimente ton RPI, le premier test est de passer par une autre alimentation.

Second point, le réseau :
De ce que je peux voir, tes interfaces sont notées en "manual", ce qui veux dire qu'elles sont gérées par un autre programme (ex: NetworkManager).
S'il n'y a aucune raison spécifique pour le mode "manual", je te conseil de faire un configuration "static" dans le fichier /etc/network/interfaces pour au moins l'interface ETH0.

Dernièr point qui relie les deux premiers :
Sur base de ton fichier /etc/network/interfaces, tu utilises, si c'est toujours le cas, 2 interfaces WLAN complémentaire, sans doute en USB.
Si elles ne sont pas sur un HUB USB alimenté et n'ont pas de raison spécifiques d'être là, je te conseil de les retirer physiquement du RPI.
Une carte Wifi consomme pas mal de courant, cela peux expliquer certaines choses.

Last but not least :
Vérifie que ta carte SD n'est pas en train de souffrir voir de mourir ...
Il serait peut-être temps de la remplacer si cela n'a pas déjà été fait, mais après les 3 premiers tests.
Et si elle a déjà été remplacée, peut-être que la nouvelle carte SD est défectueuse.

Bonne soirée,
Il n'y a pas de question stupide, il n'y a que des imbéciles qui ne posent pas de question !
RaspBerry Pi : 1 x B+ Raspbian 1 x RPI2 MiniBian
Mieux me connaître ? Regarder mon LinkedIn

Arnaudduluoz
Messages : 9
Enregistré le : lun. 4 avr. 2016 15:56

Re: Blocage intempestif SSH et Freebox

Message par Arnaudduluoz » lun. 5 juin 2017 10:19

Bonjour,

Merci beaucoup pour ta réponse. J'ai aussi noté ces décalages d'heure et me demandais si cela n'était pas dû aux redémarrages et aux extinctions forcées.

Pour l'alimentation : j'utilise l'alimentation officielle Raspberry qui fonctionne plutôt bien jusqu'ici. J'ai fait un test avec une autre alim dont je dispose pour un autre projet raspberry et cela ne change malheureusement rien.

Pour le réseau : je n'ai jamais utilisé d'interface wlan sur ce raspberry et suis surpris qu'elles y figurent. Je croyais que c'était inscrit d'office. Je vais donc essayer de mettre le code suivant pour eht0 :

Code : Tout sélectionner

iface eth0 inet static
    address 192.168.0.50
    netmask 255.255.255.0
    network 192.168.0.254
    broadcast 192.168.1.255
    gateway 192.168.1.1
Est-ce que cela ne posera pas de souci avec le fait que la freebox est déjà paramétrée pour attribuer l'ip ?

Quant aux wlan, je peux tout simplement les enlever du fichier ?

J'avais aussi craint un problème de carte et avais donc fait un clone de la carte que j'ai installé. La carte est donc neuve mais le problème est malheureusement toujours là.

Est-il possible, au regard des logs dhcp, que cela vienne de la Freebox qui pour une raison ou une autre, aie du mal à attribuer l'adresse ip ?

Merci encore pour ces conseils.

Bonne journée,

maxty01
Modérateur
Messages : 738
Enregistré le : dim. 16 nov. 2014 20:53
Localisation : Charleroi - Belgique

Re: Blocage intempestif SSH et Freebox

Message par maxty01 » lun. 5 juin 2017 10:54

Bonjour,

Pour la configuration de la carte réseau, c'est parfait !

Il faut juste faire attention à bien configurer la partie DNS en modifiant le fichier /etc/resolv.conf.

Si le fichier de DNS est géré par "resolvconf", il faut configurer l'option "dns-nameservers" dans le fichier /etc/network/interfaces :

Code : Tout sélectionner

dns-nameservers a.a.a.a b.b.b.b
Tu peux mettre "dns-nameservers" après "gateway" dans ton fichier.
a.a.a.a et b.b.b.b sont les adresses IP de deux serveurs DNS, tu peux en mettre une ou plusieurs.

Pour la réservation DHCP : Non il n'y a pas de risque, au contraire, c'est mieux :
Tu peux être certain que l'adresse ne sera plus distribuée et utilisée par un autre périphérique sur ton réseau.

Tu peux enlever la configuration des interfaces WLANx, si elle n'a plus d’intérêt.

Je pense que la Freebox n'est pas étrangère au problème, mais rien pour le confirmer.

Bonne journée,
Il n'y a pas de question stupide, il n'y a que des imbéciles qui ne posent pas de question !
RaspBerry Pi : 1 x B+ Raspbian 1 x RPI2 MiniBian
Mieux me connaître ? Regarder mon LinkedIn

Arnaudduluoz
Messages : 9
Enregistré le : lun. 4 avr. 2016 15:56

Re: Blocage intempestif SSH et Freebox

Message par Arnaudduluoz » lun. 5 juin 2017 16:59

Merci beaucoup pour ta réponse. J'ai donc modifié mon /etc/network/interfaces comme suit :

Code : Tout sélectionner

# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

iface eth0 inet static
  address 192.168.0.50
  netmask 255.255.255.0
  broadcast 192.168.1.255
  gateway dns-nameservers

dns-nameservers 212.27.40.240 212.27.40.241
C'est bien correct ?

Après redémarrage, le problème persiste malheureusement.

Hier, alors qu'après un énième redémarrage je constatais que le réseau ne s'établissait pas et poursuivais mes recherches sur internet, le réseau s'est établi 20mn après, comme si finalement le bail avait pu être établi. C'est à n'y rien comprendre mais je soupçonne fortement la Freebox. Je lui aurais bien appliqué un reset mais il n'y en a semble-t-il pas sur ce modèle...

Merci encore pour ton aide,

maxty01
Modérateur
Messages : 738
Enregistré le : dim. 16 nov. 2014 20:53
Localisation : Charleroi - Belgique

Re: Blocage intempestif SSH et Freebox

Message par maxty01 » mar. 6 juin 2017 00:04

Bonsoir,

Deux petites corrections dans le fichier :

La première : met la partie "auto eth0" avant "iface eth0 ..." comme le "auto lo".
La seconde : met le "dns-nameservers" au même niveau que gateway.

Une dernière question, est-ce que ton RPI ne serait pas fatigué tout simplement ...
Si tu as la possibilité de tester un autre RPI pour confirmer ...

Bonne soirée,
Bonne nuit,
Il n'y a pas de question stupide, il n'y a que des imbéciles qui ne posent pas de question !
RaspBerry Pi : 1 x B+ Raspbian 1 x RPI2 MiniBian
Mieux me connaître ? Regarder mon LinkedIn

destroyedlolo
Raspinaute
Messages : 1388
Enregistré le : dim. 10 mai 2015 18:44
Localisation : Dans la campagne à côté d'Annecy
Contact :

Re: Blocage intempestif SSH et Freebox

Message par destroyedlolo » mar. 6 juin 2017 11:09

Salut,

As tu un cable "console" sur ton PI ? Il serait interessant de s'y connecter pour voir quel est son état lorsqu'il a perdu le réseau.

Cordialement

Laurent
  • BananaPI : Gentoo, disque SATA de 2 To
  • Domotique : 1-wire, TéléInfo, Tablette passée sous Gentoo, ESP8266
  • Multimedia par DNLA
  • Et pleins d'idées ... et bien sûr, pas assez de temps.
Un descriptif de ma domotique 100% fait maison.

Arnaudduluoz
Messages : 9
Enregistré le : lun. 4 avr. 2016 15:56

Re: Blocage intempestif SSH et Freebox

Message par Arnaudduluoz » mer. 7 juin 2017 22:16

Merci maxty01, c'est corrigé !

Destroyedlolo, je n'ai malheureusement pas ce type de câble mais j'ai jeté un oeil en branchant un écran et un clavier : tout est en ordre, la console s'affiche correctement et tout le reste a l'air de fonctionner sans mal. Je penche pour un problème logiciel quelconque à la suite d'une MAJ de la box, car là je ne vois pas d'où peut venir le souci.

Répondre

Retourner vers « Le réseau sur le Raspberry Pï »