Pas de connection en wifi si le cable RJ45 est déconnecté

Paramétrer le Raspberry Pi B/B+ pour se connecter via Ethernet ou une clé WiFi USB

Modérateurs : Francois, maxty01

Répondre
gillespenot
Messages : 2
Enregistré le : dim. 29 avr. 2018 22:41

Pas de connection en wifi si le cable RJ45 est déconnecté

Message par gillespenot » dim. 29 avr. 2018 23:33

J'ai configuré un PI2 sous strech de la manière la plus simple : DHCP sur eth0 et sur le WIFI. Tout marche à merveille tant que la connexion par eth0 reste active. La livebox fournit deux adresses séparées, je peux me connecter en VNC sur les deux adresses, le dongle wifi clignote bleu, le symbole wifi est stable sur l'interface graphique et je vois la liste des réseaux wifi à proximité.
Mais si je fait un shutdown et que je débranche le câble réseau, plus rien ne marche. Le dongle clignote, mais les adresses fixées par la la livebox ne sont plus pingable (ce qui est normal pour le eth0 débranché!)
Avez vous eu le même problème?

En fait j'ai deux endroits pour "jouer" avec mon PI2 : à Paris j'ai un switch et tout ce qu'il faut mais ailleurs (Oléron) je n'ai que le WIFI disponible. Donc je veux qu'il démarre sur le wifi si le cable rj45 n'est pas branché.

Cordialement
Gilles

Voici pour info le résultat d'un ifconfig quand le câble est branché. Je ne peux vous donner la même chose quand le câble n'est pas branché car je n'ai pas la main sous VNC si SSH

<t>eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500<br/>
inet 192.168.1.100 netmask 255.255.255.0 broadcast 192.168.1.255<br/>
ether b8:27:eb:45:18:12 txqueuelen 1000 (Ethernet)<br/>
RX packets 1924 bytes 108373 (105.8 KiB)<br/>
RX errors 0 dropped 23 overruns 0 frame 0<br/>
TX packets 2897 bytes 3358695 (3.2 MiB)<br/>
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0<br/>
<br/>
lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536<br/>
inet 127.0.0.1 netmask 255.0.0.0<br/>
loop txqueuelen 1000 (Boucle locale)<br/>
RX packets 3557 bytes 346034 (337.9 KiB)<br/>
RX errors 0 dropped 0 overruns 0 frame 0<br/>
TX packets 3557 bytes 346034 (337.9 KiB)<br/>
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0<br/>
<br/>
wlx74da386194a5: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500<br/>
inet 192.168.1.207 netmask 255.255.255.0 broadcast 192.168.1.255<br/>
ether 74:da:38:61:94:a5 txqueuelen 1000 (Ethernet)<br/>
RX packets 9799 bytes 2178993 (2.0 MiB)<br/>
RX errors 0 dropped 342 overruns 0 frame 0<br/>
TX packets 206 bytes 16281 (15.8 KiB)<br/>
TX errors 0 dropped 0 overruns 0 carrier 0 collisions

le contenu de /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)

le contenu de /etc/dhcpcd.conf (j'enleve les commentaires pour simplifier)
hostname rpigilles
clientid
persistent
option rapid_commit
option domain_name_servers, domain_name, domain_search, host_name
option classless_static_routes
option ntp_servers
option interface_mtu
require dhcp_server_identifier
slaac private
interface wlx74da386194a5
noipv6

maxty01
Modérateur
Messages : 705
Enregistré le : dim. 16 nov. 2014 20:53
Localisation : Charleroi - Belgique

Re: Pas de connection en wifi si le cable RJ45 est déconnecté

Message par maxty01 » lun. 30 avr. 2018 00:37

Bonsoir,

Est-il possible d'avoir le fichier de log /var/log/syslog

Bonne soirée,
Il n'y a pas de question stupide, il n'y a que des imbéciles qui ne posent pas de question !
RaspBerry Pi : 1 x B+ Raspbian 1 x RPI2 MiniBian
Mieux me connaître ? Regarder mon Image

Répondre

Retourner vers « Le réseau sur le Raspberry Pï »