[RESOLU] Relais récalcitrent  [RESOLU]

Un lieu pour discuter des composants et de leur utilisation. Un passage obligé si vous devez interfacer votre Raspberry Pi avec le monde extérieur. On y trouvera aussi les cartes type commande de moteur pas à pas, continu, servo...

Modérateurs : Francois, smba38

Avatar du membre
EVOTk
Modérateur
Messages : 878
Enregistré le : sam. 20 sept. 2014 02:36

Re: Relais récalcitrent

Message par EVOTk » dim. 30 nov. 2014 00:31

Sans cette résistance le MOSFET n'a rien qui le rappel au 0.
je ne maîtrise que moyennement les transistor et encore moins les MOSFET.

Par contre pour activer CH1, le MOSFET tout comme un transistor n'est pour moi pas adapter car ton module possède déjà un transistor ! Cela donne donc un montage a amplification, c'est n'est pas se qu'on cherche.

la seul explication que je voit c'est que 4,7v ne suffit pas au module ... Ton alim pour le PCF8575 fourni t'elle bien 5V ? ou aussi du 4,7v ?
NAS : DS3615xs Xpenology - 2x 8To + 2x 3To + 2x 4To WD Red - APC Back-UPS Pro 900
SeedBox / VPN : 1To / 20Gbps / Trafic illimité chez FeralHosting
Surveillance Réseau : Smokeping sur Rasp. B / Raspbian
Imprimante 3D : Dagoma DiscoEasy 200

Avatar du membre
vague nerd
Modérateur
Messages : 1473
Enregistré le : mar. 14 oct. 2014 11:42
Localisation : France !

Re: Relais récalcitrent

Message par vague nerd » dim. 30 nov. 2014 00:42

Ton alim pour le PCF8575 fourni t'elle bien 5V ? ou aussi du 4,7v ?
4.91V pour l'alim, et 4.8 pour le pin...

Je crois comprendre ou tu veux en venir. Oui, j'arrive à commuter le relais avec la même alim que celle qui alimente le pcf8575 (et le relais lui même d'ailleur).
On pourrait peut-être baisser la tension avec une resistance pour s'assurer qu'il commute avec une tension plus faible ?
Cordialement,

Vague Nerd

Avatar du membre
EVOTk
Modérateur
Messages : 878
Enregistré le : sam. 20 sept. 2014 02:36

Re: Relais récalcitrent

Message par EVOTk » dim. 30 nov. 2014 00:58

vague nerd a écrit :
On pourrait peut-être baisser la tension avec une resistance pour s'assurer qu'il commute avec une tension plus faible ?
C'est pas bete !

Voila comment faire un pont diviseur de tension :

Vs = (R1/(R1+R2)) x Ve

Image

Si tu a une resistance variable sous la main, c'est encore plus simple :
Image
NAS : DS3615xs Xpenology - 2x 8To + 2x 3To + 2x 4To WD Red - APC Back-UPS Pro 900
SeedBox / VPN : 1To / 20Gbps / Trafic illimité chez FeralHosting
Surveillance Réseau : Smokeping sur Rasp. B / Raspbian
Imprimante 3D : Dagoma DiscoEasy 200

Avatar du membre
vague nerd
Modérateur
Messages : 1473
Enregistré le : mar. 14 oct. 2014 11:42
Localisation : France !

Re: Relais récalcitrent

Message par vague nerd » dim. 30 nov. 2014 00:59

BINGO !

En faisant baisser la tension de l'alim en dessous de 4.8V (et en s'en servant sur ch1), la led du relais ne s'allume plus et le relais à du mal à commuter (cli/clac, clic/clac...).

J'abandonne ici pour ce soir... sur une simili victoire ?
Merci de ton aide.
Cordialement,

Vague Nerd

Avatar du membre
EVOTk
Modérateur
Messages : 878
Enregistré le : sam. 20 sept. 2014 02:36

Re: Relais récalcitrent

Message par EVOTk » dim. 30 nov. 2014 01:00

vague nerd a écrit :sur une simili victoire ?
On dirait bien :)

Bon courage pour la suite ! Bonne nuit.
NAS : DS3615xs Xpenology - 2x 8To + 2x 3To + 2x 4To WD Red - APC Back-UPS Pro 900
SeedBox / VPN : 1To / 20Gbps / Trafic illimité chez FeralHosting
Surveillance Réseau : Smokeping sur Rasp. B / Raspbian
Imprimante 3D : Dagoma DiscoEasy 200

Avatar du membre
vague nerd
Modérateur
Messages : 1473
Enregistré le : mar. 14 oct. 2014 11:42
Localisation : France !

Re: Relais récalcitrent

Message par vague nerd » dim. 30 nov. 2014 01:01

En fait je suis parti de ça :
domi a écrit :Tu peux éventuellement mettre une résistance afin de baisser la tension, mais il faudrait connaitre l'intensité consommée par la commande.
Essai une alim 5V sur la commande avec un ampèremètre pour mesurer l'intensité consommée.
Ensuite si ma mémoire est bonne : U = R*I donc R = U/I soit R = 0,4 / I afin de faire consommer à la résistance les 0,4 V excessif.
J'ai utilisé les résistances que j'avais sous la mains, et avec une 4.7k, la tension à chutée de 0.1V...

Merci, bye.
Cordialement,

Vague Nerd

Avatar du membre
EVOTk
Modérateur
Messages : 878
Enregistré le : sam. 20 sept. 2014 02:36

Re: Relais récalcitrent

Message par EVOTk » dim. 30 nov. 2014 01:04

vague nerd a écrit :J'ai utilisé les résistances que j'avais sous la mains, et avec une 4.7k, la tension à chutée de 0.1V...
Tu utilise quoi comme alim ? Une alim de 5V qui fourni 4,9V est soit surchargé, soit de mauvaise facture
NAS : DS3615xs Xpenology - 2x 8To + 2x 3To + 2x 4To WD Red - APC Back-UPS Pro 900
SeedBox / VPN : 1To / 20Gbps / Trafic illimité chez FeralHosting
Surveillance Réseau : Smokeping sur Rasp. B / Raspbian
Imprimante 3D : Dagoma DiscoEasy 200

Avatar du membre
vague nerd
Modérateur
Messages : 1473
Enregistré le : mar. 14 oct. 2014 11:42
Localisation : France !

Re: Relais récalcitrent

Message par vague nerd » dim. 30 nov. 2014 01:06

Une alim de breadboard noname.
Oui, surement de la m**** ! Et oui, possiblement surchargée. 2 cartes i2C (dont la pcf8575), le relais, et plein de servos (mais au repos).
Cordialement,

Vague Nerd

Avatar du membre
EVOTk
Modérateur
Messages : 878
Enregistré le : sam. 20 sept. 2014 02:36

Re: Relais récalcitrent

Message par EVOTk » dim. 30 nov. 2014 01:10

Si cela tinteresse, j'ai il y a peu acheté cette alim : 5v 2A

Elle alimente mon raspberry, un relais, une led et un afficheur LCD depuis maintenant 2 semaines sans problème, elle chauffe peu. Pour 4,8€ j'en suis super satisfait. Petit plus, la tension est ajustable si le 5V n'est pas parfait ;)
NAS : DS3615xs Xpenology - 2x 8To + 2x 3To + 2x 4To WD Red - APC Back-UPS Pro 900
SeedBox / VPN : 1To / 20Gbps / Trafic illimité chez FeralHosting
Surveillance Réseau : Smokeping sur Rasp. B / Raspbian
Imprimante 3D : Dagoma DiscoEasy 200

Avatar du membre
vague nerd
Modérateur
Messages : 1473
Enregistré le : mar. 14 oct. 2014 11:42
Localisation : France !

Re: Relais récalcitrent

Message par vague nerd » dim. 30 nov. 2014 01:13

Et combien de frais de port ? :D

Mon projet de base, c'est un ugv. Du coup, je suis plutôt sur batterie USB...
Mais ça peut être intéressant pour les tests et la mise au point.
Cordialement,

Vague Nerd

Répondre

Retourner vers « L'électronique et le Raspberry Pi »