[RESOLU] Relais récalcitrent  [RESOLU]

Un lieu pour discuter des composants et de leur utilisation. Un passage obligé si vous devez interfacer votre Raspberry Pi avec le monde extérieur. On y trouvera aussi les cartes type commande de moteur pas à pas, continu, servo...

Modérateurs : Francois, smba38

Avatar du membre
EVOTk
Modérateur
Messages : 847
Enregistré le : sam. 20 sept. 2014 02:36

Re: Relais récalcitrent

Message par EVOTk » dim. 30 nov. 2014 01:15

Sur Dx.com comme sur tout les sites du genre les frais de port sont gratuit. Faut juste pas etre pressé ( environ 3/4semaines mini )

Edit :
Sur batterie style batterie de secours pour telephone ? Dans se cas il faudra peut etre prévoir se genre de chose ? 5v Booster
NAS : DS3615xs Xpenology - 2x 8To + 2x 3To + 2x 4To WD Red - APC Back-UPS Pro 900
SeedBox / VPN : 1To / 20Gbps / Trafic illimité chez FeralHosting
Surveillance Réseau : Smokeping sur Rasp. B / Raspbian
Imprimante 3D : Dagoma DiscoEasy 200

Avatar du membre
vague nerd
Modérateur
Messages : 1471
Enregistré le : mar. 14 oct. 2014 11:42
Localisation : France !

Re: Relais récalcitrent

Message par vague nerd » dim. 30 nov. 2014 14:45

Sur batterie style batterie de secours pour telephone ?
Oui. Par contre, cette batterie ne servira sûrement pas en usage relais...

Le composant 5v Booster prend une tension d'entrée de 3 ~ 5V et fournit une tension de sortie: 5.0V / 3A.
Je veux bien le croire, mais il fait comment ? Et que signifie :
- Mode d'entrée: IN + niveau d'entrée positif, négatif IN-entrée
?
Cordialement,

Vague Nerd

Avatar du membre
EVOTk
Modérateur
Messages : 847
Enregistré le : sam. 20 sept. 2014 02:36

Re: Relais récalcitrent

Message par EVOTk » dim. 30 nov. 2014 15:46

Il rehausse la tension ( Comme le ferai un onduleur, amis la on reste en continu c'est donc beaucoup plus simple ), via un Mosfet et une oscillation de 500khz

Pour un peu plus de detail : http://fr.wikipedia.org/wiki/Convertiss ... tionnement

Bien sur il y a toujours des pertes ( mais généralement le rendement de se genre de chose n'est pas trop mauvais ( une histoire de 92% pour les moins bon d'entre eux on en trouve qui monte a 96% )

Que tu cable l'entrée, donc + 3 a +5V sur IN+ ( positif ) et IN- ( négatif, 0v ), et ton 5V ressort en +OUT et -OUT
NAS : DS3615xs Xpenology - 2x 8To + 2x 3To + 2x 4To WD Red - APC Back-UPS Pro 900
SeedBox / VPN : 1To / 20Gbps / Trafic illimité chez FeralHosting
Surveillance Réseau : Smokeping sur Rasp. B / Raspbian
Imprimante 3D : Dagoma DiscoEasy 200

Avatar du membre
vague nerd
Modérateur
Messages : 1471
Enregistré le : mar. 14 oct. 2014 11:42
Localisation : France !

Re: Relais récalcitrent

Message par vague nerd » mer. 14 janv. 2015 12:49

Bonjour.

Ca y est, j'ai enfin reçu ma commande de dx.com. Merci pour les liens, evo.

...

Et zut, impossible de renouveler ma licence gratuite de yenka à cette heure. :cry:
Du coup, je ne peux pas refaire le schéma de mon montage...

Je me base sur le thread
pour ce montage.
Image

J'ajoute le booster fraîchement reçu non pas la place du voltmètre de droite et relié à ch1, mais directement au cul de l’alimentation qui me délivre le 4.7V que je veux monter en 5V (représenté 9V dans le schéma). C''est bien ça ?
@evo ; j'ai été un peu c*n sur le coup : j'ai acheté le booster que tu m'a conseillé (à juste titre), alors que j'aurai du prendre un modèle permettant de produire + de 5V. Tu as vu de tes yeux une tension max de combien avec ce composant ?

Cdt.

EDIT : C'est pas vrais.... impossible de retrouver le pack de résistance recu sous 3 jours chez dx... Quelqu'un à une frontale et une fourche (mode gaston lagaffe et le courrier en retard) à me preter ?
Cordialement,

Vague Nerd

Avatar du membre
vague nerd
Modérateur
Messages : 1471
Enregistré le : mar. 14 oct. 2014 11:42
Localisation : France !

Re: Relais récalcitrent

Message par vague nerd » mer. 14 janv. 2015 16:28

Bon, j'ai trouvé de quoi faire, malgré un gros sachet de résistance parti dans une dimension parallèle.

Image
Mon transistor à l'aire d'être dans un boitier TO92, alors que selon cette image, mon 2n2222 devrait être dans un TO 5, 18 ou 39. Peu importe, n'est-ce pas ? Peu importe, il faut juste faire attention aux pins.

Image
Mon transistor est un NPN. N'est-ce pas ?

Image
Après une mise à la masse commune (je vais finir par bruller un truc, moi) ça marche !

Par contre, on est d'accord, je flingue mes piles, même relais éteint, car j’alimente tout le temps le relais, justement. N'est-ce pas ?
Edit : c'est pas très grave, ça marche aussi avec mon alim de breadboard à 4.9V...

Encore merci evo.

Cdt.
Cordialement,

Vague Nerd

Avatar du membre
EVOTk
Modérateur
Messages : 847
Enregistré le : sam. 20 sept. 2014 02:36

Re: [RESOLU] Relais récalcitrent

Message par EVOTk » mer. 14 janv. 2015 17:35

Salut !
Non le relais nest pas toujours alimente sinon il serait toujours actif ;)
NAS : DS3615xs Xpenology - 2x 8To + 2x 3To + 2x 4To WD Red - APC Back-UPS Pro 900
SeedBox / VPN : 1To / 20Gbps / Trafic illimité chez FeralHosting
Surveillance Réseau : Smokeping sur Rasp. B / Raspbian
Imprimante 3D : Dagoma DiscoEasy 200

Avatar du membre
vague nerd
Modérateur
Messages : 1471
Enregistré le : mar. 14 oct. 2014 11:42
Localisation : France !

Re: [RESOLU] Relais récalcitrent

Message par vague nerd » mer. 14 janv. 2015 18:34

Le module relais l'est, lui !
Tu veux dire que tout ce qui consomme, c'est la pauv' let d'état, quand le relais est "éteint" ?

Cdt.
Cordialement,

Vague Nerd

Avatar du membre
EVOTk
Modérateur
Messages : 847
Enregistré le : sam. 20 sept. 2014 02:36

Re: [RESOLU] Relais récalcitrent

Message par EVOTk » mer. 14 janv. 2015 19:29

Ha oui c'est vrai sye cest un module que tu utilise
Les transistors consome egalement mais cest faible voir negligeable tout depend de la source dalimentation ;)
NAS : DS3615xs Xpenology - 2x 8To + 2x 3To + 2x 4To WD Red - APC Back-UPS Pro 900
SeedBox / VPN : 1To / 20Gbps / Trafic illimité chez FeralHosting
Surveillance Réseau : Smokeping sur Rasp. B / Raspbian
Imprimante 3D : Dagoma DiscoEasy 200

Avatar du membre
vague nerd
Modérateur
Messages : 1471
Enregistré le : mar. 14 oct. 2014 11:42
Localisation : France !

Re: [RESOLU] Relais récalcitrent

Message par vague nerd » mer. 14 janv. 2015 20:11

Ok, merci.

Là, je crois que je viens de flinguer mon pi. :cry:
J'ai envoyé du 5v sur un gpio, puis 5v sur la masse....

Depuis, les pins sont bloqués dans un état logique, qui n'est pas l'état electrique. Certain à vrais d'autres à faux. Re :cry:

Je vais laisser reposer un peu, là !

Edit : je suis largué, là...
Un des deux pin qui ne marchait plus remarche, après tripotage en python...

Code : Tout sélectionner

pi@raspberrypi ~ $ gpio read 7
1
pi@raspberrypi ~ $ gpio write 7 0
pi@raspberrypi ~ $ gpio read 7
1
pi@raspberrypi ~ $ python lampe.py
pi@raspberrypi ~ $ gpio read 7
0
pi@raspberrypi ~ $ gpio write 7 1
pi@raspberrypi ~ $ gpio read 7
1
pi@raspberrypi ~ $ gpio write 7 0
pi@raspberrypi ~ $ gpio read 7
0
Et lampe.py :

Code : Tout sélectionner

import RPi.GPIO as GPIO
#setup GPIO using Board numbering
GPIO.setmode(GPIO.BOARD)
GPIO.setup(7, GPIO.OUT)
GPIO.output(7, False)
J'imagine que c'est le

Code : Tout sélectionner

GPIO.setup(7, GPIO.OUT)
qui remet les choses d'aplomb... ou il y a des fusibles magiques qui se re-soudent tout seul ?

Re-edit : Le pin 11 ne veut rien savoir. C'est celui qui s'est pris le 5V. Le pin 7, qui remarche, est tombé en panne après injection de 5V sur la masse... le coup des fuses, c'est ça ?
Cordialement,

Vague Nerd

Avatar du membre
vague nerd
Modérateur
Messages : 1471
Enregistré le : mar. 14 oct. 2014 11:42
Localisation : France !

Re: [RESOLU] Relais récalcitrent

Message par vague nerd » mer. 14 janv. 2015 23:46

Après lecture des spec de mon capteur, je n'ai pas injecté de 5V dans le pin 11, mais du 3,3V. Normal, quoi.
J'imagine que mes symptômes actuels sont dus au branchement sauvage du 5V sur la masse... et qu'il y a des fuses auto-réamorce-able qui protègent de ça.

Actuellement, le pin 7 fonctionne, les pin 11 et 12 non.

Je verrai demain matin...
Cordialement,

Vague Nerd

Répondre

Retourner vers « L'électronique et le Raspberry Pi »