Impossible de mettre a jour ou d’installer un logiciel

Le système préconisé par la Fondation Raspberry Pi

Modérateurs : Francois, maxty01

atchoum99
Messages : 3
Enregistré le : lun. 6 nov. 2017 19:19

Impossible de mettre a jour ou d’installer un logiciel

Messagepar atchoum99 » lun. 6 nov. 2017 19:21

bonjour tout le monde,
voila depuis quelques jours, j’essaye de mettre a jour mon raspberry 3 sous raspbian. Mais il me retourne une erreur. Par exemple ce matin je tape sudo apt-get dist-upgrade et voila l’erreur : Préparation du dépaquetage de …/samba_2%3a4.2.14+dfsg-0+deb8u8_armhf.deb …
Bus error
Bus error
Bus error
Bus error
invoke-rc.d: initscript samba-ad-dc, action “stop” failed.
dpkg : avertissement : le sous-processus ancien script pre-removal a retourné une erreur de sortie d’état 135
dpkg: tentative d’exécution du script du nouveau paquet à la place…
Bus error
Bus error
Bus error
Bus error
invoke-rc.d: initscript samba-ad-dc, action “stop” failed.
dpkg: erreur de traitement de l’archive /var/cache/apt/archives/samba_2%3a4.2.14+dfsg-0+deb8u8_armhf.deb (–unpack) :
le sous-processus nouveau script pre-removal a retourné une erreur de sortie d’état 135
Bus error
Bus error
Bus error
Bus error
invoke-rc.d: initscript smbd, action “start” failed.
dpkg : erreur lors du nettoyage :
le sous-processus script post-installation installé a retourné une erreur de sortie d’état 135
Des erreurs ont été rencontrées pendant l’exécution :
/var/cache/apt/archives/samba_2%3a4.2.14+dfsg-0+deb8u8_armhf.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Avez vous une idee?
merci d’avance

maxty01
Modérateur
Messages : 675
Enregistré le : dim. 16 nov. 2014 21:53
Localisation : Charleroi - Belgique

Re: Impossible de mettre a jour ou d’installer un logiciel

Messagepar maxty01 » lun. 6 nov. 2017 19:34

Bonsoir,

Tu peux essayer ces commandes :

Code : Tout sélectionner

sudo rm /var/lib/apt/lists/lock /var/lib/dpkg/lock /var/cache/apt/archives/lock
sudo killall apt-get


Bonne soirée

Source :
https://forum.ubuntu-fr.org/viewtopic.php?id=1986648 => https://doc.ubuntu-fr.org/probleme_apt#autres_erreurs

Autre solution :
http://forums.bodhilinux.com/index.php? ... bus-error/

Google :
« apt-get bus error »
Il n'y a pas de question stupide, il n'y a que des imbéciles qui ne posent pas de question !
RaspBerry Pi : 1 x B+ Raspbian 1 x RPI2 MiniBian
Mieux me connaître ? Regarder mon Image

atchoum99
Messages : 3
Enregistré le : lun. 6 nov. 2017 19:19

Re: Impossible de mettre a jour ou d’installer un logiciel

Messagepar atchoum99 » lun. 6 nov. 2017 19:53

bonsoir,
merci pour ta réponse. Mais ce ne change pas le problème.

jelopo
Messages : 21
Enregistré le : mer. 11 oct. 2017 10:23

Re: Impossible de mettre a jour ou d’installer un logiciel

Messagepar jelopo » mar. 7 nov. 2017 22:38

Bonjour,

Avant de faire un dist-upgrade, as-tu fais ceci ?

Code : Tout sélectionner

sudo apt-get update
sudo apt-get upgrade

atchoum99
Messages : 3
Enregistré le : lun. 6 nov. 2017 19:19

Re: Impossible de mettre a jour ou d’installer un logiciel

Messagepar atchoum99 » jeu. 9 nov. 2017 18:34

salut,
oui j'ai fais ces 2 commandes avant


Retourner vers « Raspbian »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité