rdiff-backup 2.0.0

Votre Apache se cache, votre Pi gémit, votre SoC fume ? La panne quoi ! C'est ici que vous trouverez sans doute une solution... Sinon du réconfort :)

Modérateurs : Francois, maxty01

Répondre
marcelbenhur
Messages : 1
Enregistré le : jeu. 9 mars 2017 21:41

rdiff-backup 2.0.0

Message par marcelbenhur » dim. 28 févr. 2021 17:14

Bonjour,
J'ai installé rdiff-backup 1.2.8 des dépôts officiels de raspbian. Mais pour être compatible avec mon autre hôte il faudrait que j'installe la version 2.0.0.
J'ai l'impression que la version existe en test (non stable), https://repology.org/project/rdiff-backup/versions
Quelqu'un saurait où trouver le paquet ou faut 'il compiler qqchose ?

Merci d'avance

maxty01
Modérateur
Messages : 755
Enregistré le : dim. 16 nov. 2014 20:53
Localisation : Charleroi - Belgique

Re: rdiff-backup 2.0.0

Message par maxty01 » sam. 13 mars 2021 09:59

Bonjour,

Je dois d'abord avouer que ce post a échappé à ma vigilance.

Dans un premier temps, je pense qu'il est possible de prendre des paquets de version unstable/testing via des backports, mais je déconseille cela.
Cette méthode est à utiliser avec précaution et seulement si votre expertise le permet.

Perso, j'ai une certaine expertise de Linux et je n'ai que très rarement effectuer des backports !

Dans un second temps, je dirai que c'est un «problème» générale au distribution Debian de façon général ainsi que ces dérivées (je suis sur Mint 20 et j'ai également la même version).
Dans ce cas, je me permets de déplacer le sujet dans la section «En Panne» qui est la meilleure pour ce sujet.

En tout cas, ce sujet sera plus visible dans cette section.

Bonne journée,
Bon weekend !
Il n'y a pas de question stupide, il n'y a que des imbéciles qui ne posent pas de question !
RaspBerry Pi : 1 x B+ Raspbian 1 x RPI2 MiniBian
Mieux me connaître ? Regarder mon LinkedIn

jelopo
Raspinaute
Messages : 231
Enregistré le : mer. 11 oct. 2017 10:23

Re: rdiff-backup 2.0.0

Message par jelopo » sam. 13 mars 2021 18:39

Bonjour,

Comment a été installé rdiff-backup ? via apt ou via pip ?
Il semblerait que sur RaspbianOS il soit recommandé de l'installer avec pip3, avec une version de Python > 3.5.

voir cette page: https://github.com/rdiff-backup/rdiff-b ... tag/v2.0.5

Télécharger le fichier rdiff-backup-2.0.5.tar.gz de la page https://github.com/rdiff-backup/rdiff-b ... tag/v2.0.5

Décompresser le fichier tar.gz et consulter le fichier README.md :

----
### Debian and derivatives, Raspbian, etc. (from PyPi)

```
sudo apt install python3-pip python3-setuptools python3-pylibacl python3-pyxattr
sudo pip3 install rdiff-backup
```

> **NOTE:** If your platform is not i386 or amd64, e.g. ARM/MIPS/etc,
you may need the build dependencies `build-essentials`, `librsync-dev`.
----

En espérant que ça aide.

A+

Répondre

Retourner vers « En panne ? »