[RESOLU] Serveur mail privé

Le système préconisé par la Fondation Raspberry Pi

Modérateurs : Francois, maxty01

Korhm
Raspinaute
Messages : 232
Enregistré le : ven. 19 sept. 2014 08:13
Localisation : Toulouse

Re: Serveur mail privé

Message par Korhm » ven. 4 mars 2016 18:19

rebeldu31 a écrit : - mettre en place un smtp privé et ne plus utiliser le smtp d'Orange : faisable, je pense, que lorsque j'aurais mon nom de domaine (en .fr)
Bonjour,

j'ai testé ce point de mon côté déjà.
Même avec un nom de domain, il te faut un smtp relay (celui de ton opérateur) : les smtp externes (de type gmail, orange,....) refusaient la connexion entre mon serveur et le leur car pour eux je suis un serveur inconnu et pas de confiance.
Avec le smtp relay, ta connexion entre ton serveur et ton opérateur est authentifiée, et le smtp de ton opérateur est connu et "de confiance" pour les autres smtp.

rebeldu31
Raspinaute
Messages : 269
Enregistré le : sam. 5 déc. 2015 20:17
Localisation : Toulouse

Re: Serveur mail privé

Message par rebeldu31 » sam. 5 mars 2016 18:47

Korhm a écrit :
rebeldu31 a écrit : - mettre en place un smtp privé et ne plus utiliser le smtp d'Orange : faisable, je pense, que lorsque j'aurais mon nom de domaine (en .fr)
Bonjour,

j'ai testé ce point de mon côté déjà.
Même avec un nom de domain, il te faut un smtp relay (celui de ton opérateur) : les smtp externes (de type gmail, orange,....) refusaient la connexion entre mon serveur et le leur car pour eux je suis un serveur inconnu et pas de confiance.
Avec le smtp relay, ta connexion entre ton serveur et ton opérateur est authentifiée, et le smtp de ton opérateur est connu et "de confiance" pour les autres smtp.
Bah, j'utiliserais un smtp relay, tant pis !!!

Bon, mes mails fonctionnent... J'ai ajouté quelques plugins à Roundcube, style "modifier son mot de passe" et obligation de changer son mot de passe à la 1ère connexion... Nickel !!!
D'autres plugins à tester, comme la perte de son mot de passe !!!
Clamav, Spamassassin et Amavis sont installés, je vais tester tout ça !!!

Par contre, je n'arrive pas à paramétrer mon appli mail sur mon smartphone Android. J'ai beau essayer tous les paramètres, impossible de m'y connecter...
Pi3 : envoi/réception SMS et sauvegardes
Pi4 : serveur de mail privé
Pi3 : serveur de surveillance
Pi3 : serveur web
Pi3 : serveur de tests
NAS Synology DS416 (2x2To en RAID1 + 1x2To + 1x4To)

rebeldu31
Raspinaute
Messages : 269
Enregistré le : sam. 5 déc. 2015 20:17
Localisation : Toulouse

Re: Serveur mail privé

Message par rebeldu31 » sam. 5 mars 2016 20:22

Suite....

Test de ClamAv, Spamassassin et Amavis...
Un fichier contenant un "virus" est bien mis en quarantaine et l'admin du serveur mail (moi) est informé...
Un fichier considéré comme SPAM me parvient, taggué "***SPAM***"... Maintenant il faut que je trouve la manière de lui dire de me le balancer directement dans le dossier "Pourriel" de Roundcube...

Trouvé : plugin movespam !!!

Dernier point donc : lire mes mails sur mon Android... SMTP SASL/TLS... Si vous avez des pistes...
Pi3 : envoi/réception SMS et sauvegardes
Pi4 : serveur de mail privé
Pi3 : serveur de surveillance
Pi3 : serveur web
Pi3 : serveur de tests
NAS Synology DS416 (2x2To en RAID1 + 1x2To + 1x4To)

rebeldu31
Raspinaute
Messages : 269
Enregistré le : sam. 5 déc. 2015 20:17
Localisation : Toulouse

Re: Serveur mail privé

Message par rebeldu31 » ven. 11 mars 2016 21:15

Bonjour,

Une suite à mon "aventure"...

J'ai réussi à envoyer un mail de mon appli Android, cool... 8-)

MAIS voilà... je ne reçois pas les mails sur l'appli... et en regardant, je ne les reçois plus sur mon webmail, sans aucune erreur ni retour dans mon email d'origine (gmail, orange), ni dans les logs...
Une vague sensation d'une mise à jour qui a fait foirée je ne sais quoi (MàJ qui a eu lieu dimanche, après mes sauvegardes)...

:o :shock:

Il semblerait que dovecot ne distribue plus... Ou que j'ai un problème de redirection mais je ne vois pas où...
J'ai tenté d'envoyer un mail d'1 compte vers 1 autre, tous les 2 sur mon serveur privé, et il part... mais n'arrive pas !!!
:?: :?: :?:
Pi3 : envoi/réception SMS et sauvegardes
Pi4 : serveur de mail privé
Pi3 : serveur de surveillance
Pi3 : serveur web
Pi3 : serveur de tests
NAS Synology DS416 (2x2To en RAID1 + 1x2To + 1x4To)

Korhm
Raspinaute
Messages : 232
Enregistré le : ven. 19 sept. 2014 08:13
Localisation : Toulouse

Re: Serveur mail privé

Message par Korhm » sam. 12 mars 2016 21:17

Bonsoir,

c'est un peu compliqué, surtout que je débarque après 10 pages :)
J'ai moi même installé un serveur mail chez moi récemment, qui marche très bien.

Que disent les logs ? Est-ce qu'il y a une trace du mail qui est censé arrivé ?
N'as-tu toujours rien reçu de la part de gmail ? Quand je faisais mes tests et que ça ne fonctionnait pas, j'avais un retour environ 24h plus tard
Est-ce que tu as déjà réussi à faire entrer des mails sur ton serveur ?

rebeldu31
Raspinaute
Messages : 269
Enregistré le : sam. 5 déc. 2015 20:17
Localisation : Toulouse

Re: Serveur mail privé

Message par rebeldu31 » sam. 12 mars 2016 23:11

Korhm a écrit :Bonsoir,

c'est un peu compliqué, surtout que je débarque après 10 pages :)
J'ai moi même installé un serveur mail chez moi récemment, qui marche très bien.

Que disent les logs ? Est-ce qu'il y a une trace du mail qui est censé arrivé ?
N'as-tu toujours rien reçu de la part de gmail ? Quand je faisais mes tests et que ça ne fonctionnait pas, j'avais un retour environ 24h plus tard
Est-ce que tu as déjà réussi à faire entrer des mails sur ton serveur ?
Bonsoir,

Dans l'ordre :
- aucun message dans la log, ni d'erreur ni de quoi que ce soit
- j'ai reçu un mail de gmail, ça y est... message : "The recipient server did not accept our requests to connect. (mon_domaine @IP_de_ma_box socket error)
- il y a quelques jours encore, j'envoyais et recevais des mails sans soucis... maintenant je reçois plus... même d'un email de mon domaine vers un autre mail de mon domaine (j'ai 3 mails pour l'instant)
- par contre, je reçois le "mail d'accueil" renvoyé par postfixadmin, et là je comprends plus....

Problème de nattage ? Pour tester j'ai natté les ports 587, 995, 993, 143, 110 vers mon serveur : je ne reçois toujours rien...
Pi3 : envoi/réception SMS et sauvegardes
Pi4 : serveur de mail privé
Pi3 : serveur de surveillance
Pi3 : serveur web
Pi3 : serveur de tests
NAS Synology DS416 (2x2To en RAID1 + 1x2To + 1x4To)

Korhm
Raspinaute
Messages : 232
Enregistré le : ven. 19 sept. 2014 08:13
Localisation : Toulouse

Re: Serveur mail privé

Message par Korhm » dim. 13 mars 2016 09:03

Salut
rebeldu31 a écrit : Problème de nattage ? Pour tester j'ai natté les ports 587, 995, 993, 143, 110 vers mon serveur : je ne reçois toujours rien...
As-tu essayé de NATer le port 25 ?
J'avais beau mettre les ports 587 et 993 pour le SMTP et IMAP, si je ne NATais pas le 25, les serveur "externes" n'arrivaient pas à contacter mon postfix
Le mail était le suivant, et pourtant l'entrée MX du DNS était correcte :

Code : Tout sélectionner

This is an automatically generated Delivery Status Notification

THIS IS A WARNING MESSAGE ONLY.

YOU DO NOT NEED TO RESEND YOUR MESSAGE.

Delivery to the following recipient has been delayed:

     user@domain.com

Message will be retried for 1 more day(s)

Technical details of temporary failure:
DNS Error: 55587193 DNS type 'mx' lookup of domain.com responded with code SERVFAIL

Par contre c'est bizarre qu'en interne ça ne marche pas.
As-tu des entrée DNS en locale qui pointe directement sur ton serveur mail, ou est-ce que ça "sort" sur Internet avant de revenir ?

rebeldu31
Raspinaute
Messages : 269
Enregistré le : sam. 5 déc. 2015 20:17
Localisation : Toulouse

Re: Serveur mail privé

Message par rebeldu31 » dim. 13 mars 2016 10:51

Korhm a écrit :Salut
rebeldu31 a écrit : Problème de nattage ? Pour tester j'ai natté les ports 587, 995, 993, 143, 110 vers mon serveur : je ne reçois toujours rien...
As-tu essayé de NATer le port 25 ?
J'avais beau mettre les ports 587 et 993 pour le SMTP et IMAP, si je ne NATais pas le 25, les serveur "externes" n'arrivaient pas à contacter mon postfix
Le mail était le suivant, et pourtant l'entrée MX du DNS était correcte :

Code : Tout sélectionner

This is an automatically generated Delivery Status Notification

THIS IS A WARNING MESSAGE ONLY.

YOU DO NOT NEED TO RESEND YOUR MESSAGE.

Delivery to the following recipient has been delayed:

     user@domain.com

Message will be retried for 1 more day(s)

Technical details of temporary failure:
DNS Error: 55587193 DNS type 'mx' lookup of domain.com responded with code SERVFAIL

Par contre c'est bizarre qu'en interne ça ne marche pas.
As-tu des entrée DNS en locale qui pointe directement sur ton serveur mail, ou est-ce que ça "sort" sur Internet avant de revenir ?
Bonjour,

J'ai natté le port 25... J'ai (enfin) reçu mon mail en interne ET je reçois bien mes mails... pffffffffff :shock:
Je n'ai aucune entrée DNS en local, donc ça "sort" pour "re rentrer"...
ET... j'arrive à recevoir mes mail sur mon appli Android...
PARFAIT !!!

Dernière étape : mon nom de domaine !!!
8-) :D
Pi3 : envoi/réception SMS et sauvegardes
Pi4 : serveur de mail privé
Pi3 : serveur de surveillance
Pi3 : serveur web
Pi3 : serveur de tests
NAS Synology DS416 (2x2To en RAID1 + 1x2To + 1x4To)

rebeldu31
Raspinaute
Messages : 269
Enregistré le : sam. 5 déc. 2015 20:17
Localisation : Toulouse

Re: Serveur mail privé

Message par rebeldu31 » sam. 19 mars 2016 21:00

Bonjour,

La suite de mes "exploits" (découvertes surtout).

J'ai fais l'acquisition de mon domaine en .fr. :shock:
J'ai modifié toute la configuration de mon serveur mail avec ce nouveau nom de domaine.
Ça y est, j'ai un serveur mail totalement fonctionnel !!! Bon, il me reste 2-3 petites choses à paramétrer/corriger mais il fonctionne... 8-)

Il ne me reste donc plus que :

- activer et paramétrer le filtrage des mails avec sieve/managesieve (Dovecot/Roundcube) ==> bloqué car quoi que je modifie, le filtrage ne se fait pas
- paramétrer mon serveur mail pour que je puisse utiliser un smtp local sur mon serveur (avec le smtp de mon FAI en relais, bien sûr) ==> si cela n'est pas faisable, je reste sur le smtp de mon FAI

Pour ces 2 dernières choses, je suis preneur de toutes aides.
Pi3 : envoi/réception SMS et sauvegardes
Pi4 : serveur de mail privé
Pi3 : serveur de surveillance
Pi3 : serveur web
Pi3 : serveur de tests
NAS Synology DS416 (2x2To en RAID1 + 1x2To + 1x4To)

rebeldu31
Raspinaute
Messages : 269
Enregistré le : sam. 5 déc. 2015 20:17
Localisation : Toulouse

Re: Serveur mail privé

Message par rebeldu31 » lun. 28 mars 2016 18:15

Bonjour,

La suite, et presque fin !!!

J'ai réglé mon soucis de filtrage des mails entrants.
Alors, j'ai du "magouiller" parce-que le plugin sieve de Dovecot avait besoin d'un lien symbolic ".dovecot.sieve" vers le fichier "managesieve.sieve" dans le répertoire "sieve" (contenant les règles de filtrage de managesieve Roundcube) présent dans le répertoire du compte mail (au-dessus du répertoire des mails "Maildir"). Mais je n'arrivais pas à créer ce lien (ln -fs ==> "permission denied" en tant que root). J'ai donc créer un répertoire "sieve" dans /etc/dovecot, avec les droits de vmail, et j'ai créé un lien symbolic par compte (.compte-dovecot.sieve). Et là, ben ça marche nickel !! Seul "hic", si je créé d'autres comptes mail je vais devoir ne pas oublier de créer ce lien symbolic !!! Je vais jeter un oeil vers postfixadmin et roundcube qui s'occupent de créer le répertoire du compte mail, afin de rajouter la création du lien symbolic au bon endroit !!!

Il ne me reste donc que le smtp local à tester, valider, confirmer, tout en utilisant le relay smtp de mon FAI. Ça marche très bien via mon NAS (envoi de mail) où je lui spécifie le smtp local et non le smtp de mon FAI !!!

Si vous avez des pistes !!!
Pi3 : envoi/réception SMS et sauvegardes
Pi4 : serveur de mail privé
Pi3 : serveur de surveillance
Pi3 : serveur web
Pi3 : serveur de tests
NAS Synology DS416 (2x2To en RAID1 + 1x2To + 1x4To)

Répondre

Retourner vers « Raspbian »