Paquet le plus recent ?

Le système préconisé par la Fondation Raspberry Pi

Modérateurs : Francois, maxty01

Répondre
pascal
Messages : 3
Enregistré le : dim. 16 nov. 2014 12:17

Paquet le plus recent ?

Message par pascal » dim. 16 nov. 2014 17:30

Bonjour à tous,
C'est mon premier message sur ce forum, vous allez voir que je ne suis pas un guru ;-)
Le but principal de mon raspberry est de surveiller mon mail et mon compte en banque, pour cela je comptais utiliser l'EXCELLENT weboob qui tourne déjà sur mon PC (quand il est allumé).
Mais je suis bloqué car sur la dernière Raspbian qui tourne très bien chez moi je ne peux installer que la version weboob_0.c-4.1_all.deb. Cette version n'est plus maintenue par les développeurs et ne gère pas ma banque = sans intérêt. Mais si je regarde dans le dépôt de mon source list je vois que les paquets de la toute dernière release sont présents (voir http://mirrordirector.raspbian.org/rasp ... /w/weboob/) aux cotés de la version installable (dont je ne veux pas). Avec synaptic je ne vois même pas weboob_1.0-1_all.deb qu'il me faut.
Ma question est: existe t'il une façon de forcer l'installation de cette version 1.0-1 puisqu'elle est dispo dans le dépôt?

C'est pas forcement très clair n’hésitez pas à me demander de préciser.

Merci pour votre aide

Pascal

domi
Administrateur
Messages : 2622
Enregistré le : mer. 17 sept. 2014 18:12
Localisation : Seine et Marne

Re: Paquet le plus recent ?

Message par domi » dim. 16 nov. 2014 17:48

Bonjour,

tu as essayé avec DPKG.

Tu télécharge le paquet Debian, puis tu fais un :

Code : Tout sélectionner

sudo dpkg -i weboob_1.0-1_all.deb

pascal
Messages : 3
Enregistré le : dim. 16 nov. 2014 12:17

Re: Paquet le plus recent ?

Message par pascal » mar. 18 nov. 2014 13:13

Merci pour ta reponse Domi, j'ai essaye avec apt-get install et dpkg mais j'ai des problemes de dependance en casquade et j'esperais que qq1 saurait y remedier avec une option magique .
Je continue a chercher

Bonne journee

domi
Administrateur
Messages : 2622
Enregistré le : mer. 17 sept. 2014 18:12
Localisation : Seine et Marne

Re: Paquet le plus recent ?

Message par domi » mar. 18 nov. 2014 17:22

Si le "apt-get" existe, toutes les dépendances sont installées.

Avec "dpkg", tu dois toi même installer les dépendances qui sont demandées.

Avatar du membre
Manfraid
Modérateur
Messages : 1402
Enregistré le : ven. 3 oct. 2014 14:50
Contact :

Re: Paquet le plus recent ?

Message par Manfraid » mar. 18 nov. 2014 19:49

Je viens de regarder et ce qui me parais bizarre c'est qu'on le vois biens dans les depots sur le site mais pas moyen de le voir dans la liste de paquet disponible je te cherche une solution (si il en existe une facile surtout)
NAS : DIY OS Debian: DD250Go + 3x2To + 6To
Raspberry pi : 2B OS : Raspbian
Se tromper est humain, Vraiment foutre la merde nécessite le mot de passe de root.

pascal
Messages : 3
Enregistré le : dim. 16 nov. 2014 12:17

Re: Paquet le plus recent ?

Message par pascal » mar. 18 nov. 2014 20:04

@manfraid: c´est exactement ce que je disais, s´il est dans le dépôt, qq1 l´y a mis pour quelque chose, il doit y avoir une solution.

@domi: le problème c´est que les dépendance nécessaires ne sont pas toutes dans le dépôt. Par exemple la version de python-requests présente dans le dépôt est trop ancienne.

des idées?

Bonne soirée

Avatar du membre
Manfraid
Modérateur
Messages : 1402
Enregistré le : ven. 3 oct. 2014 14:50
Contact :

Re: Paquet le plus recent ?

Message par Manfraid » mar. 18 nov. 2014 20:19

Dans se cas il n'y a plus que l'installer a la main alors. Car cela doit être pour ça qu'il n'est pas visible c'est que les dépendances ne peuvent pas être satisfaite
NAS : DIY OS Debian: DD250Go + 3x2To + 6To
Raspberry pi : 2B OS : Raspbian
Se tromper est humain, Vraiment foutre la merde nécessite le mot de passe de root.

Répondre

Retourner vers « Raspbian »