impossible de démarrer un script bash au démarrage

Le système préconisé par la Fondation Raspberry Pi

Modérateurs : Francois, maxty01

dyox
Raspinaute
Messages : 568
Enregistré le : dim. 28 déc. 2014 15:28
Localisation : Le long de la côte, au dessus du pays des bigoudennes, aïe

Re: impossible de démarrer un script bash au démarrage

Message par dyox » mar. 31 juil. 2018 22:42

C'est normal et j'ai précisé hier :
Et bonne nouvelle, en enlevant l'esperluette, votre script fonctionne.
Et je reviens encore sur ce que j'ai dit hier, il y a bien un sudo crontab.
Débutant sous RPi / linux

:arrow: :arrow: :arrow: [Pour bien commencer] Pour les nouveaux acquéreurs de Raspberry Pi (liste de liens utiles)

Romaric
Messages : 17
Enregistré le : dim. 29 juil. 2018 10:55

Re: impossible de démarrer un script bash au démarrage

Message par Romaric » mar. 31 juil. 2018 22:47

eh bien non pas chez moi
je l'avais d'abord écris dans le & a la fin

dyox
Raspinaute
Messages : 568
Enregistré le : dim. 28 déc. 2014 15:28
Localisation : Le long de la côte, au dessus du pays des bigoudennes, aïe

Re: impossible de démarrer un script bash au démarrage

Message par dyox » mar. 31 juil. 2018 22:54

Reprenez votre script initial sans le & et retestez.

sinon sur celui-ci, il est bien "x" ? Et il n'y a pas le path de date.

Perso, j'ai testé un équivalent de ça et cela fonctionnait :

Code : Tout sélectionner

#!/bin/bash
#date_du_jour='07 - 22'
PATH=/home/pi/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/local/games:/usr/games
date_du_jour=$(date "+%m - %d")

#find /media/pi/8177-BB35/"$date_du_jour"/ -type f -iname "*.jp*g" > /home/pi/bin/JPEGlist.txt
find /home/pi/Pictures/"$date_du_jour"/ -type f -iname "*.jp*g" > /home/pi/bin/JPEGlist.txt
sudo chmod 666 /home/pi/bin/JPEGlist.txt
export DISPLAY=:0.0
feh -q -z -Y -Z -F -D 10.0 -f /home/pi/bin/JPEGlist.txt

#sudo shutdown -h 21:00
Débutant sous RPi / linux

:arrow: :arrow: :arrow: [Pour bien commencer] Pour les nouveaux acquéreurs de Raspberry Pi (liste de liens utiles)

Romaric
Messages : 17
Enregistré le : dim. 29 juil. 2018 10:55

Re: impossible de démarrer un script bash au démarrage

Message par Romaric » mar. 31 juil. 2018 23:23

ça ne fonctionne pas chez moi
le diapo ne se lance pas

j'ai trouvé une manière de faire fonctionner :
je lance un terminal dans le lxsession avec @lxterminal
et ensuite dans le .bashrc ; j'appelle mon scripte ! et là ça marche
par contree ça marche uniquement avec les images en local,
avec les images sur clef usb ça ne fonctionne pas

il faudra que je regarde pour monter la clef manuelle sur dans mon script :)

on verra ça un autre soir :) bonne nuit

dyox
Raspinaute
Messages : 568
Enregistré le : dim. 28 déc. 2014 15:28
Localisation : Le long de la côte, au dessus du pays des bigoudennes, aïe

Re: impossible de démarrer un script bash au démarrage

Message par dyox » mar. 31 juil. 2018 23:26

La clé dans le fstab et on n'en parle plus.

Bonne nuit aussi
Débutant sous RPi / linux

:arrow: :arrow: :arrow: [Pour bien commencer] Pour les nouveaux acquéreurs de Raspberry Pi (liste de liens utiles)

Répondre

Retourner vers « Raspbian »