Passage Wheesy -> wheezy (problème)

Votre Apache se cache, votre Pi gémit, votre SoC fume ? La panne quoi ! C'est ici que vous trouverez sans doute une solution... Sinon du réconfort :)

Modérateurs : Francois, maxty01

Répondre
Xenon
Messages : 34
Enregistré le : dim. 27 sept. 2015 16:34

Passage Wheesy -> wheezy (problème)

Message par Xenon » mar. 6 sept. 2016 14:46

Bonjour à tous,

Tout a commencé lorsque j'ai voulu installer gitlab-ce, ça ne fonctionnait pas, j'avais ce message à chaque fois :
/opt/gitlab/embedded/bin/ruby: /lib/arm-linux-gnueabihf/libc.so.6: version `GLIBC_2.17' not found (required by /opt/gitlab/embedded/lib/libruby.so.2.3)

Après avoir essayé pas mal de choses, j'ai décidé de passer sous Jessie pour voir ce que ça donnait. J'ai donc changé wheesy par jessie dans /etc/apt/sources..., puis fait un update et un upgrade. Problème, j'ai maintenant un problème de dépendance que je ne parviens pas à résoudre.

J'ai bien entendu essayé la solution suggérée (apt-get install -f) mais je me retrouve avec encore des erreurs et je sais plus comment me dépêtrer de cette situation.
Si quelqu'un pouvait m'aider, ça serait sympa.

Code : Tout sélectionner

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 console-setup-linux : Depends: keyboard-configuration (= 1.123) but 1.88 is installed
E: Unmet dependencies. Try using -f.

Code : Tout sélectionner

sudo apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following package was automatically installed and is no longer required:
  libgssglue1
Use 'apt-get autoremove' to remove it.
The following extra packages will be installed:
  console-setup debconf keyboard-configuration
Suggested packages:
  debconf-doc libterm-readline-gnu-perl libgtk2-perl libnet-ldap-perl libqtgui4-perl libqtcore4-perl
The following packages will be upgraded:
  console-setup debconf keyboard-configuration
3 upgraded, 0 newly installed, 0 to remove and 761 not upgraded.
24 not fully installed or removed.
Need to get 1,061 kB of archives.
After this operation, 196 kB of additional disk space will be used.
Do you want to continue [Y/n]? Y
Get:1 http://mirrordirector.raspbian.org/raspbian/ jessie/main debconf all 1.5.56 [167 kB]
Get:2 http://mirrordirector.raspbian.org/raspbian/ jessie/main keyboard-configuration all 1.123 [766 kB]
Get:3 http://mirrordirector.raspbian.org/raspbian/ jessie/main console-setup all 1.123 [128 kB]
Fetched 1,061 kB in 3s (316 kB/s)  
Preconfiguring packages ...
dpkg: warning: files list file for package 'libwildmidi1:armhf' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'hicolor-icon-theme' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libopencv-video2.4' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libfm-modules:armhf' missing; assuming package has no files currently installed
(Reading database ... 82745 files and directories currently installed.)
Preparing to replace debconf 1.5.49 (using .../debconf_1.5.56_all.deb) ...
Traceback (most recent call last):
  File "/usr/bin/py3clean", line 32, in <module>
    from debpython import files as dpf
  File "/usr/share/python3/debpython/files.py", line 25, in <module>
    from debpython.pydist import PUBLIC_DIR_RE
  File "/usr/share/python3/debpython/pydist.py", line 28, in <module>
    from debpython.tools import memoize
UnicodeDecodeError: 'utf-8' codec can't decode byte 0xf5 in position 13: invalid start byte
dpkg: warning: subprocess old pre-removal script returned error exit status 1
dpkg: trying script from the new package instead ...
Traceback (most recent call last):
  File "/usr/bin/py3clean", line 32, in <module>
    from debpython import files as dpf
  File "/usr/share/python3/debpython/files.py", line 25, in <module>
    from debpython.pydist import PUBLIC_DIR_RE
  File "/usr/share/python3/debpython/pydist.py", line 28, in <module>
    from debpython.tools import memoize
UnicodeDecodeError: 'utf-8' codec can't decode byte 0xf5 in position 13: invalid start byte
dpkg: error processing /var/cache/apt/archives/debconf_1.5.56_all.deb (--unpack):
 subprocess new pre-removal script returned error exit status 1
Traceback (most recent call last):
  File "/usr/bin/py3compile", line 36, in <module>
    from debpython import files as dpf
  File "/usr/share/python3/debpython/files.py", line 25, in <module>
    from debpython.pydist import PUBLIC_DIR_RE
  File "/usr/share/python3/debpython/pydist.py", line 28, in <module>
    from debpython.tools import memoize
UnicodeDecodeError: 'utf-8' codec can't decode byte 0xf5 in position 13: invalid start byte
dpkg: error while cleaning up:
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 /var/cache/apt/archives/debconf_1.5.56_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Xenon
Messages : 34
Enregistré le : dim. 27 sept. 2015 16:34

Re: Passage Wheesy -> wheezy (problème)

Message par Xenon » mer. 7 sept. 2016 12:26

Je crois que je vais repartir sur une image de raspbian, ça sera plus simple.^^

Répondre

Retourner vers « En panne ? »