Lenteur LAN WIFI seulement !

Votre Apache se cache, votre Pi gémit, votre SoC fume ? La panne quoi ! C'est ici que vous trouverez sans doute une solution... Sinon du réconfort :)

Modérateurs : Francois, maxty01

2RJ
Messages : 55
Enregistré le : jeu. 18 déc. 2014 14:14
Localisation : 45 20 00 N 73 20 00 W
Contact :

Lenteur LAN WIFI seulement !

Message par 2RJ » ven. 28 avr. 2017 23:34

Bonjour...

Bizarre.... j'ai 4 raspberry actifs en mode surveillance (rpi cam control) qui sont monitorés en permanence sur le wifi local, depuis plusieurs mois. Vitesse excellente, sans latence et les vidéos s'enrégistrent lorsqu'il y a mouvement. Tout était normal jusqu'à avant hier.
Là, ça rame... ca plante... et pas seulement un (ce serait trop facile...) mais les quatre caméras en même temps !

Pourtant, mes deux ordinateurs, deux téléphones intelligents, un téléviseur et une tablette sont branchés aussi en WIFI et roulent à toute vitesse. Si je branche un raspberry par éthernet, bien sûr, le problème de latence disparait. Si je branche un des ordinateurs qui monitorent les écrans de surveillance, par éthernet, c'est aussi lent que par WIFI. J'en déduis que le problème est entre les rapberry et la borne WIFI. Mais les 4 rencontrent ce problème en même temps ??

J'ai rien ajouté, installé, enlevé.. téléchargé... rien changé à la configuration du/des systèmes. Rien.

Les pings sont lents.. parfois le temps est dépassé... ça revient à 2 ms, 300 ms.. rien de stable.

Je la comprend pas. Sortez vos idées, ça peut mener à une piste de réflection.

Merci
NIDcornifleur (Zero W RPI Cam Web, RFID, LiFePo4wered PI+)
Pi2 et Zero W RPI Cam Web sur surveillance de plusieurs nichoirs WiFi
PIZero W gérant 5 sondes DHT22 et DS18B20
PI3 sur diapo en boucle
TNC-PI (vendu)
Dongles WIFI

spourre
Raspinaute
Messages : 735
Enregistré le : lun. 22 déc. 2014 16:50
Localisation : 67380 LINGOLSHEIM

Re: Lenteur LAN WIFI seulement !

Message par spourre » ven. 28 avr. 2017 23:49

Bonsoir,

Cela fait donc déjà au moins 10 appareils connectés sur le même point d'accès WIFI (votre box).
De plus, le WIFI n'est pas "privatif" et un autre réseau proche a pu être activé sur le même canal.

Le canal étant une ressource commune, il est partagé entre tous les appareils présents sur cette même fréquence, même s'ils n'appartiennent pas au même réseau.

Vu que vous avez des smartphones, il existe des applications de monitoring du WIFI qui permettent de visualiser l'occupation de la bande WIFI et de choisir le canal le moins perturbé.

Sylvain

2RJ
Messages : 55
Enregistré le : jeu. 18 déc. 2014 14:14
Localisation : 45 20 00 N 73 20 00 W
Contact :

Re: Lenteur LAN WIFI seulement !

Message par 2RJ » sam. 29 avr. 2017 01:38

En effet, Sylvain, je monitore par le smartphone, le réseau complet (Fing)... la bande passante est adéquatement isolée, un signal excellent sur toutes les machines et rien n'a changé depuis que tout allait très bien.

Je suis branché sur le net à 300 Mgb/s et tout va bien à ce niveau. Aucun lag sur la TV qui est sur fibre direct. Le problème est entre les 4 raspberry et la borne WIFI.
Après avoir fouillé pratiquement partout, je cherche des idées comme les tiennes.

Entre-temps, je vais défaire tout le réseau de caméras un à la fois et ensuite, tout remonter un à la fois. Je m'amuse avec des RPI depuis les tout débuts et ces petites machines roulent pendant des mois et des mois sans arrêt et c'est la première fois que je rencontre ce problème particulier.

Comme si ces 4 machines auraient décidé de me faire ch... toutes en même temps. Conspiration ??? Un pouvoir insoupçonné des raspberrys :? Ici, on frôle la fiction...
NIDcornifleur (Zero W RPI Cam Web, RFID, LiFePo4wered PI+)
Pi2 et Zero W RPI Cam Web sur surveillance de plusieurs nichoirs WiFi
PIZero W gérant 5 sondes DHT22 et DS18B20
PI3 sur diapo en boucle
TNC-PI (vendu)
Dongles WIFI

guillaume9344
Raspinaute
Messages : 629
Enregistré le : mar. 6 janv. 2015 19:44
Localisation : finistere

Re: Lenteur LAN WIFI seulement !

Message par guillaume9344 » sam. 29 avr. 2017 10:18

Bonjour, si vous avez branché toutes les rpi en même temps , il est fortement probable qu'elles ont vieillie ensembles , peut être que les cartes sd sont toutes fatiguées , ou toutes pleines, on y fait pas souvent attention , mais les logs remplissent doucement celles-ci, il y a aussi la ram qui peut être pleine après un long moment d'utilisation.
@+
rpi b+ ,osmc, motioneyes
rpi 2 raspbian , server minecraft 24h/24 , utilisation gpio
orange pi pc debian ,utilisation gpio, motion cam

2RJ
Messages : 55
Enregistré le : jeu. 18 déc. 2014 14:14
Localisation : 45 20 00 N 73 20 00 W
Contact :

Re: Lenteur LAN WIFI seulement !

Message par 2RJ » sam. 29 avr. 2017 13:13

Les RPI n'ont pas été branchés en même temps, certains ont été réinitialisés, un autre a bénéficié d'une nouvelle carte microSD 32 Go grade 10 de Sandisk.

Je viens de désinstaller RPI Cam d'un des récalcitrant, refait la config. pour le minimum, tué tous les processus inutiles... et encore des pings frôlant la seconde sur Google.com.

Alors, c'est définitivement un problème de communication entre le RPI et la borne WIFI.

Merci pour vos idées.
NIDcornifleur (Zero W RPI Cam Web, RFID, LiFePo4wered PI+)
Pi2 et Zero W RPI Cam Web sur surveillance de plusieurs nichoirs WiFi
PIZero W gérant 5 sondes DHT22 et DS18B20
PI3 sur diapo en boucle
TNC-PI (vendu)
Dongles WIFI

2RJ
Messages : 55
Enregistré le : jeu. 18 déc. 2014 14:14
Localisation : 45 20 00 N 73 20 00 W
Contact :

Re: Lenteur LAN WIFI seulement ! (RÉSLU)

Message par 2RJ » lun. 1 mai 2017 02:29

Résolu en remettant les même paramètres dans le routeur pour finalement le réinitialiser. Avec WifiAnalyser, je pouvais voir un signal fantôme juxtaposant mon ssid. Ce signal interférait les échanges entre les RPI et le routeur. Bizarre... maintenant tout est ok. Sauf que, une autre bizarrerie.. je vais démarrer un autre tread.
NIDcornifleur (Zero W RPI Cam Web, RFID, LiFePo4wered PI+)
Pi2 et Zero W RPI Cam Web sur surveillance de plusieurs nichoirs WiFi
PIZero W gérant 5 sondes DHT22 et DS18B20
PI3 sur diapo en boucle
TNC-PI (vendu)
Dongles WIFI

spourre
Raspinaute
Messages : 735
Enregistré le : lun. 22 déc. 2014 16:50
Localisation : 67380 LINGOLSHEIM

Re: Lenteur LAN WIFI seulement ! (RÉSLU)

Message par spourre » lun. 1 mai 2017 11:18

2RJ a écrit :Résolu en remettant les même paramètres dans le routeur pour finalement le réinitialiser. Avec WifiAnalyser, je pouvais voir un signal fantôme juxtaposant mon ssid. Ce signal interférait les échanges entre les RPI et le routeur. Bizarre... maintenant tout est ok. Sauf que, une autre bizarrerie.. je vais démarrer un autre tread.
Un signal fantôme, ça n’existe pas (en tout cas pas dans ces conditions).
Si tu le vois dans ton logiciel de monitoring, c'est parce qu'il existe.

comme tu ne nous as pas décrit l'installation mais seulement parlé d'un point d'accès, on ne sait pas si tu utilises une box d'un FAI.
Ces box gèrent souvent un réseau WIFI pour les accès nomades et un autre pour le décodeur TV. Parfois tu peux bloquer cette fonction dans la page de configuration de la box.

Ton nouveau post ne donne pas beaucoup plus de renseignements sur l'architecture de ton réseau. Qui est le serveur DHCP ? le routeur (box ?) ou la borne d'accès WIFI ?).
Le duplication d'une adresse IP sur un réseau génère énormément de problèmes.

Si tu as 2 serveurs DHCP (le routeur + la borne WIFI), il faut que les plages d'adresses ne se recouvrent pas, tout en restant dans le même subnet.

Sylvain

maxty01
Modérateur
Messages : 729
Enregistré le : dim. 16 nov. 2014 20:53
Localisation : Charleroi - Belgique

Re: Lenteur LAN WIFI seulement !

Message par maxty01 » lun. 1 mai 2017 11:55

Bonjour,

Petite précission,

Il se peut qu'un autre Wifi ai été mis en place, mais avec un SSID caché.

Pour résoudre cela, il faut changer le canal de son propre Wifi.

Bonne journée,
Il n'y a pas de question stupide, il n'y a que des imbéciles qui ne posent pas de question !
RaspBerry Pi : 1 x B+ Raspbian 1 x RPI2 MiniBian
Mieux me connaître ? Regarder mon LinkedIn

2RJ
Messages : 55
Enregistré le : jeu. 18 déc. 2014 14:14
Localisation : 45 20 00 N 73 20 00 W
Contact :

Re: Lenteur LAN WIFI seulement !

Message par 2RJ » lun. 1 mai 2017 13:28

L'autre signal wifi (fantôme) était aussi fort... et en changeant de canal (6 à 11) il suivait. SSID caché, bien sûr.. et ici, c'est un petit hameau sans grand traffic autour.
J'ai tout éteint les 12 appareils branchés en wifi de la maison et le signal persistait. Il restait le téléphone intelligent (pour monitorer tout celà avec WiFi Analyser) et la borne WiFi.
Sauf qu'il y avait toujours ce fameux signal. qui juxtaposait mon SSID.
J'ai réinitialisé le routeur, changé et rechangé les paramètres, redémarré le tout et le signal fantôme a disparu.
Redémarré un par un tous les appareils et le signal n'est pas réapparu.
J'en déduis un problème de routeur. Il s'est démarré un signal non identifié probablement lors d'une mise à jour quelconque.. possible ? C'est la dernière chose que j'aurais pensé mais ça semble bien être le cas. J'suis pas un spécialiste dans ce domaine mais pour l'instant, c'est une évidence pour moi.
Présentement, les 4 caméras raspberry sont fonctionnels, sans latence, ainsi qu'une sur sondes et une dernière sur moniteur, Xbox et PS, deux téléphones intelligent, une tablette, deux téléviseurs et une imprimante. Accès instantané sur tout le réseau.
Merci à tous pour votre aide.

8-)
NIDcornifleur (Zero W RPI Cam Web, RFID, LiFePo4wered PI+)
Pi2 et Zero W RPI Cam Web sur surveillance de plusieurs nichoirs WiFi
PIZero W gérant 5 sondes DHT22 et DS18B20
PI3 sur diapo en boucle
TNC-PI (vendu)
Dongles WIFI

2RJ
Messages : 55
Enregistré le : jeu. 18 déc. 2014 14:14
Localisation : 45 20 00 N 73 20 00 W
Contact :

Re: Lenteur LAN WIFI seulement !

Message par 2RJ » lun. 1 mai 2017 13:46

La plage débute à 192.168.2.10


Paramètres : réseau



IO
Accueil
Adresse IP du routeur :
192
.
168
.
2
.
1
Masque de sous-réseau :
255
.
255
.
255
.
Plage d’adresses IP : Début
192
.
168
.
2
.
10
Fin
192
.
168
.
2
.
254

Bail :
03

00

00
(JJ:HH:MM)
NIDcornifleur (Zero W RPI Cam Web, RFID, LiFePo4wered PI+)
Pi2 et Zero W RPI Cam Web sur surveillance de plusieurs nichoirs WiFi
PIZero W gérant 5 sondes DHT22 et DS18B20
PI3 sur diapo en boucle
TNC-PI (vendu)
Dongles WIFI

Répondre

Retourner vers « En panne ? »