Même IP que le routeur !

Votre Apache se cache, votre Pi gémit, votre SoC fume ? La panne quoi ! C'est ici que vous trouverez sans doute une solution... Sinon du réconfort :)

Modérateurs : Francois, maxty01

Répondre
2RJ
Messages : 56
Enregistré le : jeu. 18 déc. 2014 14:14
Localisation : 45 20 00 N 73 20 00 W
Contact :

Même IP que le routeur !

Message par 2RJ » lun. 1 mai 2017 02:39

Bonjour..

En effet, un PI3 qui affiche wlan0 192.168.2.1, comme IP. Sauf que c'est le IP du routeur WIFI !

Évidemment, je peux pas entrer dans ce RPI en mode SSH ou VNC.

Si je branche un dongle WIFI USB, il affiche wlan1 192.168.2.12 et j'ai accès. Avec le câble éthernet, aucun problème...
les trois branchés ensemble:
eth0 192.168.2.135
wlan0 192.168.2.1
wlan1 192.168.2.12

Je désactive wlan0 et le wlan1 devient WLAN0 avec le IP du routeur.

Comment ça peut être possible ?
NIDcornifleur (Zero W RPI Cam Web, RFID, LiFePo4wered PI+)
Pi2 et Zero W RPI Cam Web sur surveillance de plusieurs nichoirs WiFi
PIZero W gérant 5 sondes DHT22 et DS18B20
PI3 sur diapo en boucle
TNC-PI (vendu)
Dongles WIFI

destroyedlolo
Raspinaute
Messages : 1389
Enregistré le : dim. 10 mai 2015 18:44
Localisation : Dans la campagne à côté d'Annecy
Contact :

Re: Même IP que le routeur !

Message par destroyedlolo » lun. 1 mai 2017 10:41

Salut,

Ton routeur a une IP fixe, n'est-ce pas ?
Il faut que tu l'exclue de la plage des adresses que peut délivrer ton DHCP.

Généralement, on met toutes les adresses fixes au début ou à la fin du réseau pour facilité la config du dhcp.

A+
  • BananaPI : Gentoo, disque SATA de 2 To
  • Domotique : 1-wire, TéléInfo, Tablette passée sous Gentoo, ESP8266
  • Multimedia par DNLA
  • Et pleins d'idées ... et bien sûr, pas assez de temps.
Un descriptif de ma domotique 100% fait maison.

maxty01
Modérateur
Messages : 738
Enregistré le : dim. 16 nov. 2014 20:53
Localisation : Charleroi - Belgique

Re: Même IP que le routeur !

Message par maxty01 » lun. 1 mai 2017 11:52

Bonjour,

Cela ressemble plus à une adresse fixée sur le RPI pour l'interface WLAN0.

Est-ce que tu peux nous donner le contenu du fichier /etc/network/interfaces ?

Bonne journée,
Il n'y a pas de question stupide, il n'y a que des imbéciles qui ne posent pas de question !
RaspBerry Pi : 1 x B+ Raspbian 1 x RPI2 MiniBian
Mieux me connaître ? Regarder mon LinkedIn

2RJ
Messages : 56
Enregistré le : jeu. 18 déc. 2014 14:14
Localisation : 45 20 00 N 73 20 00 W
Contact :

Re: Même IP que le routeur !

Message par 2RJ » lun. 1 mai 2017 13:43

En effet, le routeur WIFI a son adresse fixe 192.168.2.1

Voici quelques informations, dont le ifconfig et iwconfig du wlan0 (module wifi du rpi3) et wlan1 (dongle usb)


auto lo
iface lo inet loopback

iface eth0 inet manual

allow-hotplug wlan0
iface wlan0 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

allow-hotplug wlan1
iface wlan1 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf







wlan0 Link encap:Ethernet HWaddr b8:27:eb:22:10:f8
inet addr:192.168.2.1 Bcast:192.168.2.255 Mask:255.255.255.0
inet6 addr: fe80::16e3:200b:9d6e:6698/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:40684 errors:0 dropped:26249 overruns:0 frame:0
TX packets:1247 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:8648147 (8.2 MiB) TX bytes:312665 (305.3 KiB)

wlan1 Link encap:Ethernet HWaddr 00:36:76:55:3d:e0
inet addr:192.168.2.12 Bcast:192.168.2.255 Mask:255.255.255.0
inet6 addr: fe80::9805:dbbf:88aa:cc6e/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:16351 errors:0 dropped:3385 overruns:0 frame:0
TX packets:111 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2312881 (2.2 MiB) TX bytes:10965 (10.7 KiB)

iwconfig wlan0
wlan0 IEEE 802.11bgn ESSID:"BELL765"
Mode:Managed Frequency:2.462 GHz Access Point: 40:F2:01:E6:35:31
Bit Rate=72.2 Mb/s Tx-Power=31 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Power Management:on
Link Quality=70/70 Signal level=-38 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:2 Invalid misc:0 Missed beacon:0

iwconfig wlan1
wlan1 IEEE 802.11bgn ESSID:"BELL765"
Mode:Managed Frequency:2.462 GHz Access Point: 40:F2:01:E6:35:31
Bit Rate=72.2 Mb/s Tx-Power=30 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Power Management:off
Link Quality=65/70 Signal level=-45 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:33 Missed beacon:0
NIDcornifleur (Zero W RPI Cam Web, RFID, LiFePo4wered PI+)
Pi2 et Zero W RPI Cam Web sur surveillance de plusieurs nichoirs WiFi
PIZero W gérant 5 sondes DHT22 et DS18B20
PI3 sur diapo en boucle
TNC-PI (vendu)
Dongles WIFI

domi
Administrateur
Messages : 2834
Enregistré le : mer. 17 sept. 2014 18:12
Localisation : Seine et Marne

Re: Même IP que le routeur !

Message par domi » lun. 1 mai 2017 16:12

Bonjour,

Tu n'es pas en DHCP : "iface wlan0 inet manual"
Passionné de Raspberry, Arduino, ESP8266, ESP32, et objets connectés :
Spécial débutant, concevez vous-même votre domotique DIY : https://www.youtube.com/c/DomoticDIY

maxty01
Modérateur
Messages : 738
Enregistré le : dim. 16 nov. 2014 20:53
Localisation : Charleroi - Belgique

Re: Même IP que le routeur !

Message par maxty01 » lun. 1 mai 2017 17:28

domi a écrit :Bonjour,

Tu n'es pas en DHCP : "iface wlan0 inet manual"
C'est bien ce que je pensais ...

As-tu une un bureau graphique et un interface pour configurer la carte Wifi ?
Si tu es en console, le problème est ailleurs.

Bonne journée,
Il n'y a pas de question stupide, il n'y a que des imbéciles qui ne posent pas de question !
RaspBerry Pi : 1 x B+ Raspbian 1 x RPI2 MiniBian
Mieux me connaître ? Regarder mon LinkedIn

2RJ
Messages : 56
Enregistré le : jeu. 18 déc. 2014 14:14
Localisation : 45 20 00 N 73 20 00 W
Contact :

Re: Même IP que le routeur !

Message par 2RJ » mar. 2 mai 2017 03:42

J'ai changé les paramètres pour DHCP et le problème persiste. Et que ce soit en mode console ou graphique.

Maintenant, wlan0 est toujours 192.168.2.1, wlan1 est inscrit 192.168.2.140, je me connecte via SSH sur 192.168.2.12 et selon Fing, il y a un troisième IP sur ce Raspberry, soit 192.168.2.139. Il n'y a que sur 192.168.2.1 que je ne peux, évidemment, me brancher.

Y a sûrement un petit quelque chose qui m'échappe...


On a d'autres idées ?
NIDcornifleur (Zero W RPI Cam Web, RFID, LiFePo4wered PI+)
Pi2 et Zero W RPI Cam Web sur surveillance de plusieurs nichoirs WiFi
PIZero W gérant 5 sondes DHT22 et DS18B20
PI3 sur diapo en boucle
TNC-PI (vendu)
Dongles WIFI

2RJ
Messages : 56
Enregistré le : jeu. 18 déc. 2014 14:14
Localisation : 45 20 00 N 73 20 00 W
Contact :

Re: Même IP que le routeur ! RÉSOLU

Message par 2RJ » mar. 2 mai 2017 22:29

Ce matin, après avoir tout redémarré, wlan0 192.168.2.141 et wlan1 192.168.2.140 ... et si je branche le eth0, tant qu'à y être, 192.168.2.133 .

Faut dire que j'ai réinitialisé le routeur wifi, en fin de soirée, hier. Le problème venait de l'attribution des IP's ?

J'peux inscrire résolu sans connaitre la raison du problème..
NIDcornifleur (Zero W RPI Cam Web, RFID, LiFePo4wered PI+)
Pi2 et Zero W RPI Cam Web sur surveillance de plusieurs nichoirs WiFi
PIZero W gérant 5 sondes DHT22 et DS18B20
PI3 sur diapo en boucle
TNC-PI (vendu)
Dongles WIFI

Répondre

Retourner vers « En panne ? »