Impossible d'utiliser GPIO

Votre Apache se cache, votre Pi gémit, votre SoC fume ? La panne quoi ! C'est ici que vous trouverez sans doute une solution... Sinon du réconfort :)

Modérateurs : Francois, maxty01

ffdream62
Messages : 6
Enregistré le : jeu. 17 août 2017 10:38

Impossible d'utiliser GPIO

Message par ffdream62 » jeu. 17 août 2017 10:54

Bonjour

Je souhaite faire mes premiers pas avec Python et les GPIO en réalisant un petit montage/programme permettant d'allumer une LED mais rien n'y fait !

Le montage est simple :
- une connexion au GPIO17 (pin 11) du Raspi 3 B
- une resistance 100 Ohm
- une LED
- une connexion au GND (pin 6)

Le code :
*****************
import RPi.GPIO as GPIO
import time

GPIO.setmode(GPIO.BCM)
GPIO.setup(17, GPIO.OUT)

GPIO.output(17, False)
time.sleep(1)
GPIO.output(17, True)

GPIO.cleanup()
*****************
Le programme ne renvoit aucune erreur mais il ne se passe rien.

Ayant un doute sur le n° de pin VS le n° de GPIO, j'ai aussi tenté :
*****************
GPIO.setup(17, GPIO.OUT) #et adapté les autres lignes
*****************
Sans résultat.
J'ai également testé un autre port, idem, il ne se passe rien.

J'ai réalisé le programme avec Thonny Python
J'ai également testé le circuit et le breadboard avec une pile 9V, la LED s'allume normalement.
En testant le 3.3v (pin 1) et le GND (pin 6), je retrouve bien une tension le 3.3V.
Je précise ne pas avoir activé le i2C et SPI.

Je ne comprends vraiment pas ce qui coince, j'ai peur que le raspi soit HS.
Pouvez-vous m'aider à y voir plus clair ?

dyox
Raspinaute
Messages : 555
Enregistré le : dim. 28 déc. 2014 15:28
Localisation : Le long de la côte, au dessus du pays des bigoudennes, aïe

Re: Impossible d'utiliser GPIO

Message par dyox » jeu. 17 août 2017 11:23

Bonjour,

C'est normal que cela ne fonctionne pas.
Comme dans chaque script, il faut lui dire avec quel programme il va interpréter ce code, ici il faut lui dire python. Je vous laisse cherche, ce n'est pas difficile ;)
Débutant sous RPi / linux

:arrow: :arrow: :arrow: [Pour bien commencer] Pour les nouveaux acquéreurs de Raspberry Pi (liste de liens utiles)

ffdream62
Messages : 6
Enregistré le : jeu. 17 août 2017 10:38

Re: Impossible d'utiliser GPIO

Message par ffdream62 » jeu. 17 août 2017 12:31

Bonjour Dyox et merci pour ta réponse rapide.

Je suis désolé mais je ne parviens pas à me débloquer.

Sous Thonny IDE, je ne trouve pas la synthaxe manquante.

J'ai lancé le programme sous le terminal de Raspbian avec la commande "python test.py".
Le programme se lance mais les GPIO ne réagissent pas.

Peux-tu m'en dire un peu plus ?

guillaume9344
Raspinaute
Messages : 629
Enregistré le : mar. 6 janv. 2015 19:44
Localisation : finistere

Re: Impossible d'utiliser GPIO

Message par guillaume9344 » jeu. 17 août 2017 12:40

Bonjour, comment connectez-vous votre led ? Entre la pin et la masse ? Dans ce cas, ne vaudrait-il pas mieux mètres en premier la sortie à 1(gpio true) attendre 1s puis là sortie à 0 (gpio false).?
rpi b+ ,osmc, motioneyes
rpi 2 raspbian , server minecraft 24h/24 , utilisation gpio
orange pi pc debian ,utilisation gpio, motion cam

dyox
Raspinaute
Messages : 555
Enregistré le : dim. 28 déc. 2014 15:28
Localisation : Le long de la côte, au dessus du pays des bigoudennes, aïe

Re: Impossible d'utiliser GPIO

Message par dyox » jeu. 17 août 2017 12:45

Peux-tu m'en dire un peu plus ?
oui, il faut rajouter au tout début du script :

Code : Tout sélectionner

#!/usr/bin/python

import RPi.GPIO as GPIO
import time

GPIO.setmode(GPIO.BCM)
GPIO.setup(17, GPIO.OUT)

GPIO.output(17, False)
time.sleep(1)
GPIO.output(17, True)

GPIO.cleanup()
Pour info, The MagPi parle de plus en plus de gpiozero quand il évoque python. Apparemment, c'est plus simple.
Modifié en dernier par dyox le jeu. 17 août 2017 12:46, modifié 1 fois.
Débutant sous RPi / linux

:arrow: :arrow: :arrow: [Pour bien commencer] Pour les nouveaux acquéreurs de Raspberry Pi (liste de liens utiles)

dyox
Raspinaute
Messages : 555
Enregistré le : dim. 28 déc. 2014 15:28
Localisation : Le long de la côte, au dessus du pays des bigoudennes, aïe

Re: Impossible d'utiliser GPIO

Message par dyox » jeu. 17 août 2017 12:45

essayez cette commande :
python ./test.py
Débutant sous RPi / linux

:arrow: :arrow: :arrow: [Pour bien commencer] Pour les nouveaux acquéreurs de Raspberry Pi (liste de liens utiles)

ffdream62
Messages : 6
Enregistré le : jeu. 17 août 2017 10:38

Re: Impossible d'utiliser GPIO

Message par ffdream62 » jeu. 17 août 2017 15:38

@Guillaume9344
C'est une erreur dans mon post, j'ai bien codé True/False, désolé.

@Dyox
Merci ! Je teste ça ce soir et redonnerai confirmation.

ffdream62
Messages : 6
Enregistré le : jeu. 17 août 2017 10:38

Re: Impossible d'utiliser GPIO

Message par ffdream62 » jeu. 17 août 2017 20:29

Merci Dyox, c'était bien la déclaration qui manquait !

J'ai un autre petit problème en parallèle.
J'ai acheté une carte en T pour avoir un peu plus de visibilité sur le breadboard mais celle-ci ne fonctionne pas en utilisant le même programme.
Ayant un doute sur le sens de la nappe, j'ai testé les 3,3V et 5V et c'est OK.

Pouvez-vous me venir en aide ?

La carte est celle-ci :
[url]https://www.amazon.fr/gp/product/B01LXZ ... UTF8&psc=1[/url]

Merci d'avance

dyox
Raspinaute
Messages : 555
Enregistré le : dim. 28 déc. 2014 15:28
Localisation : Le long de la côte, au dessus du pays des bigoudennes, aïe

Re: Impossible d'utiliser GPIO

Message par dyox » jeu. 17 août 2017 20:49

Non pas trop !
En partant du principe que vous sachiez vous servir d'une breadboard, je ne vois que tester les fil et les soudures/piste du T :?:
Débutant sous RPi / linux

:arrow: :arrow: :arrow: [Pour bien commencer] Pour les nouveaux acquéreurs de Raspberry Pi (liste de liens utiles)

ffdream62
Messages : 6
Enregistré le : jeu. 17 août 2017 10:38

Re: Impossible d'utiliser GPIO

Message par ffdream62 » jeu. 17 août 2017 20:56

Oui pas de problème avec le breadboard, je vais tester tout ca donc.
Merci

Répondre

Retourner vers « En panne ? »